X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Since upgrading to the “Quantum” version I have been unable to play any online videos. I installed the “HTML5” player, but I am still unable to play any online

Kuphostiwe

Since upgrading to the “Quantum” version I have been unable to play any online videos. I installed the “HTML5” player, but I am still unable to play any online videos. Can someone please help me with this issue?

Since upgrading to the “Quantum” version I have been unable to play any online videos. I installed the “HTML5” player, but I am still unable to play any online videos. Can someone please help me with this issue?

Isisombululo esikhethiwe

Hi jscher2000, - GREAT NEWS! I was informed online on Friday that my “Java” app. was not up to date, & accordingly, I was invited to update it. Imagine my delight after updating the app. to find that all of the media players were functioning normally! Again, many thanks for your help with this issue. Kind regards, Seymour.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 27.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Hi Seymour, sorry to hear about this problem. Most sites use code that triggers Firefox's built-in HTML5 player, you should not need an add-on and to be honest, I don't know what such an add-on would do. ???

Could you start by checking YouTube's diagnostic page here to see whether you have at least 5 blue boxes:

https://www.youtube.com/html5

Also, please see this article as the next step:

Fix video and audio playback problems on Firefox for Windows

Hi Seymour, sorry to hear about this problem. Most sites use code that triggers Firefox's built-in HTML5 player, you should not need an add-on and to be honest, I don't know what such an add-on would do. ??? Could you start by checking YouTube's diagnostic page here to see whether you have at least 5 blue boxes: https://www.youtube.com/html5 Also, please see this article as the next step: [[Fix video and audio playback problems on Firefox for Windows]]

Umnikazi wombuzo

Hi jscher2000, I have got 5 ticked boxes. When I started to investigate using the links I was getting only 3 ticked boxes. I tried out the links that you sent without any success. Attached please find 9 screenshots which hopefully, will be of help in getting the issue resolved. Many thanks for your assistance, Seymour. P.S:- My apologies to you in not replying to you sooner, as I had some problems getting the screenshots uploaded.

Hi jscher2000, I have got 5 ticked boxes. When I started to investigate using the links I was getting only 3 ticked boxes. I tried out the links that you sent without any success. Attached please find 9 screenshots which hopefully, will be of help in getting the issue resolved. Many thanks for your assistance, Seymour. P.S:- My apologies to you in not replying to you sooner, as I had some problems getting the screenshots uploaded.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Hi Seymour, based on your YouTube check, your Firefox should be able to play the most common kinds of videos served through YouTube and other sites that use the built-in HTML5 player.

What happens when try to play a video? Do you get a specific error message you could copy/paste into a reply? Or do you have missing controls or incorrect controls (for example, a pause button when video is not playing)?

Some issues with controls can be caused by setting Firefox not to autoplay videos when you load a page. To check that setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

(3) If the media.autoplay.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

If you changed that, any improvement?

Hi Seymour, based on your YouTube check, your Firefox should be able to play the most common kinds of videos served through YouTube and other sites that use the built-in HTML5 player. What happens when try to play a video? Do you get a specific error message you could copy/paste into a reply? Or do you have missing controls or incorrect controls (for example, a pause button when video is not playing)? Some issues with controls can be caused by setting Firefox not to autoplay videos when you load a page. To check that setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered (3) If the '''media.autoplay.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true If you changed that, any improvement?

Umnikazi wombuzo

Hi jscher2000, Attached please find 4 screenshots. The “4OD” channel is playing normally. Would you please let me know the website address that you are using to access “about:config”, as I am not getting any of the 3 instructions below, in any of the websites that I have visited. Many thanks again, Seymour.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste autop and pause while the list is filtered (3) If the media.autoplay.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true.

Hi jscher2000, Attached please find 4 screenshots. The “4OD” channel is playing normally. Would you please let me know the website address that you are using to access “about:config”, as I am not getting any of the 3 instructions below, in any of the websites that I have visited. Many thanks again, Seymour. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste autop and pause while the list is filtered (3) If the media.autoplay.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Hi Seymour, about:config is an internal page and its entire address is about:config (no http at the beginning). Make sure you use a colon (:) and not a period (.) between about and config or Firefox will try to find the page on the web.

Hi Seymour, about:config is an internal page and its entire address is '''about:config''' (no http at the beginning). Make sure you use a colon (:) and not a period (.) between about and config or Firefox will try to find the page on the web.

Umnikazi wombuzo

Hi jscher2000, Attached please find a sequence of 3 screenshots in regard to “autop” programme. Hopefully, they will be of use to you. Many thanks again, Seymour.

Hi jscher2000, Attached please find a sequence of 3 screenshots in regard to “autop” programme. Hopefully, they will be of use to you. Many thanks again, Seymour.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Is the final setting the default value of true?

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Is the final setting the default value of true? Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Umnikazi wombuzo

Hi jscher2000, Final setting is the default value of true. In "Safe Mode" all player channels are functioning normally, - apart from Channel 4 player, which is requiring Adobe Flash Player, but Channel 4 player is functioning alright in "Normal Mode". So yes, - much improvement. Many thanks, Seymour.

Hi jscher2000, Final setting is the default value of true. In "Safe Mode" all player channels are functioning normally, - apart from Channel 4 player, which is requiring Adobe Flash Player, but Channel 4 player is functioning alright in "Normal Mode". So yes, - much improvement. Many thanks, Seymour.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Thank you for testing. As I mentioned, one of the effects of Firefox's Safe Mode is to disable extensions. If you have any extensions that relate to videos or content blocking (e.g., ads that sometimes play at the beginning of videos), you might want to try adjusting their settings or disabling them to see whether they are the source of the problem.

Regarding Flash, could you check this article: Why do I have to click to activate plugins?

Thank you for testing. As I mentioned, one of the effects of Firefox's Safe Mode is to disable extensions. If you have any extensions that relate to videos or content blocking (e.g., ads that sometimes play at the beginning of videos), you might want to try adjusting their settings or disabling them to see whether they are the source of the problem. Regarding Flash, could you check this article: [[Why do I have to click to activate plugins?]]
Zombieslayer57 0 izisombululo 34 izimpendulo
Kuphostiwe

try going to options, general, then scroll to performance and deselect "Use recommended performance settings", then deselect "Use hardware acceleration when available". Hope this helps! -Zombieslayer57

try going to options, general, then scroll to performance and deselect "Use recommended performance settings", then deselect "Use hardware acceleration when available". Hope this helps! -Zombieslayer57

Umnikazi wombuzo

Hi jscher2000, The only video player that I have installed which might qualify for this is “Utorrent”. What would you recommend? Thanks again, Seymour.

Hi jscher2000, The only video player that I have installed which might qualify for this is “Utorrent”. What would you recommend? Thanks again, Seymour.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Hi Seymour, does uTorrent install into Firefox? I'm not sure how it might interact with videos in Firefox. If you see it on the Add-ons page, try disabling it to see what effect that has.

Hi Seymour, does uTorrent install into Firefox? I'm not sure how it might interact with videos in Firefox. If you see it on the Add-ons page, try disabling it to see what effect that has.

Umnikazi wombuzo

Hi jscher2000, “Utorrent” is not on the "Add-ons" page. Is there a diagnostic tool which would help to identify the source of the problem? Thanks again, Seymour.

Hi jscher2000, “Utorrent” is not on the "Add-ons" page. Is there a diagnostic tool which would help to identify the source of the problem? Thanks again, Seymour.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Hi Seymour, unfortunately, the only way to found out if an add-on is causing the problem is to disable it and see whether the problem goes away. Unless someone already know what is causing it.

Hi Seymour, unfortunately, the only way to found out if an add-on is causing the problem is to disable it and see whether the problem goes away. Unless someone already know what is causing it.

Umnikazi wombuzo

Hi jscher2000, When I move the cursor along the time line in the BBC Iplayer, a changing picture of the video is displayed. – Please see attached screenshot. Could this be of use to you in your research? Also, please find attached screenshots of “Extensions” & “plugins” screens. – Anything suspicious here? Kind regards, Seymour.

Hi jscher2000, When I move the cursor along the time line in the BBC Iplayer, a changing picture of the video is displayed. – Please see attached screenshot. Could this be of use to you in your research? Also, please find attached screenshots of “Extensions” & “plugins” screens. – Anything suspicious here? Kind regards, Seymour.

Okulungisiwe ngu Seymour

Umnikazi wombuzo

Hi jscher2000, When I move the cursor along the time line in the BBC Iplayer, a changing picture of the video is displayed. – Please see attached screenshot. Could this be of use to you in your research? Also, please find attached screenshots of “Extensions” & “Plugins” screens. – Anything suspicious here? Kind regards, Seymour.

Hi jscher2000, When I move the cursor along the time line in the BBC Iplayer, a changing picture of the video is displayed. – Please see attached screenshot. Could this be of use to you in your research? Also, please find attached screenshots of “Extensions” & “Plugins” screens. – Anything suspicious here? Kind regards, Seymour.

Umnikazi wombuzo

Hi jscher2000, Have you managed to progress any further with the issue? Kind regards, Seymour.

Hi jscher2000, Have you managed to progress any further with the issue? Kind regards, Seymour.
cor-el
  • Top 10 Contributor
  • Moderator
17407 izisombululo 157253 izimpendulo
Kuphostiwe

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

  • "3-bar" menu button or Tools -> Web Developer
You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en/Tools/Web_Console

Okulungisiwe ngu cor-el

Isisombululo Esikhethiwe

Hi jscher2000, - GREAT NEWS! I was informed online on Friday that my “Java” app. was not up to date, & accordingly, I was invited to update it. Imagine my delight after updating the app. to find that all of the media players were functioning normally! Again, many thanks for your help with this issue. Kind regards, Seymour.

Hi jscher2000, - GREAT NEWS! I was informed online on Friday that my “Java” app. was not up to date, & accordingly, I was invited to update it. Imagine my delight after updating the app. to find that all of the media players were functioning normally! Again, many thanks for your help with this issue. Kind regards, Seymour.
cor-el
  • Top 10 Contributor
  • Moderator
17407 izisombululo 157253 izimpendulo
Kuphostiwe

Can you post a screenshot of that alert or post a link to that web page?

What “Java” app is this about?

Firefox 57 only supports the Shockwave Flash plugin and no other plugin like Java. If this was really about Java and not about JavaScript and you installed something from a web page then you may have gotten infected by malware.

If you get a pop-up message asking to update Firefox or plugins or scanning for malware then such a message is likely a scam and you should NEVER respond to such an alert to avoid getting infected with malware.

  • only update Firefox via "Help -> About" or by downloading and installing Firefox from the Mozilla server and never via a pop-up or link on a web page.
  • plugins should only be updated via the plugin itself or by visiting the home page of the plugin.

See also:

Can you post a screenshot of that alert or post a link to that web page? What “Java” app is this about? Firefox 57 only supports the Shockwave Flash plugin and no other plugin like Java. If this was really about Java and not about JavaScript and you installed something from a web page then you may have gotten infected by malware. If you get a pop-up message asking to update Firefox or plugins or scanning for malware then such a message is likely a scam and you should NEVER respond to such an alert to avoid getting infected with malware. *only update Firefox via "Help -> About" or by downloading and installing Firefox from the Mozilla server and never via a pop-up or link on a web page. *plugins should only be updated via the plugin itself or by visiting the home page of the plugin. See also: *https://support.mozilla.org/en-US/kb/i-found-fake-firefox-update *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware