Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Since you updated my firefox a couple of days ago it is running slower and crashing. Why do companies feel it is necessary to fix something that wasn't broken?

  • 3 uphendule
  • 2 zinale nkinga
  • 18 views
  • Igcine ukuphendulwa ngu cor-el

more options

My computer is running much slower and it is like I have dial up all over again when trying to open websites. I spent at least 10 minutes trying to shut down the computer.

All Replies (3)

more options

Hi there,

I'm sorry to hear that you're running into issue using Firefox. There are a couple of things you can try to solve the problem:

1. Running Firefox in Safe Mode: https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode - the safest and fastest way to see if the issue is caused any changes to Firefox settings 2. Refreshing Firefox: https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings - the best way to make Firefox use its default settings without having to uninstall and reinstall it

Please note that if your computer is infected with malware, you may be experiencing issues regardless of the above solutions working or not. I would also recommend scanning your computer for malware using the built-in Windows Defender software - or any other respectable virus scanning software of your choice.

I hope this helps.

more options

I tried refreshing-didn't work. I tried the safe mode-didn't work.

Right now I have to reload pages multiple times before they show up. Same with deleting pages-slow to delete & takes several attempts before deleting.

Since "upgrading" to Quantum it's slower than AOL dial-up and I'm really fed up with the error page appearing all the time and that little back & forth dot while loading is incredibly annoying.

How can I get rid of Quantum? I am running OS X version 10.11.6.

more options

Try to disable accessibility services in Firefox.