X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 57 minimizes constantly since tonight's Windows Update.

Kuphostiwe

Two days ago Firefox upgraded itself to 57 (Quantum). It worked fine, although without some add-ons that I depend on, and with a difficult-to-read color scheme. Tonight Windows updated itself and Firefox stopped working. The window minimized itself through a series of sequentially smaller windows until it was apparently just a few pixels wide and high. When I try to re-open Firefox I can OCASIONALLY get it to open a very small window and tried restoring it to its default state, but that didn't improve anything.

I'm running a Dell XPS 8700.

If you have any suggestions I'd like to hear them. I've been using Firefox for more than 10 years and I really like it, but this "upgrade" has been a fiasco for me. I'm currently using Edge, and I've downloaded Chrome which right now looks like my new browser.

Two days ago Firefox upgraded itself to 57 (Quantum). It worked fine, although without some add-ons that I depend on, and with a difficult-to-read color scheme. Tonight Windows updated itself and Firefox stopped working. The window minimized itself through a series of sequentially smaller windows until it was apparently just a few pixels wide and high. When I try to re-open Firefox I can OCASIONALLY get it to open a very small window and tried restoring it to its default state, but that didn't improve anything. I'm running a Dell XPS 8700. If you have any suggestions I'd like to hear them. I've been using Firefox for more than 10 years and I really like it, but this "upgrade" has been a fiasco for me. I'm currently using Edge, and I've downloaded Chrome which right now looks like my new browser.

Isisombululo esikhethiwe

Thanks, Philipp.

Here's what I've done and where I stand right now.

Last night I checked for any newer video drivers -- I have the latest. I did a search for new Windows updates -- there were some, and I'm now at Windows 10 Version 1709. I tried Firefox again, but no luck.

I got your reply overnight.

When I turned on my computer this afternoon I started Firefox up normally -- it had the same problem of starting in a tiny window and disappearing as soon as I tried to do anything.

Next, I started Firefox in Safe Mode. Firefox opened in a tiny window and I dragged the borders to get to a workable size. I then opened a new tab and Firefox remained open -- this *always* closed it before. I then checked my add-ons. I have two "new" add-ons that I installed after the upgrade to FF57 -- Video DownloadHelper and YouTube Video And Audio Downloader (Dev. Edt.). They showed "Disabled" of course. I manually disabled them and shut down Firefox.

I then started Firefox normally. It opened in a tiny window. I dragged the borders to get a workable window and opened a new tab. This time it worked and Firefox did not disappear. I opened some sites, checked some of my bookmarks, etc., and all went well. I then went back to the Add-ons Manager and Enabled the two add-ons. Firefox continued working normally.

I then shut down Firefox and re-opened it. Firefox opened normally to the workable size I'd previously used.

At this point Firefox appears to be working normally. I'd have a bit more confidence in it if I knew what went wrong and how it got fixed, but this was an especially bad time to lose Firefox and I'm grateful to have it back.

Please let me know if there is anything else you need from me.

I'll post again if something goes wrong.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

Let's start with this;

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox.

Let's start with this; https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' file. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ---------------- Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Umnikazi wombuzo

The first proposed solution didn't help. The file xulstore.json on my computer is located in a different location -- I'm on Windows 10:

<user>\AppData\Mozilla\Firefox\Roaming\Mozilla\Firefox\Profiles\STRING.default\

I couldn't find Localstore.rdf in that directory.

Renaming xulstore.json didn't help. A new file was created in its place when I attempted to run Firefox, so I deleted the renamed file.

The first proposed solution didn't help. The file xulstore.json on my computer is located in a different location -- I'm on Windows 10: <user>\AppData\Mozilla\Firefox\Roaming\Mozilla\Firefox\Profiles\STRING.default\ I couldn't find Localstore.rdf in that directory. Renaming xulstore.json didn't help. A new file was created in its place when I attempted to run Firefox, so I deleted the renamed file.

Umnikazi wombuzo

Thanks for your help. I don't have time to try a Safe Mode restart -- I'll try that as soon as I can.

Thanks for your help. I don't have time to try a Safe Mode restart -- I'll try that as soon as I can.

Umnikazi wombuzo

Tried starting in Safe Mode with Networking -- I have the exact same problem.

I don't know if this is significant, but I'm using an NVidia GT 750 video card. I had turned off hardware acceleration in Firefox's preferences because I was getting random black-outs on my browser tabs.

Tried starting in Safe Mode with Networking -- I have the exact same problem. I don't know if this is significant, but I'm using an NVidia GT 750 video card. I had turned off hardware acceleration in Firefox's preferences because I was getting random black-outs on my browser tabs.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

I called for more help.

cromag said

but I'm using an NVidia GT 750 video card.

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

I called for more help. ''cromag [[#answer-1034599|said]]'' <blockquote> but I'm using an NVidia GT 750 video card. </blockquote> See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
philipp
  • Top 25 Contributor
  • Moderator
5315 izisombululo 23463 izimpendulo
Kuphostiwe

Impendulo Ewusizo

can you get firefox to launch in firefox safemode and stay on screen by pressing the shift key while it's starting?

can you get firefox to launch in firefox safemode and stay on screen by pressing the shift key while it's starting?

Isisombululo Esikhethiwe

Thanks, Philipp.

Here's what I've done and where I stand right now.

Last night I checked for any newer video drivers -- I have the latest. I did a search for new Windows updates -- there were some, and I'm now at Windows 10 Version 1709. I tried Firefox again, but no luck.

I got your reply overnight.

When I turned on my computer this afternoon I started Firefox up normally -- it had the same problem of starting in a tiny window and disappearing as soon as I tried to do anything.

Next, I started Firefox in Safe Mode. Firefox opened in a tiny window and I dragged the borders to get to a workable size. I then opened a new tab and Firefox remained open -- this *always* closed it before. I then checked my add-ons. I have two "new" add-ons that I installed after the upgrade to FF57 -- Video DownloadHelper and YouTube Video And Audio Downloader (Dev. Edt.). They showed "Disabled" of course. I manually disabled them and shut down Firefox.

I then started Firefox normally. It opened in a tiny window. I dragged the borders to get a workable window and opened a new tab. This time it worked and Firefox did not disappear. I opened some sites, checked some of my bookmarks, etc., and all went well. I then went back to the Add-ons Manager and Enabled the two add-ons. Firefox continued working normally.

I then shut down Firefox and re-opened it. Firefox opened normally to the workable size I'd previously used.

At this point Firefox appears to be working normally. I'd have a bit more confidence in it if I knew what went wrong and how it got fixed, but this was an especially bad time to lose Firefox and I'm grateful to have it back.

Please let me know if there is anything else you need from me.

I'll post again if something goes wrong.

Thanks, Philipp. Here's what I've done and where I stand right now. Last night I checked for any newer video drivers -- I have the latest. I did a search for new Windows updates -- there were some, and I'm now at Windows 10 Version 1709. I tried Firefox again, but no luck. I got your reply overnight. When I turned on my computer this afternoon I started Firefox up normally -- it had the same problem of starting in a tiny window and disappearing as soon as I tried to do anything. Next, I started Firefox in Safe Mode. Firefox opened in a tiny window and I dragged the borders to get to a workable size. I then opened a new tab and Firefox remained open -- this *always* closed it before. I then checked my add-ons. I have two "new" add-ons that I installed after the upgrade to FF57 -- Video DownloadHelper and YouTube Video And Audio Downloader (Dev. Edt.). They showed "Disabled" of course. I manually disabled them and shut down Firefox. I then started Firefox normally. It opened in a tiny window. I dragged the borders to get a workable window and opened a new tab. This time it worked and Firefox did not disappear. I opened some sites, checked some of my bookmarks, etc., and all went well. I then went back to the Add-ons Manager and Enabled the two add-ons. Firefox continued working normally. I then shut down Firefox and re-opened it. Firefox opened normally to the workable size I'd previously used. At this point Firefox appears to be working normally. I'd have a bit more confidence in it if I knew what went wrong and how it got fixed, but this was an especially bad time to lose Firefox and I'm grateful to have it back. Please let me know if there is anything else you need from me. I'll post again if something goes wrong.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

Impendulo Ewusizo

It might be a corrupt file was overwritten.

That was very good work. Well done.

It might be a corrupt file was overwritten. That was very good work. Well done.

Umnikazi wombuzo

One (hopefully) last problem. While trying to fix this problem I made Chrome my default browser in Windows. Now that Firefox is working again, I tried to make Firefox my default browser again. But when I get to the Default Apps page in Windows Settings and click on Web Browser it doesn't give Firefox as an option. I can choose Microsoft Edge, Avast SafeZone Browser, Google Chrome, Internet Explorer, or "Look for an App in the Store." (I couldn't find Firefox in the Store.)

I tried a simple re-install of Firefox (without uninstalling everything) but that didn't help.

Any ideas? (Thanks!)

One (hopefully) last problem. While trying to fix this problem I made Chrome my default browser in Windows. Now that Firefox is working again, I tried to make Firefox my default browser again. But when I get to the Default Apps page in Windows Settings and click on Web Browser it doesn't give Firefox as an option. I can choose Microsoft Edge, Avast SafeZone Browser, Google Chrome, Internet Explorer, or "Look for an App in the Store." (I couldn't find Firefox in the Store.) I tried a simple re-install of Firefox (without uninstalling everything) but that didn't help. Any ideas? (Thanks!)
FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe
https://www.bing.com/search?q=change+default+browser+windows+10&pc=MOZI&form=MOZSBR
philipp
  • Top 25 Contributor
  • Moderator
5315 izisombululo 23463 izimpendulo
Kuphostiwe

cromag, if firefox isn't showing up in the list of suggested webbrowser scroll further down to "set default settings per app", select firefox in that list, go to manage and set is as default for all the available file formats & protocols.

cromag, if firefox isn't showing up in the list of suggested webbrowser scroll further down to "set default settings per app", select firefox in that list, go to manage and set is as default for all the available file formats & protocols.

Umnikazi wombuzo

Thanks, guys!

Thanks, guys!
FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.