X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"Add security exception" dialog box kept on increasing in size on pressing "Enter" button on keyboard and now is out of my screen limits. This looks to be a bug

Kuphostiwe

User gets a dialogue box to add security exception when there is a certificate error upon accessing a https web site. The "Add security exception" dialog box that pops up, keeps on increasing in size upon pressing "Enter" button on keyboard. In my PC Its now out of my screen limits, I can not see anything due to the extremely stretched dialogue box. This looks to be a bug in FireFox. Attached image showing the problem.

User gets a dialogue box to add security exception when there is a certificate error upon accessing a https web site. The "Add security exception" dialog box that pops up, keeps on increasing in size upon pressing "Enter" button on keyboard. In my PC Its now out of my screen limits, I can not see anything due to the extremely stretched dialogue box. This looks to be a bug in FireFox. Attached image showing the problem.

Okulungisiwe ngu Charan1

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Eminye Imininingwane

Mkll 314 izisombululo 1978 izimpendulo
Kuphostiwe

Hello, sorry to see you are having this issue. Try right clicking and closing this dialogue box or try to make it small again by double clicking the box or it's borders. Hope this helps!

Hello, sorry to see you are having this issue. Try right clicking and closing this dialogue box or try to make it small again by double clicking the box or it's borders. Hope this helps!

Umnikazi wombuzo

Hi, Thanks for getting back so quick. I tried, but the resizing of dialogue box doesn't work. Apart from the "Escape" button (to exit the dialogue box) nothing works.

Hi, Thanks for getting back so quick. I tried, but the resizing of dialogue box doesn't work. Apart from the "Escape" button (to exit the dialogue box) nothing works.
Mkll 314 izisombululo 1978 izimpendulo
Kuphostiwe

Terminate the Firefox process, and try again -- this time click on the prompt instead of clicking Enter.

Terminate the Firefox process, and try again -- this time click on the prompt instead of clicking Enter.

Umnikazi wombuzo

To add more to this problem description, I see that the issue persists even after a system reboot.

To add more to this problem description, I see that the issue persists even after a system reboot.
Mkll 314 izisombululo 1978 izimpendulo
Kuphostiwe

Make sure your DPi settings are correct on your computer! This can be an issue too.

Make sure your DPi settings are correct on your computer! This can be an issue too.

Umnikazi wombuzo

Pressing "Enter" button on the "Add Security Exception" dialogue box what caused the the issue, I doubt its related to DPi settings. Because if it was, there must be similar issues with other apps too. Whereas I don't see similar issue with the other apps on my machine. May be its some bug in firefox, Can you please check.

Pressing "Enter" button on the "Add Security Exception" dialogue box what caused the the issue, I doubt its related to DPi settings. Because if it was, there must be similar issues with other apps too. Whereas I don't see similar issue with the other apps on my machine. May be its some bug in firefox, Can you please check.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Please consider turning on send info to Mozilla before posting a question. This helps us help you.

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

Reinstall Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/ Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

Please consider turning on send info to Mozilla before posting a question. This helps us help you. Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. Reinstall Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/ Note : Legacy Extensions will be disabled and or removed. Please let us know if this solved your issue or if need further assistance.

Umnikazi wombuzo

I believe you are referring to below option in the settings: == "Allow Firefox to automatically send technical and interaction data to Mozilla" == This has always been turned on in my firefox.

Will try updating firefox. Thanks.

I believe you are referring to below option in the settings: == "Allow Firefox to automatically send technical and interaction data to Mozilla" == This has always been turned on in my firefox. Will try updating firefox. Thanks.

Umnikazi wombuzo

By the way, I had been using Firefox 56.0.2 (64 bit) version.

By the way, I had been using Firefox 56.0.2 (64 bit) version.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Charan1 said

I believe you are referring to below option in the settings: == "Allow Firefox to automatically send technical and interaction data to Mozilla" == This has always been turned on in my firefox. Will try updating firefox. Thanks.

No data came, usually means is turned off. Usually also get Flash version but not this time.

Sorry yes you had 56...

BEFORE UPDATING You need to go through your list of Extensions 1 by 1 and google them and find the Firefox Extension page for each and look to see if they are Firefox Version 57 compatible. Note : Legacy Extensions will be disabled and or removed when it updates soon, hours or days.

Can use google search terms : Firefox Extension <old extension name> Comparable

''Charan1 [[#answer-1027676|said]]'' <blockquote> I believe you are referring to below option in the settings: == "Allow Firefox to automatically send technical and interaction data to Mozilla" == This has always been turned on in my firefox. Will try updating firefox. Thanks. </blockquote> No data came, usually means is turned off. Usually also get Flash version but not this time. Sorry yes you had 56... BEFORE UPDATING You need to go through your list of Extensions 1 by 1 and google them and find the Firefox Extension page for each and look to see if they are Firefox Version 57 compatible. Note : Legacy Extensions will be disabled and or removed when it updates soon, hours or days. Can use google search terms : Firefox Extension <old extension name> Comparable
bustr4 0 izisombululo 3 izimpendulo
Kuphostiwe

I have tried all of these solutions for waterfox (firefox is too slow and locks up too much) and none of them work. Also the "add exception" button rarely appears and when I try to do by going through options I get the problem described in this thread. I have also tried putting "chrome://pippki/content/exceptionDialog.xul" in the dialog box. All it does is enlarge the browser so that the bottom of the page is obscured. My IT guy says the problem is not on their end. The company uses Symantec for protection. Chrome and IE open webpages just fine.

I have tried all of these solutions for waterfox (firefox is too slow and locks up too much) and none of them work. Also the "add exception" button rarely appears and when I try to do by going through options I get the problem described in this thread. I have also tried putting "chrome://pippki/content/exceptionDialog.xul" in the dialog box. All it does is enlarge the browser so that the bottom of the page is obscured. My IT guy says the problem is not on their end. The company uses Symantec for protection. Chrome and IE open webpages just fine.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71663 izimpendulo
Kuphostiwe

Impendulo Ewusizo

If you use an ultra-high resolution display, and especially if you have two displays with very different resolutions, this could be a bug with how Firefox sizes dialogs in that situation. But otherwise:

Sometimes the settings file that stores window and dialog dimensions becomes corrupted with nonsensical values. You can rename the file to restore the defaults. (Or use the Refresh feature if you don't like messing with files...)

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. (On Mac, it's "Show in Finder" and opens Finder.)

Leaving that window open, switch back to Firefox and Exit/Quit, either:

  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit, or Firefox > Quit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Do windows and dialogs display at normal sizes again?

That mini-reset will hide the menu bar and bookmarks toolbar, so if you want those back:

You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Show/Hide Toolbars (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

If you use an ultra-high resolution display, and especially if you have two displays with very different resolutions, this could be a bug with how Firefox sizes dialogs in that situation. But otherwise: Sometimes the settings file that stores window and dialog dimensions becomes corrupted with nonsensical values. You can rename the file to restore the defaults. (Or use the Refresh feature if you don't like messing with files...) Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. (On Mac, it's "Show in Finder" and opens Finder.) Leaving that window open, switch back to Firefox and Exit/Quit, either: * "3-bar" menu button > Exit/Quit * (menu bar) File > Exit, or Firefox > Quit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like xulstoreOLD.json. If you see a file named localstore.rdf, rename that one to localstore.old. Start Firefox back up again. Do windows and dialogs display at normal sizes again? ''That mini-reset will hide the menu bar and bookmarks toolbar, so if you want those back:'' You can use one of these methods to show the toolbar list and select the desired bars there: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.
bustr4 0 izisombululo 3 izimpendulo
Kuphostiwe

Thanks. That fixed the size of the popup.

Thanks. That fixed the size of the popup.