Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Allow me to move the toolbars in Quantum

  • 25 uphendule
  • 448 zinale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu TeknoXI

more options

On the new Firefox Quantum it appears the positions of the toolbars is fixed and the extension that used to allow this to change don't work. Particularly, the tabs are on top which is just hideously awful. I'm sure someone, somewhere likes it, but why are we all being forced to work in a specific way? Have you been brainwashed by Apple of Microsoft? Just look at how many people used the "Classic Theme Restorer" or "Tabs on Bottom" extensions to see how many people despise this awful layout you've imposed on us.

Please, fix this urgently and let users decide how their screen should be laid out, rather than imposing your will on us - especially since this is a cross platform browser so needs that level of flexibility.

Quantum seems to work great, but the ethos underpinning this design ("Work my way or not at all") it terrible and is a great way of alienating people.

Isisombululo esikhethiwe

userChrome.css modifications continue to work fine with firefox quantum. the author of classic theme restorer has also made a bunch of them available at https://github.com/Aris-t2/CustomCSSforFx

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (5)

more options

alancsalt said

This is the actual code: copy and paste it. It works for me. If it doesn't for you, I don't know why not. #TabsToolbar { -moz-box-ordinal-group: 2; } #nav-bar{ border-top-width: 0px !important; }

Re-reading your original instructions, I now see why it didn't work . You say the following:

"Press Windows button and R on keyboard Type %appdata% Click OK Find: Roaming>Mozilla>Firefox>Profiles>(alphanumeric mix).default>chrome chrome folder may need to be created.

Open notepad Type in the text in the image: (I tried putting the raw text here, but it changed on saving)


In the save, set to "all files" Save somewhere as userChrome.css Cut and paste it into that chrome folder Restart Firefox. Tabs should now be on bottom."

and I've just noticed the penultimate line "Restart Firefox", however, nowhere do you say "Close Firefox"

more options

I was able to get "Tabs on Bottom" using this fix. However, I run across a problem when I go into "Fullscreen Mode". In previous versions of Firefox, when in fullscreen mode, moving the mouse towards the top of the window would unhide the toolbar.

Now, the functionality is gone when using "Tabs on Bottom". Anyone run across this problem too or has a fix?

more options

TeknoXI said

I was able to get "Tabs on Bottom" using this fix. However, I run across a problem when I go into "Fullscreen Mode". In previous versions of Firefox, when in fullscreen mode, moving the mouse towards the top of the window would unhide the toolbar. Now, the functionality is gone when using "Tabs on Bottom". Anyone run across this problem too or has a fix?

As a colleague at work used tio say, "To every solutions there's a problem". Firefox Quantum just proves that saying.

more options

See this tread for a fix with tabs on bottom and full screen mode.

  • /questions/1191103 Tab bar does not appear during fullscreen mode (when it is located under nav-bar)

:root {
  /* fix for full screen mode */
  --tab-toolbar-navbar-overlap: 0px !important;
  /* set minimum tab height */
  --tab-min-height: 25px !important;
}
more options

cor-el said

See this tread for a fix with tabs on bottom and full screen mode.
  • /questions/1191103 Tab bar does not appear during fullscreen mode (when it is located under nav-bar)

:root {
  /* fix for full screen mode */
  --tab-toolbar-navbar-overlap: 0px !important;
  /* set minimum tab height */
  --tab-min-height: 25px !important;
}

Thanks! That fixed it! Much appreciated.

  1. 1
  2. 2