Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have FireFox Quantum Beta and am having issues with it chewing up alot of memory (7gb!). I do have a screen capture of the task manager

  • 42 uphendule
  • 249 zinale nkinga
  • 19622 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

Hi. I was having an extreme amount of slowness on FireFox Quantum Beta (version 57). I had the slowness just before and after a new update was installed (11/13/17 at about 10:45AM CDT). I captured the Task manager just before and after the update. I know that there is a legacy Flash plugin but it is set to never activate. How can I get rid of it permanently?

Isisombululo esikhethiwe

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

You can get Firefox 57 Final Release from here : https://fileforum.betanews.com/detail/Mozilla-Firefox-for-Windows/1032985422/1

Please let us know if this solved your issue or if need further assistance.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (20)

more options

Here are screen captures of the Task Manager before and after the update to FireFox 57.

more options

I was able to remove the Flash plugin from appearing on the plugin page by uninstalling it. I don't think that was the issue because it was set to Ask to Activate when the crash occurred. But now it doesn't appear at all on the Add On page.

more options

Here is current status of the Task Manager. Why are there four instances of Firefox open and there are only two pages open (this page and Add-ons Manager)?

more options

I don't think this problem was solved with Flash. Right now I have 22 windows open on FIrefox. All but three are just regular Twitter tabs. Why is the top Firefox channel puling 1 GB?

more options

Here is a compact view of all 7 cores

more options

WOW - just found that opening Yahoo mail makes one of the cores bounce up to over 3GB!

more options

safemanusa said

WOW - just found that opening Yahoo mail makes one of the cores bounce up to over 3GB!

But does not relinquish memory gracefully when it is closed!

more options

Isisombululo Esikhethiwe

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

You can get Firefox 57 Final Release from here : https://fileforum.betanews.com/detail/Mozilla-Firefox-for-Windows/1032985422/1

Please let us know if this solved your issue or if need further assistance.

more options

So now with your recommended fixes I have cores that have 300 to 600K memory usage. Is this expected? I purposely have some heavy hitters open like YouTube, Yahoo, Gmail, newspaper website. Is this normal? It seems more stable. Time will tell.

more options

safemanusa said

So now with your recommended fixes I have cores that have 300 to 600K memory usage. Is this expected? I purposely have some heavy hitters open like YouTube, Yahoo, Gmail, newspaper website. Is this normal? It seems more stable. Time will tell.

Unfortunately I feel the same but yes. Version 58 will have multi-thread support so it should come down sooner or later. Is a lot better than gigs+++ you were getting though. Mine is about 800 to 1500 with 10tabs + open depending on what.

Please let us know if this solved your issue or if need further assistance.

more options

That's good to hear! Glad that Version 58 will be Multi-Thread! And glad to know that now I have a normal running Firefox. Thanks!

more options

So do I need to monitor the memory usage periodically and do the process you described every so often? How long does it take for the system to bog down again?

more options

I uninstalled Firefox with Revo, deleted all remnants I could find (Apps/Local and Apps/ Roaming, etc.), re-booted, and reinstalled Firefox. Issue persists.

more options

smoddelm said

I uninstalled Firefox with Revo, deleted all remnants I could find (Apps/Local and Apps/ Roaming, etc.), re-booted, and reinstalled Firefox. Issue persists.

So if you look at the task manager how much memory is Firefox using? You might have multiple instances of Firefox. One for each processor core. Right now I am showing between 77KB and 1.1 Gb with 21 tabs open.

more options

Will this problem be fixed so users to not have to go through this time-consuming problem?

more options

I hope so. Hopefully Version 58 will make better use of the multi-threading engine.

more options

Any idea when version 58 will be available?

more options

.....are you effin' KIDDING me? I've got JUST 4 GB RAM on my PC, and THIS clown decides he's going to SLAM a platform which requires OVER 3 GB of desktop memory ALONE just to have Yahoo! as an email server???? What is WRONG with these people??? Try AGAIN, Chris - PLEASE.....

more options

Hi runnersweb and smoddelm and ogam5 and Pkshadow-

I have found this solution (see below) to also be very helpful. I performed the solution that Pkshadow suggested above and marked as the solution first. It brought memory into more tolerable range of 1.5 Gb. But just today I found another solution by Pkshadow. Here is the scenario.

I have 21 tabs open in Firefox 57 (Yahoo Mail, Gmail, 3 actively running YouTube, rest Twitter).

My desktop: i7 processor, 16Gb Ram, Windows 10 Home, Memory usage is about 39%. Task Manager details shows Firefox using 7 cores ranging from 22 Kb to 800 Mb. Very consistent performance.

Thanks to the help of Pkshadow - https://support.mozilla.org/en-US/questions/1188043

"You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Hardware Acceleration might have also been a issue so turn it off. Run it later and see as you turn things back on and test it, and again. Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance."

Okulungisiwe ngu safemanusa

more options

.....genuinely appreciate the advice, safeman - but, after having decelerated hardware previously (at the express recommendation of a Mozilla tech) with NO appreciable SUSTAINED improvement to hanging up, not gonna change from 45 (which I installed last night - yeah, ironic, I do realize) at least for now - so FAR, no apparent conflicts with Flash but, haven't used it much yet, either.....

  1. 1
  2. 2
  3. 3