X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

30+ instances of firefox in task manager even after closing program - what?????

Kuphostiwe

suddenly I have 30+ instances of firefox (56.xxx) in my task manager in background processes, even after I close firefox. I have to click on each one to close, closing one does not close them all. I can open firefox and use it but it just continues to add to the list. After restart they go away but then eventually start to build again. I've tried to recreate it while I watch but after a number of attempts I only show one at the moment that still stays after closing FF. After using FF for a few days I'll remember to check and behold, many many instances of FF in background processes even after closing FF completely. I don't know how long it takes to build up so many or why it's doing it. tried to attach a screen shot but it wouldn't load. any ideas? I only noticed this the last 4-5 days so i don't know how long it's been going on. clicked share data while it currently shows only one instance of FF in background processes that has been there through multiple closings of FF.

Alienware 17, win 10 updated, firefox updated, noscript, adblock plus, enhancer for youtube addons, otherwise nothing special in my setup.

suddenly I have 30+ instances of firefox (56.xxx) in my task manager in background processes, even after I close firefox. I have to click on each one to close, closing one does not close them all. I can open firefox and use it but it just continues to add to the list. After restart they go away but then eventually start to build again. I've tried to recreate it while I watch but after a number of attempts I only show one at the moment that still stays after closing FF. After using FF for a few days I'll remember to check and behold, many many instances of FF in background processes even after closing FF completely. I don't know how long it takes to build up so many or why it's doing it. tried to attach a screen shot but it wouldn't load. any ideas? I only noticed this the last 4-5 days so i don't know how long it's been going on. clicked share data while it currently shows only one instance of FF in background processes that has been there through multiple closings of FF. Alienware 17, win 10 updated, firefox updated, noscript, adblock plus, enhancer for youtube addons, otherwise nothing special in my setup.

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 56.0.2
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/56.0.2/WINNT/en-US/

Izandiso

  • Adblock Plus 3.0 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Enhancer for YouTube™ 2.0.49 (enhancerforyoutube@maximerf.addons.mozilla.org)
  • NoScript 5.1.5 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Safe Browsing Version 4 (temporary add-on) 1.0.0 (sbv4-gradual-rollout@mozilla.com)
  • YouTube Control Center 0.5.3 (jid1-CikLKKPVkw6ipw@jetpack) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics 630
  • adapterDescription2: NVIDIA GeForce GTX 1060
  • adapterDeviceID: 0x591b
  • adapterDeviceID2: 0x1c20
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvdm.inf_amd64_004e0427ab640454\nvldumd.dll
  • adapterRAM: Unknown
  • adapterRAM2: 6144
  • adapterSubsysID: 07781028
  • adapterSubsysID2: 07781028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.16299.15
  • driverDate: 6-16-2017
  • driverDate2: 7-30-2017
  • driverVersion: 22.20.16.4708
  • driverVersion2: 22.21.13.8514
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'disabled', u'description': u'Advanced Layers', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'ADVANCED_LAYERS'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'skia', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 630 Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000011620) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture_nv12 EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 630 Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000011620) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture_nv12 EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11
  • windowUsingAdvancedLayers: False

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha

Impendulo Ewusizo

got the upload of screen capture to work as a reply.

got the upload of screen capture to work as a reply.
cor-el
  • Top 10 Contributor
  • Moderator
17539 izisombululo 158588 izimpendulo
Kuphostiwe

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.


Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software.

  • do NOT remove "personal data" When you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data When you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data When you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then you can create a new profile to test if your current profile is causing the problem.


Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 ---- Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release. *download the Firefox installer and save the file to the desktop<br>*https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software. *do NOT remove "personal data" When you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(64-bit Firefox) "C:\Program Files\Mozilla Firefox\" *(32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\" *it is important to delete the Firefox program folder to remove all the files and make sure there are no problems with files that were leftover after uninstalling *http://kb.mozillazine.org/Uninstalling_Firefox Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data When you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data When you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then you can create a new profile to test if your current profile is causing the problem. <hr> *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Umnikazi wombuzo

first, booting in safe mode doesn't help. I can't run my computer for normal use in safe mode and since it took at least 20 minutes to get it to repeat the one instance, it's not practical. as I said, I can't get it to repeat while I watch except for the one time, other times it didn't do it. I simply can't run my computer and do work in safe mode for days to see if it does it. I use windows defender and firewall, nothing extra.

the other suggestion is a hella lot of work to then reset up firefox and get things going again (the profile settings and personal data always seems to get wacked somehow when I've done this before). if you are just suggesting some blanket "restart" style option I'd appreciate if someone else has maybe experienced it and has a suggestion/input first. I'll keep that as a last resort for now.

first, booting in safe mode doesn't help. I can't run my computer for normal use in safe mode and since it took at least 20 minutes to get it to repeat the one instance, it's not practical. as I said, I can't get it to repeat while I watch except for the one time, other times it didn't do it. I simply can't run my computer and do work in safe mode for days to see if it does it. I use windows defender and firewall, nothing extra. the other suggestion is a hella lot of work to then reset up firefox and get things going again (the profile settings and personal data always seems to get wacked somehow when I've done this before). if you are just suggesting some blanket "restart" style option I'd appreciate if someone else has maybe experienced it and has a suggestion/input first. I'll keep that as a last resort for now.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Your doing good there with that issue. At least all those are not running in megs. Really be in a mess. I have 2 running at the lowest yet of 438 megs each, usually is a gig & 1/2.

I really do not know where to start as you stated running a pretty simple install. Video Card drivers could be updated but are not too old and no errors. You have 2, a on-board adapterDescription: Intel(R) HD Graphics 630 https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 and adapterDescription2: NVIDIA GeForce GTX 1060 https://www.geforce.com/drivers

Since both have recent driver date am wondering if the Intel is turned on and if it is why ? If not using it check Bios on a boot and turn it off. Though should keep drivers updated.

Well do know it is Multiprocessor related. There is a cure for that.

Am trying to weigh turning off that support vs leaving it if it is not causing instability. as Firefox 57 Quantum release date Nov 14th hoping for cures in that. https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

So with that information I will leave the info as to how to turn it off if so choose to before FF57 release date if it takes to much system resources.

Check to : See if Multi-Processor Support is turned on. Multi-processor support feature may be disabled depending on your setup (it was for me) - you can check this by launching Firefox, then enter in "about:support" in the address bar; near the bottom, you should see a heading that says: "Multiprocess Windows", then look at the value next to it. If it says "0/1", then that means it's disabled. 0/2 and higher = on unless says it is off.

Then check the Task Manager and see how many instances of Firefox is running and what the memory numbers are like.

If need to can turn off multiprocessor : You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Please let us know if this solved your issue or if need further assistance.

Your doing good there with that issue. At least all those are not running in megs. Really be in a mess. I have 2 running at the lowest yet of 438 megs each, usually is a gig & 1/2. I really do not know where to start as you stated running a pretty simple install. Video Card drivers could be updated but are not too old and no errors. You have 2, a on-board adapterDescription: Intel(R) HD Graphics 630 https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 and adapterDescription2: NVIDIA GeForce GTX 1060 https://www.geforce.com/drivers Since both have recent driver date am wondering if the Intel is turned on and if it is why ? If not using it check Bios on a boot and turn it off. Though should keep drivers updated. Well do know it is Multiprocessor related. There is a cure for that. Am trying to weigh turning off that support vs leaving it if it is not causing instability. as Firefox 57 Quantum release date Nov 14th hoping for cures in that. https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed. So with that information I will leave the info as to how to turn it off if so choose to before FF57 release date if it takes to much system resources. Check to : See if Multi-Processor Support is turned on. Multi-processor support feature may be disabled depending on your setup (it was for me) - you can check this by launching Firefox, then enter in "about:support" in the address bar; near the bottom, you should see a heading that says: "Multiprocess Windows", then look at the value next to it. If it says "0/1", then that means it's disabled. 0/2 and higher = on unless says it is off. Then check the Task Manager and see how many instances of Firefox is running and what the memory numbers are like. If need to can turn off multiprocessor : You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false Please let us know if this solved your issue or if need further assistance.

Umnikazi wombuzo

I also noticed I can delete the background process without it closing FF, it still shows in apps and I'm using now after deleting the one instance in background processes.

to be clear, there are not multiple instances in Apps in the task manager list, the multiple instances are only in background processes.

I also noticed I can delete the background process without it closing FF, it still shows in apps and I'm using now after deleting the one instance in background processes. to be clear, there are not multiple instances in Apps in the task manager list, the multiple instances are only in background processes.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Where your Profile is : https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data and backup/restore https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles and auto do it http://kb.mozillazine.org/Profile_backup

Please let us know if this solved your issue or if need further assistance.

Where your Profile is : https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data and backup/restore https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles and auto do it http://kb.mozillazine.org/Profile_backup Please let us know if this solved your issue or if need further assistance.

Umnikazi wombuzo

Pkshadow so, I am not really following your post very well. I see you are typing as you think it out, I can relate. Driver dates you mentioned, this computer is only a month or so old so it's all new.

if I follow correctly, it's not unstable and doesn't crash, i only noticed the multi instances when I checked task manager for something else. multiprocessor is turned off, should it be on?

I do have the browser tabs set to not show multiple instances in the Apps section.

I'm a bit lost at the moment, I see your notes but not sure which steps to actually take - sorry bout that...

Pkshadow so, I am not really following your post very well. I see you are typing as you think it out, I can relate. Driver dates you mentioned, this computer is only a month or so old so it's all new. if I follow correctly, it's not unstable and doesn't crash, i only noticed the multi instances when I checked task manager for something else. multiprocessor is turned off, should it be on? I do have the browser tabs set to not show multiple instances in the Apps section. I'm a bit lost at the moment, I see your notes but not sure which steps to actually take - sorry bout that...

Umnikazi wombuzo

Boom, just got it to repeat.

I have two ways to open a New Window File, New Window FF shortcut on start menu (I use classic start menu)

I've got 3 more instances after opening from the start menu. It does not do it from File, New Window, only from the shortcut in the start menu.

helpful?

Boom, just got it to repeat. I have two ways to open a New Window File, New Window FF shortcut on start menu (I use classic start menu) I've got 3 more instances after opening from the start menu. It does not do it from File, New Window, only from the shortcut in the start menu. helpful?
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Pkshadow said

Your doing good there with that issue. At least all those are not running in megs. Really be in a mess. I have 2 running at the lowest yet of 438 megs each, usually is a gig & 1/2. I really do not know where to start as you stated running a pretty simple install. Video Card drivers could be updated but are not too old and no errors. You have 2, a on-board adapterDescription: Intel(R) HD Graphics 630 https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 and adapterDescription2: NVIDIA GeForce GTX 1060 https://www.geforce.com/drivers Since both have recent driver date am wondering if the Intel is turned on and if it is why ? If not using it check Bios on a boot and turn it off. Though should keep drivers updated. Well do know it is Multiprocessor related. There is a cure for that. Am trying to weigh turning off that support vs leaving it if it is not causing instability. as Firefox 57 Quantum release date Nov 14th hoping for cures in that. https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed. So with that information I will leave the info as to how to turn it off if so choose to before FF57 release date if it takes to much system resources. Check to : See if Multi-Processor Support is turned on. Multi-processor support feature may be disabled depending on your setup (it was for me) - you can check this by launching Firefox, then enter in "about:support" in the address bar; near the bottom, you should see a heading that says: "Multiprocess Windows", then look at the value next to it. If it says "0/1", then that means it's disabled. 0/2 and higher = on unless says it is off. Then check the Task Manager and see how many instances of Firefox is running and what the memory numbers are like. If need to can turn off multiprocessor : You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false Please let us know if this solved your issue or if need further assistance.

here are newer drivers on the URL's above :

driverDate: 6-16-2017

driverDate2: 7-30-2017 driverVersion: 22.20.16.4708 driverVersion2: 22.21.13.8514

Yes, it means you should do a reinstall as cor-el suggested.

''Pkshadow [[#answer-1025566|said]]'' <blockquote> Your doing good there with that issue. At least all those are not running in megs. Really be in a mess. I have 2 running at the lowest yet of 438 megs each, usually is a gig & 1/2. I really do not know where to start as you stated running a pretty simple install. Video Card drivers could be updated but are not too old and no errors. You have 2, a on-board adapterDescription: Intel(R) HD Graphics 630 https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 and adapterDescription2: NVIDIA GeForce GTX 1060 https://www.geforce.com/drivers Since both have recent driver date am wondering if the Intel is turned on and if it is why ? If not using it check Bios on a boot and turn it off. Though should keep drivers updated. Well do know it is Multiprocessor related. There is a cure for that. Am trying to weigh turning off that support vs leaving it if it is not causing instability. as Firefox 57 Quantum release date Nov 14th hoping for cures in that. https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed. So with that information I will leave the info as to how to turn it off if so choose to before FF57 release date if it takes to much system resources. Check to : See if Multi-Processor Support is turned on. Multi-processor support feature may be disabled depending on your setup (it was for me) - you can check this by launching Firefox, then enter in "about:support" in the address bar; near the bottom, you should see a heading that says: "Multiprocess Windows", then look at the value next to it. If it says "0/1", then that means it's disabled. 0/2 and higher = on unless says it is off. Then check the Task Manager and see how many instances of Firefox is running and what the memory numbers are like. If need to can turn off multiprocessor : You can try to modify multi-process settings to see if this has effect. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false Please let us know if this solved your issue or if need further assistance. </blockquote> here are newer drivers on the URL's above : driverDate: 6-16-2017 driverDate2: 7-30-2017 driverVersion: 22.20.16.4708 driverVersion2: 22.21.13.8514 Yes, it means you should do a reinstall as cor-el suggested.

Umnikazi wombuzo

Waited for 57 to see if it resolves issue. Did not. Removed firefox then reinstalled 57. Issue is still there.

Followed your steps below, multip-process was set to 1, changed it to 4 to turn it on? set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox

changed these both to true browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

no change, still repeating firefox instances in background process. I do notice when I close all firefox windows, a momentary version of firefox shows with the other instances under background process (if there’s two, a third shows momentarily). Then it’s back to two until I delete them manually, or however many might be there.

Again, these only show when I use the start menu or desktop shortcut to start a new firefox window. Now when I click file/new window from within the first firefox window.

Waited for 57 to see if it resolves issue. Did not. Removed firefox then reinstalled 57. Issue is still there. Followed your steps below, '''multip-process was set to 1, changed it to 4 to turn it on?''' '' set dom.ipc.processCount to 1 if it is currently set to a higher value (4) disable multi-process windows in Firefox '' '''changed these both to true''' ''browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false '' no change, still repeating firefox instances in background process. I do notice when I close all firefox windows, a momentary version of firefox shows with the other instances under background process (if there’s two, a third shows momentarily). Then it’s back to two until I delete them manually, or however many might be there. Again, these only show when I use the start menu or desktop shortcut to start a new firefox window. Now when I click file/new window from within the first firefox window.

Okulungisiwe ngu callingdoug

Umnikazi wombuzo

I also created a new profile as a test and the situation is unchanged.

I also created a new profile as a test and the situation is unchanged.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Ok. Been awhile, yes they keep moving down the list. Also most times that means we have done our best at it.

Ok so you waited for 57. Did you do the clean install or did you just update ? If just updated : Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

What did you do about the Video Card Drivers ? Intel(R) HD Graphics 630 https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 and adapterDescription2: NVIDIA GeForce GTX 1060 https://www.geforce.com/drivers NVIDIA is listed as # 2 so something weird here as should be 1 as is better card/chip. Go into Bios and find out if that Intel is Enabled. If it is turn it off. This will free up some system resources for you as well.

So you reversed the instructions for turning off Multi-processor is that correct ?

Think that ghost icon you see at close is just lag.

Ok....seeing all those processes running is ok as that is what it is suppose to do ie: Multi-processor When you monitor in Task Manager I for this have 7 going right now and I am using a total of 1,241..MB. with 14 Tabs Open. I have been running from 750-1500MB

So if you are in that range think that is what you are supposed to be.

No from the Tools --> Options --> go to near page bottom Performace Untick Use Recommended Settings, Untick Use Hardware Acceleration for now and then from the little pull down menu change the recommended Content Limit to 1 or 2 below. (If no change after monitoring increase back.) Restart Firefox. Now play and watch Task Manager for changes and also for feel, Video Playing may have to turn Hardware Acceleration Back on..you will need to decide from watching videos. Which brings full circle to the Video Drivers..........

Ok, tired now.

Please let us know if this solved your issue or if need further assistance.

Ok. Been awhile, yes they keep moving down the list. Also most times that means we have done our best at it. Ok so you waited for 57. Did you do the clean install or did you just update ? If just updated : Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/ What did you do about the Video Card Drivers ? Intel(R) HD Graphics 630 https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 and adapterDescription2: NVIDIA GeForce GTX 1060 https://www.geforce.com/drivers NVIDIA is listed as # 2 so something weird here as should be 1 as is better card/chip. Go into Bios and find out if that Intel is Enabled. If it is turn it off. This will free up some system resources for you as well. So you reversed the instructions for turning off Multi-processor is that correct ? Think that ghost icon you see at close is just lag. Ok....seeing all those processes running is ok as that is what it is suppose to do ie: Multi-processor When you monitor in Task Manager I for this have 7 going right now and I am using a total of 1,241..MB. with 14 Tabs Open. I have been running from 750-1500MB So if you are in that range think that is what you are supposed to be. No from the Tools --> Options --> go to near page bottom Performace Untick Use Recommended Settings, Untick Use Hardware Acceleration for now and then from the little pull down menu change the recommended Content Limit to 1 or 2 below. (If no change after monitoring increase back.) Restart Firefox. Now play and watch Task Manager for changes and also for feel, Video Playing may have to turn Hardware Acceleration Back on..you will need to decide from watching videos. Which brings full circle to the Video Drivers.......... Ok, tired now. Please let us know if this solved your issue or if need further assistance.

Impendulo Ewusizo

Hello again, Fresh install of 57, removed 56 and folders were gone as well. Tried the new profile under 57

Video drivers. Went into device manager, display adapters, clicked update for each and windows said they were both good.

Intel 630 driver, went to website, downloaded most recent, wouldn’t install, said it’s not for my system. Downloaded next older version, wouldn’t install. Confirmed through a search that it should have been for my system, still didn’t work. Went through Dell site and downloaded what they had (said it was a month newer?) and the date didn’t change, still says 6/6/2017

GeForced, downloaded and installed. 11/14/2017


Yes, I reversed the multi-processor because it sounded like it should have been turned on and it was not. Should it be on or off?


Re: NVIDIA is listed as # 2 so something weird here as should be 1 as is better card/chip. Go into Bios and find out if that Intel is Enabled. If it is turn it off. This will free up some system resources for you as well. I’m not real comfortable making changes to the Bios settings. Being a new computer I’d hope it’s set up right (Alienware 17 R4). Don’t want to screw something up…


No from the Tools --> Options --> go to near page bottom Performace Untick Use Recommended Settings, Untick Use Hardware Acceleration for now and then from the little pull down menu change the recommended Content Limit to 1 or 2 below. (If no change after monitoring increase back.) Restart Firefox.

Did these things. No change.

Which brings full circle to the Video Drivers..........

Well, It’s not affecting performance and it’s only in the background process and it will keep adding new ones unless I delete them one at a time or restart. I hate stupid sh*& like this…

If you have no other ideas, I’ll just have to deal with it and try to remember to not start a new window except from the menu in firefox. I wouldn’t be surprised if others are having the same issue and not seeing it. I stumbled across it by accident since it’s only in the background processes. And when I restart they do all go away.

Hello again, Fresh install of 57, removed 56 and folders were gone as well. Tried the new profile under 57 Video drivers. Went into device manager, display adapters, clicked update for each and windows said they were both good. Intel 630 driver, went to website, downloaded most recent, wouldn’t install, said it’s not for my system. Downloaded next older version, wouldn’t install. Confirmed through a search that it should have been for my system, still didn’t work. Went through Dell site and downloaded what they had (said it was a month newer?) and the date didn’t change, still says 6/6/2017 GeForced, downloaded and installed. 11/14/2017 Yes, I reversed the multi-processor because it sounded like it should have been turned on and it was not. Should it be on or off? Re: NVIDIA is listed as # 2 so something weird here as should be 1 as is better card/chip. Go into Bios and find out if that Intel is Enabled. If it is turn it off. This will free up some system resources for you as well. I’m not real comfortable making changes to the Bios settings. Being a new computer I’d hope it’s set up right (Alienware 17 R4). Don’t want to screw something up… No from the Tools --> Options --> go to near page bottom Performace Untick Use Recommended Settings, Untick Use Hardware Acceleration for now and then from the little pull down menu change the recommended Content Limit to 1 or 2 below. (If no change after monitoring increase back.) Restart Firefox. Did these things. No change. Which brings full circle to the Video Drivers.......... Well, It’s not affecting performance and it’s only in the background process and it will keep adding new ones unless I delete them one at a time or restart. I hate stupid sh*& like this… If you have no other ideas, I’ll just have to deal with it and try to remember to not start a new window except from the menu in firefox. I wouldn’t be surprised if others are having the same issue and not seeing it. I stumbled across it by accident since it’s only in the background processes. And when I restart they do all go away.
Moses
  • Moderator
459 izisombululo 3607 izimpendulo
Kuphostiwe

Download drivers directly from manufacturer, don't use Device Manager or Windows Update to pull in versions of drivers, most of the time they are out of date.

Download drivers directly from manufacturer, don't use Device Manager or Windows Update to pull in versions of drivers, most of the time they are out of date.
delmond 0 izisombululo 5 izimpendulo
Kuphostiwe

The same thing is happening to me. I'm getting a minimum of 3 listed in my task manager and I can only close the one taking up the least resources. If I try to close all but the one taking the larges resources, it shuts down FF completely!

The same thing is happening to me. I'm getting a minimum of 3 listed in my task manager and I can only close the one taking up the least resources. If I try to close all but the one taking the larges resources, it shuts down FF completely!

Umnikazi wombuzo

delmondar - different issue I think. the ones I'm referring to are in the background processes section, not the main section. the ones you are talking about are the main apps actually running. sounds like a resource issue.

from above, one guy says this about your issue which might be normal: Ok....seeing all those processes running is ok as that is what it is suppose to do ie: Multi-processor When you monitor in Task Manager I for this have 7 going right now and I am using a total of 1,241..MB. with 14 Tabs Open. I have been running from 750-1500MB

but again, my issue is multiple instances in "background processes" (scroll down in task manager, you'll see the title).

delmondar - different issue I think. the ones I'm referring to are in the background processes section, not the main section. the ones you are talking about are the main apps actually running. sounds like a resource issue. from above, one guy says this about your issue which might be normal: Ok....seeing all those processes running is ok as that is what it is suppose to do ie: Multi-processor When you monitor in Task Manager I for this have 7 going right now and I am using a total of 1,241..MB. with 14 Tabs Open. I have been running from 750-1500MB but again, my issue is multiple instances in "background processes" (scroll down in task manager, you'll see the title).

Okulungisiwe ngu callingdoug

delmond 0 izisombululo 5 izimpendulo
Kuphostiwe

Mine are in background processes as well and this never happened prior to this most recent update

Mine are in background processes as well and this never happened prior to this most recent update

Umnikazi wombuzo

Wow, finally another discovers. I'm still betting it's more of an issue that people just don't notice unless they happen to be looking around in that section of task manager.

Difference for me seems to be that they take almost no resources (screen shot way up above) and I can delete them, one at a time, and when they are all gone it has no affect on FF. I really have no idea how long it's been going on. Especially since when I do a restart, they all go away.

Mine show up when I click on a new window through a shortcut. Have you been able to figure out when your's show up? Have you tried any of the recommendations from Pkshadow?

Wow, finally another discovers. I'm still betting it's more of an issue that people just don't notice unless they happen to be looking around in that section of task manager. Difference for me seems to be that they take almost no resources (screen shot way up above) and I can delete them, one at a time, and when they are all gone it has no affect on FF. I really have no idea how long it's been going on. Especially since when I do a restart, they all go away. Mine show up when I click on a new window through a shortcut. Have you been able to figure out when your's show up? Have you tried any of the recommendations from Pkshadow?
delmond 0 izisombululo 5 izimpendulo
Kuphostiwe

I'm in the task manager all the time so it was definitely with this latest release.

I'm having a few other issues too but I think that some of them have to do with the latest Windows update (my printer won't stay connected and frequently my task bar disappears). So, I've been rebooting and restarting a lot and I continue to have a minimum of 3 FFs running no matter what and they seem to show up as soon as I open FF.

I haven't tried any of the suggestions because they're too much work. Waiting for someone who has success to chime in then I'll try. Not happy at all with this latest FF release. I usually wait quite a while to install but did fairly quickly this time... wish I'd have waited.

I'm in the task manager all the time so it was definitely with this latest release. I'm having a few other issues too but I think that some of them have to do with the latest Windows update (my printer won't stay connected and frequently my task bar disappears). So, I've been rebooting and restarting a lot and I continue to have a minimum of 3 FFs running no matter what and they seem to show up as soon as I open FF. I haven't tried any of the suggestions because they're too much work. Waiting for someone who has success to chime in then I'll try. Not happy at all with this latest FF release. I usually wait quite a while to install but did fairly quickly this time... wish I'd have waited.
kallistra 1 izisombululo 2 izimpendulo
Kuphostiwe

I'm getting this issue too. I opened a support request as well. I'm on an Alienware. As soon as I open Firefox, bam, many processes. Chrome does that as well to me, so I had switched to Firefox... and now with latest updates, Firefox now acts like Chrome. :/

Please don't force me to use Edge.........

Images attached.

I'm getting this issue too. I opened a support request as well. I'm on an Alienware. As soon as I open Firefox, bam, many processes. Chrome does that as well to me, so I had switched to Firefox... and now with latest updates, Firefox now acts like Chrome. :/ Please don't force me to use Edge......... Images attached.