Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

so why does firefox need to have so many processes open for one window?

  • 9 uphendule
  • 134 zinale nkinga
  • 55629 views
  • Igcine ukuphendulwa ngu 60012334

more options

So i was watching a video on youtube as a game had frozen, decided to open task manager to end task for the game, then noticed there were 5 processors of firefox running, just wondering why are there 5? all i was doing was watching youtube.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Hi, this is Multiprocess which is normal, but if you are having slowness/hanging issues, try reducing the number of multiprocesses: Go to Options > General - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to a smaller number - try 1. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 24

All Replies (9)

more options

sorry for double post not sure why it did it

this one has a screenshot as you can see

more options

Isisombululo Esikhethiwe

Hi, this is Multiprocess which is normal, but if you are having slowness/hanging issues, try reducing the number of multiprocesses: Go to Options > General - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to a smaller number - try 1. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

more options

Scribe said

Hi, this is Multiprocess which is normal, but if you are having slowness/hanging issues, try reducing the number of multiprocesses: Go to Options > General - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to a smaller number - try 1. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.'

Awesome thanks for the help that solved my problems :)

more options

There option to limit one process does not work with the new Firefox Quantum so you will have to use and older version of Firefox and then it may actually work.

This does not work in the newest version of Firefox and will NOT run only one process. I am a 35 year computer tech with a LOT of experience. Firefox will need to patch the new Firefox Quantum to allow this option to work.

Okulungisiwe ngu ARREB

more options

cant delete this comment so wrote this

Okulungisiwe ngu ARREB

more options

"Hi, this is Multiprocess which is normal,"

why is this normal? what is Multiprocess?

more options

_DRP said

"Hi, this is Multiprocess which is normal," why is this normal? what is Multiprocess?

I Second this excellent question Why is this 'Normal' I am watching 6 processes taking over 3% and over 400Mb memory of a fast Win10 i5 system just posting this reply!? This does warrant explanation

more options

You may see three or more Firefox processes running.

  • one process for the main Firefox thread (user interface)
  • one or more content processes set via dom.ipc.processCount
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • one process for the compositor thread (Windows;graphics)

You can look in "Help -> Troubleshooting Information" (about:support) to see the current multi-process state.

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Web Content Processes

See also:

more options

cor-el said

You may see three or more Firefox processes running.
  • one process for the main Firefox thread (user interface)
  • one or more content processes set via dom.ipc.processCount
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • one process for the compositor thread (Windows;graphics)
You can look in "Help -> Troubleshooting Information" (about:support) to see the current multi-process state.
  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Web Content Processes
See also:

Thanks for your reply ghacks was most informative and I'm not going to get stressed seeing Firefox at the top of Task Manager having followed your links Your reply is very much appreciated Regards TW