Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Not receiving push notifications

  • 39 uphendule
  • 4 zinale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu Happy112

more options

Have enabled push notifications for my website www.tuckerhockey.com, however it's not recording my choice in the browser. When I switch pages, the pop up keeps coming up, again not saving my preferences. I get the confirmation pop up indicating I've accepted notifications however it's not saved. I am not browsing privately, I keep my cookies, preferences have all been enabled. I am using the newest version of Firefox on my Windows 10 PC.

All Replies (20)

more options

Did you check out this page for this problem?

https://support.mozilla.org/en-US/kb/push-notifications-firefox

Hope this page will help you to solve your problem.

more options

I've already gone over this page and nothing done changed the outcome.

more options

Did you look in "Tools -> Page Info -> Permissions" ?

more options

If you have already checked everything that is mentioned in the link that
Adib Obaid gave you, then would you please take a look at the article :

How to fix preferences that won't save

Anything helpful in that article  ?

more options

Happy112 said

If you have already checked everything that is mentioned in the link that
Adib Obaid gave you, then would you please take a look at the article : How to fix preferences that won't save Anything helpful in that article  ?
more options

Ok, so I refreshed Firefox. That seems to have solved the problem of saving my notification preferences, however I did not receive the Welcome Notification that I should have, nor did I receive the notification I created and sent just after allowing notifications. I closed the browser, nothing upon re-opening. I opened Chrome and received the notification immediately... Anything else I could try?

more options

Separate issue :

Your system details show two versions of Shockwave Flash, which can cause major problems. So, please uninstall them .

Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

Then re-install the latest version, which is 27.0.0.170 You can download te latest version from here : https://get.adobe.com/flashplayer/

Note : some 'extras' may be offered in the download.

more options

Ok, did that! And did a refresh on Firefox again... still nothing... Any other suggestions?

more options

Tucker_Hockey said

Ok, did that! And did a refresh on Firefox again... still nothing... Any other suggestions?

Just went to your website and I was immediately asked if I wanted to receive notifications .......

I have absolutely no idea what to suggest next (so sorry  !). But somebody else is bound to come up with the perfect solution (fingers crossed)  !

more options

Well that's good at least... I just can't understand why I can't see it in Firefox. Thanks for all of your help, I really appreciate it!

more options

Tucker_Hockey said

Well that's good at least... I just can't understand why I can't see it in Firefox. Thanks for all of your help, I really appreciate it!

Wish I could have really helped ......

This 'notification' on your website : what does it say (cause I do get some dropdown saying something about Christmas ......  ?)

And : it says to activate Adobe Flash - did you do that  ? (the little grey icon in the upper left corner  ?)

more options

In the left-hand corner, that's just a Pop Up box only for the Home page, no notifications in the future. The one I was looking for was from Push Assist which drops down from the middle of the page... as for the Adobe Flash, I got nothing for ya!

more options

Tucker_Hockey said

The one I was looking for was from Push Assist which drops down from the middle of the page... as for the Adobe Flash, I got nothing for ya!

That Adobe Flash message on your website : you can't miss it, cause it's huge  ! (top middle of the page ...... ) What do you mean by "I got nothing for ya ! "  ?

more options

Just one last tiny brainwave :

After you checked 'Allow' for 'receive notifications' : did you reload
the page  ?

And maybe a very dumb question : but is that notification supposed to appear immediately  ?

more options
more options

You can open the about:serviceworkers page to see all registered service workers.

You can also check the WebSockets stats via this page:

  • about:networking#websockets

Some demos here:

Did you check the "Receive Notification" setting?

  • "Tools -> Page Info -> Permissions"?

Note that you see a notch attached to the Control Center 'i' icon at one o'clock when you change permissions from its default value.

more options

Happy112 said

Tucker_Hockey said
The one I was looking for was from Push Assist which drops down from the middle of the page... as for the Adobe Flash, I got nothing for ya!

That Adobe Flash message on your website : you can't miss it, cause it's huge  ! (top middle of the page ...... ) What do you mean by "I got nothing for ya ! "  ?

The adobe flash notification that you mentioned in your previous reply, you'd asked if I had changed that, to which I was responding no to! Not sure why the flash header is not working...

more options

Happy112 said

Just one last tiny brainwave : After you checked 'Allow' for 'receive notifications' : did you reload
the page  ? And maybe a very dumb question : but is that notification supposed to appear immediately  ?

I did reload the page and yes, the notification, saying thanks for subscribing should show up on the bottom of the browser window immediately... at least it did in Chrome.

more options

cor-el said

You can open the about:serviceworkers page to see all registered service workers. You can also check the WebSockets stats via this page:
  • about:networking#websockets

Some demos here:

Did you check the "Receive Notification" setting?

  • "Tools -> Page Info -> Permissions"?

Note that you see a notch attached to the Control Center 'i' icon at one o'clock when you change permissions from its default value.

I'm not familiar with web sockets, so not sure what i am looking at on the page. As for the service provider of the notifications, I'm using Push Assist, no the other two sites are not needed. And yes, the permissions are in place for the page, icon (i) has the 1 o'clock green circle.

more options

I just went to your site again, and this time I got the 'Tuckerhockey Would Like to Send You Push Notifications' etc... , which did not appear before.

Unfortunately I can't check if that notification actually appears, as I clicked 'Don't Allow' - (force of habit - sorry  !) Anyway : I would have to subscribe, right  ?

  1. 1
  2. 2