Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have a code problem. Thank You!

  • 12 uphendule
  • 2 zinale nkinga
  • 72 views
  • Igcine ukuphendulwa ngu jscher2000

more options

I have a problem reading on some Websites

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

cmarinelli said

Can I wait fee months, till Firefox fix it and when it will happen browse with Safari?

I am not currently able to tell you when this will be fixed.

cmarinelli said

Thank you but I hesitate because I'm afraid that my system is less protected.

This change would roll back Firefox's sandbox to the same as Firefox 52-55. If you felt that Firefox 55 was secure enough for you, then I think this change has an acceptable risk.

The other approach is to change something on your Mac related to fonts. System fonts like Arial and Times New Roman need to be TrueType or Open Type fonts in order for Firefox to use them with the stronger sandbox. If they are Suitcase or Adobe Type 1 fonts, Firefox cannot use them and will instead use that "LastResort" symbol font. You may need to discontinue using a program named Suitcase Fusion? Or possibly you need to copy TrueType versions of the fonts into the System folder??

I'm sorry for the lack of details, I am a Windows person and these comments by Mac users are beyond my experience.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (12)

more options

hello cmarinelli, sorry but your bug made me laugh :) Is it possible you still have obsolete modules? Is yes, they can add strange behavior like this one. If not, tell us, we will find a solution together.

more options

What kind of modules, do you mean? My Firefox is up to date. 56.0.1. Flash Player also. The same Website works with Safari. I Prefer to stay with Firefox, but, it has to work… I also clean my Mac, restart it

more options

Thank you so much!!!

more options

ok, can you try to start firefox in safe mode?

Please tell us the result of this test, we will have more clues to work on your issue

more options

Hi cmarinelli, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. Most likely these formats will be allowed in a future update, but that may be a couple months away.

As a temporary workaround, you can reduce the sandbox level back to what it was in Firefox 52-55 as follows:

(1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and change the value from 3 to 1 and click OK

That change won't take effect until the next time you quit and restart Firefox.

Does that work on your Firefox?

more options

I just do it and it's still not working, sorry ;(

more options

Hi jscher2000,

Thank you but I hesitate because I'm afraid that my system is less protected.

more options

Can I wait fee months, till Firefox fix it and when it will happen browse with Safari?

more options

Can someone answer my last question?

more options

Do not be afraid about jscher2000's suggestions, you can try his recommendation and tell us if it solves your issue. Or, if you really don't want to solve with this tips, you will have to wait some months :-(

more options

Ok, I will wait. Thank you ;)

more options

Isisombululo Esikhethiwe

cmarinelli said

Can I wait fee months, till Firefox fix it and when it will happen browse with Safari?

I am not currently able to tell you when this will be fixed.

cmarinelli said

Thank you but I hesitate because I'm afraid that my system is less protected.

This change would roll back Firefox's sandbox to the same as Firefox 52-55. If you felt that Firefox 55 was secure enough for you, then I think this change has an acceptable risk.

The other approach is to change something on your Mac related to fonts. System fonts like Arial and Times New Roman need to be TrueType or Open Type fonts in order for Firefox to use them with the stronger sandbox. If they are Suitcase or Adobe Type 1 fonts, Firefox cannot use them and will instead use that "LastResort" symbol font. You may need to discontinue using a program named Suitcase Fusion? Or possibly you need to copy TrueType versions of the fonts into the System folder??

I'm sorry for the lack of details, I am a Windows person and these comments by Mac users are beyond my experience.