Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

all text on certain websites appears in question marks

  • 22 uphendule
  • 24 zinale nkinga
  • 5432 views
  • Igcine ukuphendulwa ngu slaws2

more options

hello,

since today I notice that all text in firefox (56.0 mac-version) on certain sites appears only in question marks (in suqares). looks like that on sites like mozilla support (busy right now in safari) google.com, my banking site, tmobile, gmail and a lot other ones too. all those sites show totally normal in other brouwsers.

did the following troubleshoot 1) view > text encoding > unicode = OK 2) preferences Font & Color > advanced > checked 'allow pages to choose their own font' = OK

any other suggestions? (:

tried to enclose some screenshots (small jpg and png files) but the upload keeps spinning for ever... never mind.

thanks in advance for any help on the questionmark problem.

Isisombululo esikhethiwe

This bug might be relevant:

Fonts don't display correctly since update due to content-process sandboxing on macOS (#1404919)

Key points:

(A) One workaround is to reduce sandboxing as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and reduce the value from its default value of 3 to 1 and click OK

This reverts the sandbox level in Firefox 56 to what it was in Firefox 52-55 on Mac

That won't take effect until the next time you quit and restart Firefox.

(B) One possible reason for the problem is fonts in a "suitcase" or "Postscript Type 1" format

According to a comment in the bug, Firefox currently will only load fonts with certain file extensions (.otf, .ttf, .ttc, .otc, and .dfont). Other fonts will not load and Firefox will need to use a fallback fonts. There may need to be a change in a future version of Firefox to handle other common font extensions, or to do a better job choosing a fallback font.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 11

All Replies (2)

more options

Hi jonahleewalker, I suggest adding a comment to your bug that the workaround in

https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c1

worked for you. They probably will mark your bug as a duplicate of the earlier one, and they might ask you for more information about your system. If you look at

https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c7

there's a method to extract a list of your fonts that might be helpful since they are researching which file extensions the font files have. That could be helpful.

Okulungisiwe ngu jscher2000

more options

THIS IS REALLY GREAT!

The sandboxing-thing as explained under (A) from jscher2000 fixed the problem for me as well! all text on all sites shows now properly under 56.0., NoScript enabled, no more question marks.

befor I did the sandboxing-attempt though, I run a font-test first to check (B) as presumed by jscher2000 that there might be the reason of the problem. as soon as I closed the activated Arial postscript T1 version (running font-program: LinotypeFontexplorerX) everything showed normally readable as well!

so here we go: the problem is narrowed down and temporary fixable even for technical-dumbos like myself!

A solution without workaround and/or a firefox version that would solve that problem is definately needed thoug for the future.

THANK YOU all for all your help!

Okulungisiwe ngu slaws2

  1. 1
  2. 2