Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox keeps updating even though I deactivated the automatic updater, how can I stop it? the new mozilla looks great but I use mozilla for my old add ons...

  • 5 uphendule
  • 3 zinale nkinga
  • 24 views
  • Igcine ukuphendulwa ngu Moses

more options

I don't want mozilla to update automatically, I know that the new mozilla is faster and what not but I really need my old-working add ons. Thank you

All Replies (5)

more options

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

Also turn off Use a background service to install updates

more options

thats why I wrote: "mozilla keeps updating even though I deactivated the automatic updater"... I already tried that, but thank you for your prompt response

more options

What update channel are you currently on?

  • Help -> About Firefox

You appear to be using Firefox 57 and that is either a Beta release or a Developer Edition release. You need to install the full Firefox release version to switch to the release update channel as you should use as a regular Firefox user.

You can find the full version of the current Firefox release (56.0) in all languages and all operating systems here:

more options

that's the whole point of not updating firefox, to do not get the last version...

more options

Then hop off Fx57 and back on to release. There's no use staying on Beta if you aren't going to want to update continuously.