X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox dropping sessions - running out of space?

Kuphostiwe

This has been going on for a few months, but I have a strange bug where Firefox will start instantly closing sessions. If I clear my cookies it will fix the issue temporarily, but a couple days later it will come back. It's almost like it's running out of space in one of my local .sqlite caches. I've particularly noticed that this happens for a specific domain where I regularly access lots of subdomains (100+ subdomains of a single domain) - it might be coincidental, but I thought that there might be some single-domain cookie storage limit, but from what I've read that limit should be very large and none of the stored cookies are very large and I don't seem to be having this issue in Chrome which - as far as I can tell - has the same single-domain cookie storage limit. Is there a limit to the number of cookies that it will store for a single domain (across subdomains)? Any insight would be much appreciated!

This has been going on for a few months, but I have a strange bug where Firefox will start instantly closing sessions. If I clear my cookies it will fix the issue temporarily, but a couple days later it will come back. It's almost like it's running out of space in one of my local .sqlite caches. I've particularly noticed that this happens for a specific domain where I regularly access lots of subdomains (100+ subdomains of a single domain) - it might be coincidental, but I thought that there might be some single-domain cookie storage limit, but from what I've read that limit should be very large and none of the stored cookies are very large and I don't seem to be having this issue in Chrome which - as far as I can tell - has the same single-domain cookie storage limit. Is there a limit to the number of cookies that it will store for a single domain (across subdomains)? Any insight would be much appreciated!

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 27.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4267 izisombululo 59839 izimpendulo
Kuphostiwe

The only limit I know of is the space on the hard drive. How much is there?

On the site with the issue; https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

The only limit I know of is the space on the hard drive. How much is there? On the site with the issue; https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Umnikazi wombuzo

Thanks Fred. The disk still has 30+GB on it, so I don't think that's it :)

And that trick only seems to work for a single subdomain, so it's not probably a good long-term fix. Any other thoughts? Thanks!

Thanks Fred. The disk still has 30+GB on it, so I don't think that's it :) And that trick only seems to work for a single subdomain, so it's not probably a good long-term fix. Any other thoughts? Thanks!
FredMcD
  • Top 10 Contributor
4267 izisombululo 59839 izimpendulo
Kuphostiwe

Remove History should remove everything for the selected site. Note: Including bookmarks, passwords . . . . .

Remove History should remove everything for the selected site. Note: Including bookmarks, passwords . . . . .

Umnikazi wombuzo

Yeah, I've tried that (clearing everything from history) and it bought be a couple of weeks, but the problem comes back :(

Yeah, I've tried that (clearing everything from history) and it bought be a couple of weeks, but the problem comes back :(
FredMcD
  • Top 10 Contributor
4267 izisombululo 59839 izimpendulo
Kuphostiwe

I called for more help.

I called for more help.

Umnikazi wombuzo

Awesome. Thanks Fred! I appreciate the help - hopefully we can get this resolved :)

Awesome. Thanks Fred! I appreciate the help - hopefully we can get this resolved :)
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

There are some limits for the cookies (MaxCookiesPerHost defaults to 150).

See the source code.

// default limits for the cookie list. these can be tuned by the
// network.cookie.maxNumber and network.cookie.maxPerHost prefs respectively.
static const uint32_t kMaxNumberOfCookies = 3000;
static const uint32_t kMaxCookiesPerHost  = 150;
static const uint32_t kMaxBytesPerCookie  = 4096;
static const uint32_t kMaxBytesPerPath    = 1024;

You can override these limits by creating a new Integer pref on the about:config page as listed further down in the page code. These prefs do not exist by default.

// pref string constants
static const char kPrefCookieBehavior[]       = "network.cookie.cookieBehavior";
static const char kPrefMaxNumberOfCookies[]   = "network.cookie.maxNumber";
static const char kPrefMaxCookiesPerHost[]    = "network.cookie.maxPerHost";
static const char kPrefCookiePurgeAge[]       = "network.cookie.purgeAge";
static const char kPrefThirdPartySession[]    = "network.cookie.thirdparty.sessionOnly";
static const char kCookieLeaveSecurityAlone[] = "network.cookie.leave-secure-alone";

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

There are some limits for the cookies (MaxCookiesPerHost defaults to 150). See the source code. *https://dxr.mozilla.org/mozilla-release/source/netwerk/cookie/nsCookieService.cpp#109 <pre>// default limits for the cookie list. these can be tuned by the // network.cookie.maxNumber and network.cookie.maxPerHost prefs respectively. static const uint32_t kMaxNumberOfCookies = 3000; static const uint32_t kMaxCookiesPerHost = 150; static const uint32_t kMaxBytesPerCookie = 4096; static const uint32_t kMaxBytesPerPath = 1024;</pre> You can override these limits by creating a new Integer pref on the <b>about:config</b> page as listed further down in the page code. These prefs do not exist by default. <pre><nowiki>// pref string constants static const char kPrefCookieBehavior[] = "network.cookie.cookieBehavior"; static const char kPrefMaxNumberOfCookies[] = "network.cookie.maxNumber"; static const char kPrefMaxCookiesPerHost[] = "network.cookie.maxPerHost"; static const char kPrefCookiePurgeAge[] = "network.cookie.purgeAge"; static const char kPrefThirdPartySession[] = "network.cookie.thirdparty.sessionOnly"; static const char kCookieLeaveSecurityAlone[] = "network.cookie.leave-secure-alone";</nowiki></pre> You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config