Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

WebVR not working with Oculus Rift in Firefox 55.0.3 64-bit

  • 1 baphendule
  • 2 zinale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu Beerbaron23

more options

I'm trying to get WebVR working on my Rift in Firefox 55.0.3 64-bit. I put on my Rift and get the Oculus Home page in the Rift, switch over to Firefox with the mouse, click on a example (like https://threejs.org/examples/?q=webvr#webvr_cubes), and click on the "Enter VR" button. In the Rift, the Oculus home page fades out, and then fades right back in. That's it. On some VR-enabled pages I get "Firefox is taking a long time to load" in the Rift without any dialog boxes like I do with first-time running of Rift programs (I think that dialog comes from Kaspersky)

I've updated all my Nvidia drivers (385.41, on a GTX 970) and Oculus drivers (can't find the version; but updated earlier today), changed the Nvidia power settings for Firefox, rebooted, made sure Unknown Sources is enabled for Oculus, turned off anti-virus, etc., etc. It's getting frustrating. Any one know how to fix this problem, or have ideas on what I else I can try?

I'm trying to get WebVR working on my Rift in Firefox 55.0.3 64-bit. I put on my Rift and get the Oculus Home page in the Rift, switch over to Firefox with the mouse, click on a example (like [https://threejs.org/examples/?q=webvr#webvr_cubes]), and click on the "Enter VR" button. In the Rift, the Oculus home page fades out, and then fades right back in. That's it. On some VR-enabled pages I get "Firefox is taking a long time to load" in the Rift without any dialog boxes like I do with first-time running of Rift programs (I think that dialog comes from Kaspersky) I've updated all my Nvidia drivers (385.41, on a GTX 970) and Oculus drivers (can't find the version; but updated earlier today), changed the Nvidia power settings for Firefox, rebooted, made sure Unknown Sources is enabled for Oculus, turned off anti-virus, etc., etc. It's getting frustrating. Any one know how to fix this problem, or have ideas on what I else I can try?

Okulungisiwe ngu cor-el

All Replies (1)

more options

In your "about:support" is "Multiprocess windows" set to "Enabled"? and under "Compositing" does it say "Direct3D 11"? and on that page is your WebGL drivers loaded?