X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Issue with hardware acceleration on firefox 55

Kuphostiwe

Since updating to firefox 55 videos show up as having two layers, a green and a pink one with one of them stretched below the viewport. I know that this is related to hardware acceleration, and that disabling it will fix the issue, but disabling hardware acceleration is not an option. Also I should note that my netbook is quite old, and that I have to turn on "media.hardware-video-decoding.force-enabled" and "media.wmf.skip-blacklist" in order to enable hardware acceleration.

Videos play correctly in firefox 54.0.1 and firefox 52.3.0 esr. My question is, does anyone know what changed between firefox 54 and 55 that caused this issue? Is it a regression or was there a change that removed support for older hardware? And is there any option I could change that could fix video playback on newer versions, or should I just stick with the old ones?

Since updating to firefox 55 videos show up as having two layers, a green and a pink one with one of them stretched below the viewport. I know that this is related to hardware acceleration, and that disabling it will fix the issue, but disabling hardware acceleration is not an option. Also I should note that my netbook is quite old, and that I have to turn on "media.hardware-video-decoding.force-enabled" and "media.wmf.skip-blacklist" in order to enable hardware acceleration. Videos play correctly in firefox 54.0.1 and firefox 52.3.0 esr. My question is, does anyone know what changed between firefox 54 and 55 that caused this issue? Is it a regression or was there a change that removed support for older hardware? And is there any option I could change that could fix video playback on newer versions, or should I just stick with the old ones?

Isisombululo esikhethiwe

Firefox v55 has been having problems with graphics drivers and protection programs.

Check out Firefox v56 beta, some of the issues with Intel drivers have been fixed. https://www.mozilla.org/en-US/firefox/beta/all/

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 27.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Eminye Imininingwane

Umnikazi wombuzo

(Image was 100kb bigger than the limit and failed to upload)

(Image was 100kb bigger than the limit and failed to upload)
FredMcD
  • Top 10 Contributor
4269 izisombululo 59864 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Firefox v55 has been having problems with graphics drivers and protection programs.

Check out Firefox v56 beta, some of the issues with Intel drivers have been fixed. https://www.mozilla.org/en-US/firefox/beta/all/

Firefox v55 has been having problems with graphics drivers and protection programs. Check out Firefox v56 beta, some of the issues with Intel drivers have been fixed. https://www.mozilla.org/en-US/firefox/beta/all/

Umnikazi wombuzo

Thank you for your reply. Unfortunately the issue persists in firefox 56.0b11. Also I'm using a netbook with an AMD C-70 APU so it's an AMD gpu not an Intel one, guess I should have mentioned it.

Thank you for your reply. Unfortunately the issue persists in firefox 56.0b11. Also I'm using a netbook with an AMD C-70 APU so it's an AMD gpu not an Intel one, guess I should have mentioned it.
FredMcD
  • Top 10 Contributor
4269 izisombululo 59864 izimpendulo
Kuphostiwe

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.


Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.adobe.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know. --------------------- Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Impendulo Ewusizo

Why did you even bother posting a generic response? As I said, turning hardware acceleration off is not an option, I'll stick with older versions of firefox if I can't find a fix.

Why did you even bother posting a generic response? As I said, turning hardware acceleration off is not an option, I'll stick with older versions of firefox if I can't find a fix.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

This is not an issue that suddenly occurs with Firefox 55 - guess you could say that you've been lucky not to have encountered this phenomenon so far. When you 'google' this 'green/purple' problem, you'll see that this goes back years and years :

https://www.google.nl/search?q=in+firefox%3A+videos+are+green+and+a+pink+&oq=in+firefox%3A+videos+are+green+and+a+pink+&gs_l=psy-ab.3...24811.54249.0.55686.48.40.0.0.0.0.876.4227.29j9j6-1.39.0....0...1.1.64.psy-ab..21.0.0.eeSceMuwrLw

And yes, turning off hardware acceleration will fix it, as you already mentioned yourself. FredMcD's post merely emphasizes the importance ...... Sorry to hear that it's no option for you.

This is not an issue that suddenly occurs with Firefox 55 - guess you could say that you've been lucky not to have encountered this phenomenon so far. When you 'google' this 'green/purple' problem, you'll see that this goes back years and years : https://www.google.nl/search?q=in+firefox%3A+videos+are+green+and+a+pink+&oq=in+firefox%3A+videos+are+green+and+a+pink+&gs_l=psy-ab.3...24811.54249.0.55686.48.40.0.0.0.0.876.4227.29j9j6-1.39.0....0...1.1.64.psy-ab..21.0.0.eeSceMuwrLw And yes, turning off hardware acceleration will fix it, as you already mentioned yourself. FredMcD's post merely emphasizes the importance ...... Sorry to hear that it's no option for you.

Umnikazi wombuzo

Although it working in the betas, it seems fine in firefox 56, so unless if something changes between now and the official release of firefox 56 consider this problem solved.

Although it working in the betas, it seems fine in firefox 56, so unless if something changes between now and the official release of firefox 56 consider this problem solved.