Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The connection used to fetch this resource was not secure

  • 8 uphendule
  • 7 zinale nkinga
  • 6343 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Using firefox 45.8.0 ESR on Windows.

Trying to load https://secure.scheduleonce.com/dana

The page doesn't load, and in the network panel I see a crossed padlock icon instead of green padlock icon for this request: OPTIONS https://cfproxy.scheduleonce.com/get-data/GetLandingPageLayout

on Chrome / Safari / IE and even more recent version of FF this page loads fine without any problems.

Is there any way to debug what's wrong with that reques to resource exactly ? FF doesn't give me any information as to what went wrong.

I suspect it might be related to the fact it's a preflight CORS request (the requested domain is different than that hosted page domain).

Please help.

Thanks.

Attaching HAR file of the network : https://www.dropbox.com/s/i59k66a2w8p3ast/Archive%2017-09-10%2007-06-15.har?dl=0

Can be viewer here: (https://toolbox.googleapps.com/apps/har_analyzer)

Thanks.

Isisombululo esikhethiwe

Problem was with the cipher suite choice on the server.

I used this site to change it: https://mozilla.github.io/server-side-tls/ssl-config-generator/

To support older browsers as well.

I don't know what was in FF 45.8.0 ESR that made it not respect the security of the server.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (8)

more options

I had no problem with; https://secure.scheduleonce.com/dana

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

more options

I can't load that website as well in Firefox 45.9.0 ESR.

If I compare the requests then I see that loading this JSON data fails because no POST request is send

OPTIONS /get-data/GetLandingPageLayout HTTP/1.1
Host: cfproxy.scheduleonce.com
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Access-Control-Request-Method: POST
Access-Control-Request-Headers: content-type
Origin: https://secure.scheduleonce.com
Connection: keep-alive
Cache-Control: max-age=0

In Firefox 55:

POST /get-data/GetLandingPageLayout HTTP/1.1
Host: cfproxy.scheduleonce.com
User-Agent: Mozilla/5.0 (X11; Linux i686; rv:55.0) Gecko/20100101 Firefox/55.0
Accept: application/json, text/plain, */*
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate, br
Content-Type: application/json;charset=utf-8
Referer: https://secure.scheduleonce.com/dana
Content-Length: 19
Origin: https://secure.scheduleonce.com
Connection: keep-alive
Cache-Control: max-age=0

POST data: {"linkName":"dana"}

I don't know why Firefox 45 isn't using a POST request.

If this is your website then try to ask advice at the Stack Overflow forum site, but I'm not sure if they would know why Firefox 45 works differently.

more options

Pre-flighted requests are not new enough to be the problem, but of course there could be a bug in Firefox 45. Could you try:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using the Windows run dialog or Start box (or system) search box. Paste the following and press Enter to execute it:

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like Sept2017, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

This is really a Firefox 45 ESR issue and creating a new profile doesn't work.

@Jeff: Do you know why Firefox 45 is using an OPTIONS request? The request headers look very different and Firefox 45 also doesn't send the POST data. The Request body is empty and when I try to resend the message I can't change the from OPTIONS type to POST (at least the new entry in the Network Monitor looks the same OPTIONS request).

more options

Sending an OPTIONS request is normal for some CORS requests. In this case, the page sends a POST with a content-type of application/json;charset=utf-8. That seems to trigger the OPTIONS request because it isn't one of the standard content types: https://developer.mozilla.org/docs/Web/HTTP/Access_control_CORS#Simple_requests

I don't know why it isn't sent every time. Maybe it's cached somehow?

But in Firefox 45, since you appear not to be getting a response to the OPTIONS request (if I understand the HAR), Firefox won't send a POST request.

more options

Thank you. It's not a cache / profile issue.

I am not sure it has to do with the fact that it's a CORS request that is failing, but I suspect it is. It might also have to do with the certificate of that requested website.

I have also posted a question here: https://stackoverflow.com/questions/46149048/preflight-cors-request-fail-on-some-versions-of-firefox

Okulungisiwe ngu mdzon

more options

Isisombululo Esikhethiwe

Problem was with the cipher suite choice on the server.

I used this site to change it: https://mozilla.github.io/server-side-tls/ssl-config-generator/

To support older browsers as well.

I don't know what was in FF 45.8.0 ESR that made it not respect the security of the server.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.