Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I stop a rogue search link opening up on new web pages instead of Firefox's page of favourite links?

  • 3 uphendule
  • 2 zinale nkinga
  • 11 views
  • Igcine ukuphendulwa ngu Happy112

more options

I am on Mac OS 10.7.5. I was sourcing a map and was asked to download an application to access it. Now when I open a new web page, that provider's search page opens up instead of my home page (still unaffected) or the Firefox "favourite links" page. Clicking "Open new web pages with my home page" in Firefox preferences does not change this.

Isisombululo esikhethiwe

Hi   ! Too bad you couldn't provide a link to that browser hijacker (for that's probably what it is). If you can give us a link or a name, that would be great. But it sure sounds like you've got malware, and here's what you should do :

Go to the 3-bar menu => Addons => Extensions and look for any unfamiliar or suspicious looking extensions, like e.g.:

SafeSearch Incognito SearchAssist Incognito

When you find any :   remove them.

Also look in : 3-bar menu (or 'Tools') => Options => Advanced => Network tab => Under : 'Offline Web Content and User Data'

However :   most malware will be 'hiding' somewhere , so let's run malware scans :

Further information can be found in this article :
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners.
They all work differently   -   what one program doesn't pick up, the other might.

Especially for Mac : https://www.malwarebytes.com/mac/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

Hi   ! Too bad you couldn't provide a link to that browser hijacker (for that's probably what it is). If you can give us a link or a name, that would be great. But it sure sounds like you've got malware, and here's what you should do :

Go to the 3-bar menu => Addons => Extensions and look for any unfamiliar or suspicious looking extensions, like e.g.:

SafeSearch Incognito SearchAssist Incognito

When you find any :   remove them.

Also look in : 3-bar menu (or 'Tools') => Options => Advanced => Network tab => Under : 'Offline Web Content and User Data'

However :   most malware will be 'hiding' somewhere , so let's run malware scans :

Further information can be found in this article :
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners.
They all work differently   -   what one program doesn't pick up, the other might.

Especially for Mac : https://www.malwarebytes.com/mac/

more options

Hi Happy112, your suggestion worked a treat!

Very many thanks

terrystone

more options

terrystone said

Hi Happy112, your suggestion worked a treat!

So glad everything is back to normal  ! Well done  !

Very many thanks

My pleasure  !