Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't get the You Tube site to open on just Firefox.

  • 9 uphendule
  • 11 zinale nkinga
  • 1370 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hi. I can't get You Tube to open on Firefox. All other sites work on Firefox and You Tube works on other browsers. If I click on a specific video saved to my favorites, it will play but the site itself doesn't show. Not sure what to do.

All Replies (9)

more options

What's your computer system and Firefox version?

What do you mean; it will play but the site itself doesn't show ?


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?

more options

Thank you for replying. I have a Lenovo C40-05, Windows 10, and have no idea what version of Firefox I have. I believe it's the latest but couldn't figure out how to find it. Sorry, fairly computer illiterate. What I meant is that the You Tube site just pulls up a blank page. If I go into a saved You Tube video, it plays but the background is blank, no comments, other videos, nothing. Apparently some one else is having the same problem as i saw on the Forum page.

more options

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Make sure you update Firefox to the latest version 55.0.3


https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

more options

OK, Firefox is up to date and it was to begin with. I removed You Tube as per your instructions. So do I now reload You Tube plus my passwords/settings or is there a problem with You Tube and Firefox?

more options

Give YouTube a try.

more options

Nope, still not working. As I said before, all other sites work and YouTube works on other search engines, just not Firefox.

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

I did all this then typed in YouTube in the address bar and the page is still blank. I don't think that's the issue. Did this get resolved for the other person that was having the same issue? I guess I will have to use Google Chrome to use YouTube until or if Firefox starts working.

more options

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.


Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also: