X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox text is grabbled after uprgade to 55.0.2

Kuphostiwe

Greetings,

I run gentoo linux, a few days ago, I've upgraded my firefox to 55.0.2 and since then, my ff screen looks like this: https://postimg.org/image/vbp14ybdb/ I tried using the binary version, the issue persists. any ideas what can cause this?

Thanks.

Greetings, I run gentoo linux, a few days ago, I've upgraded my firefox to 55.0.2 and since then, my ff screen looks like this: https://postimg.org/image/vbp14ybdb/ I tried using the binary version, the issue persists. any ideas what can cause this? Thanks.

Isisombululo esikhethiwe

ok, found the issue, there is an optimization named pgo. I've disabled it and rebuilt the firefox.

all works ok now. will report this to the distro maintainers.

thankd for the help.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 54.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/54.0.1/WINNT/en-US/

Izandiso

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Firefox Screenshots 6.6.0 (screenshots@mozilla.org)
  • Follow-on Search Telemetry 0.9.1 (followonsearch@mozilla.com)
  • Multi-process staged rollout 1.85 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Shield Recipe Client 1.0.0 (shield-recipe-client@mozilla.org)
  • Web Compat 1.1 (webcompat@mozilla.org)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Standard VGA Graphics Adapter
  • adapterDescription2:
  • adapterDeviceID: 0x0100
  • adapterDeviceID2:
  • adapterDrivers: vga framebuf vga256 vga64k
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 11001af4
  • adapterSubsysID2:
  • adapterVendorID: 0x1b36
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 6-21-2006
  • driverDate2:
  • driverVersion: 6.1.7600.16385
  • driverVersion2:
  • failures: [u'CP+[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.', u'CP+[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.', u'CP+[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.']
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'blacklisted', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR', u'type': u'env'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'blacklisted', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR', u'type': u'env'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Not using GPU Process since D3D11 is unavailable', u'type': u'env'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • indices: [0, 1, 2]
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'skia', u'ApzWheelInput': 1}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug_get OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (Software Adapter Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.2a250c8a0e15)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000000000) EGL_VERSION: 1.4 (ANGLE 2.1.0.2a250c8a0e15) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
FredMcD
  • Top 10 Contributor
4254 izisombululo 59575 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Umnikazi wombuzo

yes, the issue presists.

yes, the issue presists.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Maybe your graphics drivers need to be updated, see :

https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

If that doesn't solve the problem, would you try this please :

3-bar menu (or 'Tools') => Options => Advanced => General tab : under 'Browsing' : uncheck 'Use hardware acceleration when available'

Maybe your graphics drivers need to be updated, see : https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration If that doesn't solve the problem, would you try this please : 3-bar menu (or 'Tools') => Options => Advanced => General tab : under 'Browsing' : '''un'''check 'Use hardware acceleration when available'
cor-el
  • Top 10 Contributor
  • Moderator
17516 izisombululo 158398 izimpendulo
Kuphostiwe

It is possible that Firefox has a problem with the font that is used.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

It is possible that Firefox has a problem with the font that is used. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/en/Tools/Page_Inspector *https://developer.mozilla.org/en/Tools/Page_Inspector/How_to/View_fonts

Umnikazi wombuzo

Happy112 said

Maybe your graphics drivers need to be updated, see : https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration If that doesn't solve the problem, would you try this please : 3-bar menu (or 'Tools') => Options => Advanced => General tab : under 'Browsing' : uncheck 'Use hardware acceleration when available'

nope, didn't helped. my gpu driver was updated after that and not in the same day and the issue still persists.

that option is not available, probably disabled in the code by the maintainers of the distro.

''Happy112 [[#answer-1001854|said]]'' <blockquote> Maybe your graphics drivers need to be updated, see : https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration If that doesn't solve the problem, would you try this please : 3-bar menu (or 'Tools') => Options => Advanced => General tab : under 'Browsing' : '''un'''check 'Use hardware acceleration when available' </blockquote> nope, didn't helped. my gpu driver was updated after that and not in the same day and the issue still persists. that option is not available, probably disabled in the code by the maintainers of the distro.

Umnikazi wombuzo

cor-el said

It is possible that Firefox has a problem with the font that is used. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

but my issue is in the menu entries too (as can be seen in the screenshot above.) regardless, I've tried to change the fonts and it didn't solved the issue on hand.

''cor-el [[#answer-1001905|said]]'' <blockquote> It is possible that Firefox has a problem with the font that is used. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/en/Tools/Page_Inspector *https://developer.mozilla.org/en/Tools/Page_Inspector/How_to/View_fonts </blockquote> but my issue is in the menu entries too (as can be seen in the screenshot above.) regardless, I've tried to change the fonts and it didn't solved the issue on hand.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59575 izimpendulo
Kuphostiwe

Suggestion; install Firefox v54 until you can Update Firefox to the latest version 55.0.3

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Suggestion; install Firefox v54 until you can Update Firefox to the latest version '''55.0.3''' https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here. If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues. You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

Isisombululo Esikhethiwe

ok, found the issue, there is an optimization named pgo. I've disabled it and rebuilt the firefox.

all works ok now. will report this to the distro maintainers.

thankd for the help.

ok, found the issue, there is an optimization named pgo. I've disabled it and rebuilt the firefox. all works ok now. will report this to the distro maintainers. thankd for the help.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59575 izimpendulo
Kuphostiwe

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.