Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

S.O.S. HTML-video H.264 not working Firefox (unlike Chrome

  • 3 uphendule
  • 9 zinale nkinga
  • 8856 views
  • Igcine ukuphendulwa ngu Minni

more options

Foreword: Note that in about:config this is TRUE: media.hardware-video-decoding.failed

But also this is TRUE: media.hardware-video-decoding.enabled

And this is FALSE: media.hardware-video-decoding.force-enabled

Here's an answer but it's not English. Anyone understand? https://www.youtube.com/watch?v=R4No4kv3TA8

HTML-video H.264 not working in Firefox 32-bit XP. So to compare, I tried youtube video's in Chrome, (cuz i wanted an update of the eclipse on PBS Note that the Eclipse video by Richard Aguilar DOES work in Firefox - but PBS eclipse & many others do not!) In Chrome, the PBS eclipse video does work but stutters, probably because Chrome imposes an animated chat-sidebar which is too much for the 32-bits to handle.

So basically I now cannot watch many of the up-to-date YouTube videos. This confounds me.

also note I found jscher's post which cites this test-site:

http://www.quirksmode.org/html5/tests/video.html - and the latter test-site DOES play OK for me.

I think I'll try RESETing firefox now, and see what happens, Does that make sense? Or anything else? Thanks.

Update:

I reset/refreshed firefox, but still remain with the problem. Upon research, I came across the below thread which MAY be a solution, BUT i don't understand it. Can someone please break it down into dummie-friendly terms, to enable me to get HTML-video working again in Firefox 32-bit XP?

Here, it is, please decipher?

http://www.msfn.org/board/topic/175591-enable-mp4-h264-aac-html5-video-in-firefox-on-windows-xp-without-flash/

Here's another. Does the below contain a solution?? It seems like it may, but not sure:

https://www.reddit.com/r/firefox/comments/3wu61r/prevent_firefox_from_disabling_h264_hardware/

Okulungisiwe ngu Minni

Isisombululo esikhethiwe

The solution posted here to add support for playing MP4 files involves to modify some prefs on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

This involves modifying some preferences on the about:config page.

media.gmp-eme-adobe.enabled (boolean, true)
media.gmp-eme-adobe.forceSupported (boolean, true; FF 49.0+)
media.gmp-eme-adobe.forcevisible (boolean, true; FF 45-48, no longer used in 49.0+)
media.gmp-eme-adobe.visible (boolean, true; FF 49.0+)
media.gmp.decoder.enabled (boolean, true)
media.eme.enabled (boolean, true)

Modify media.gmp-manager.url : change %VERSION% to 51.0 (use 46.0 for Firefox 45 ESR)

Firefox 52.xx ESR users need to remove the Primetime plugin if it is currently loaded. You can delete the gmp folders (gmp and gmp-gmpopenh264) in the profile folder.

  • Help -> Troubleshooting Information -> Profile Directory: Show Folder

You can toggle DRM off/on to make Firefox reload DRM components. Options -> Content: Play DRMOptions/Preferences -> Content: Play DRM

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (3)

more options

P.S. I'm uploading attachment for clarity

more options

Isisombululo Esikhethiwe

The solution posted here to add support for playing MP4 files involves to modify some prefs on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

This involves modifying some preferences on the about:config page.

media.gmp-eme-adobe.enabled (boolean, true)
media.gmp-eme-adobe.forceSupported (boolean, true; FF 49.0+)
media.gmp-eme-adobe.forcevisible (boolean, true; FF 45-48, no longer used in 49.0+)
media.gmp-eme-adobe.visible (boolean, true; FF 49.0+)
media.gmp.decoder.enabled (boolean, true)
media.eme.enabled (boolean, true)

Modify media.gmp-manager.url : change %VERSION% to 51.0 (use 46.0 for Firefox 45 ESR)

Firefox 52.xx ESR users need to remove the Primetime plugin if it is currently loaded. You can delete the gmp folders (gmp and gmp-gmpopenh264) in the profile folder.

  • Help -> Troubleshooting Information -> Profile Directory: Show Folder

You can toggle DRM off/on to make Firefox reload DRM components. Options -> Content: Play DRMOptions/Preferences -> Content: Play DRM

more options

Thanks - though I see that I'm probably not qualified (and too nervous) to tackle that.

Does this mean that low-end users are practically being forced now to upgrade to the latest speedy systems or else they soon won't be able to watch any videos? I.E. will all video's soon use that format?

Okulungisiwe ngu Minni