X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Add on icons not showing next to the search bar.

Kuphostiwe

So when I turned on my computer today I opened Firefox, and it updated like it does. Normally, this isn't an issue. When I opened it up today, however, all of my addons were disabled. I re-enabled them, but it didn't quite go back to normal. Normally, I keep the Adblock Plus and YouTube HD addons to the right of my search bar. But for whatever reason, I just can't get them to show like they're supposed to. Now, there's a magnifying glass on the right part of my search bar that wasn't there before, and anything I put to the right of the search bar is hidden and only accessible by clicking on the little arrow button and finding it in a context menu. I don't want the arrow button, I want the addons to be visible in the pane next to the search bar. And if anyone knows how to get rid of the magnifying glass, that would also be appreciated. Also worth mentioning is that the only addons I have that affect UI are Classic Theme Restorer and TabMixPlus.

Here is a screenshot: http://imgur.com/a/yqWAc

So when I turned on my computer today I opened Firefox, and it updated like it does. Normally, this isn't an issue. When I opened it up today, however, all of my addons were disabled. I re-enabled them, but it didn't quite go back to normal. Normally, I keep the Adblock Plus and YouTube HD addons to the right of my search bar. But for whatever reason, I just can't get them to show like they're supposed to. Now, there's a magnifying glass on the right part of my search bar that wasn't there before, and anything I put to the right of the search bar is hidden and only accessible by clicking on the little arrow button and finding it in a context menu. I don't want the arrow button, I want the addons to be visible in the pane next to the search bar. And if anyone knows how to get rid of the magnifying glass, that would also be appreciated. Also worth mentioning is that the only addons I have that affect UI are Classic Theme Restorer and TabMixPlus. Here is a screenshot: http://imgur.com/a/yqWAc

Isisombululo esikhethiwe

Your search bar is huge and seems to have eaten up all the available space, forcing everything else onto the overflow list (the >> icon). Or maybe I should blame the address bar, but I can't really get a sense of its current size...

You could try using the "Restore Defaults" button on the Customize tab. See: Customize Firefox controls, buttons and toolbars. It's at the bottom a little off center. But I'm not sure that will help.

The relative sizes of the address bar and search bar are stored in a file that sometimes becomes corrupted. Since it is difficult to edit, we generally suggest hiding it from Firefox so that Firefox generates a new one with default dimensions. Here's how.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Any improvement?

This procedure will hide the Menu Bar and Bookmarks Toolbar. To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there:

To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list.

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 26.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4192 izisombululo 58521 izimpendulo
Kuphostiwe

If an add-on is disabled, it will not show up on the toolbar.

Firefox v55 has been giving problems to many. I called for more help.

If an add-on is disabled, it will not show up on the toolbar. Firefox v55 has been giving problems to many. I called for more help.

Impendulo Ewusizo

No, the add ons are enabled, I re-enabled them when I opened up Firefox right after the update.

No, the add ons are enabled, I re-enabled them when I opened up Firefox right after the update.
jscher2000
  • Top 10 Contributor
8580 izisombululo 70167 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Your search bar is huge and seems to have eaten up all the available space, forcing everything else onto the overflow list (the >> icon). Or maybe I should blame the address bar, but I can't really get a sense of its current size...

You could try using the "Restore Defaults" button on the Customize tab. See: Customize Firefox controls, buttons and toolbars. It's at the bottom a little off center. But I'm not sure that will help.

The relative sizes of the address bar and search bar are stored in a file that sometimes becomes corrupted. Since it is difficult to edit, we generally suggest hiding it from Firefox so that Firefox generates a new one with default dimensions. Here's how.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old.

Start Firefox back up again. Any improvement?

This procedure will hide the Menu Bar and Bookmarks Toolbar. To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there:

To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list.

Your search bar is huge and seems to have eaten up all the available space, forcing everything else onto the overflow list (the '''>>''' icon). Or maybe I should blame the address bar, but I can't really get a sense of its current size... You could try using the "Restore Defaults" button on the Customize tab. See: [[Customize Firefox controls, buttons and toolbars]]. It's at the bottom a little off center. But I'm not sure that will help. The relative sizes of the address bar and search bar are stored in a file that sometimes becomes corrupted. Since it is difficult to edit, we generally suggest hiding it from Firefox so that Firefox generates a new one with default dimensions. Here's how. Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like xulstore.old. If you see a file named localstore.rdf, rename that one to localstore.old. Start Firefox back up again. Any improvement? This procedure will hide the Menu Bar and Bookmarks Toolbar. To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there: * right-click a blank spot on the tab bar (or the "+" button) * tap the Alt key to activate the classic menu bar > View > Toolbars * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list.

Umnikazi wombuzo

Thank you so much, that solved the issue. I did have to re-enable all of the toolbars, but that's not a big deal. My addon buttons are where I want them, so all is good.

Thank you so much, that solved the issue. I did have to re-enable all of the toolbars, but that's not a big deal. My addon buttons are where I want them, so all is good.