Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Set duckduckgo as default search engine.

  • 2 uphendule
  • 8 zinale nkinga
  • 32005 views
  • Igcine ukuphendulwa ngu bidwin

more options

I set duckduckgo as my default search engine in preferences but Google still comes up. How can I make duckduckgo my default search engine? Thanks.

Isisombululo esikhethiwe

Search Setting

The default search engine setting controls where searches go if you enter them through the address bar or search bar (both on the main toolbar). It also controls searches through Firefox's built-in home page and built-in new tab page.

That setting is the top one on the Preferences page Search panel. You can ignore the box lower down that shows all your available search engine plugins. Change your default search settings in Firefox.

After setting that to DuckDuckGo:

  • Does it work the first time?
  • Does it work until you quit Firefox, but changes at the next startup?
  • Is it always ignored?

Home Page

Firefox's home page setting controls the page or pages displayed in new windows, including the first new window at startup. If you get Google when you launch a new window (e.g., Command+n), you can change your home page to DuckDuckGo instead. See: How to set the home page.

Something Else is Going On!

Your startup page and search site can be modified by add-ons, particularly extensions. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All Mozilla-installed extensions are hidden from this page, so what you see listed here is your choice/your responsibility to enable, disable, or remove. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

Isisombululo Esikhethiwe

Search Setting

The default search engine setting controls where searches go if you enter them through the address bar or search bar (both on the main toolbar). It also controls searches through Firefox's built-in home page and built-in new tab page.

That setting is the top one on the Preferences page Search panel. You can ignore the box lower down that shows all your available search engine plugins. Change your default search settings in Firefox.

After setting that to DuckDuckGo:

  • Does it work the first time?
  • Does it work until you quit Firefox, but changes at the next startup?
  • Is it always ignored?

Home Page

Firefox's home page setting controls the page or pages displayed in new windows, including the first new window at startup. If you get Google when you launch a new window (e.g., Command+n), you can change your home page to DuckDuckGo instead. See: How to set the home page.

Something Else is Going On!

Your startup page and search site can be modified by add-ons, particularly extensions. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All Mozilla-installed extensions are hidden from this page, so what you see listed here is your choice/your responsibility to enable, disable, or remove. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

more options

Thanks, jscher2000, you've solved my problem. Never would have thought of setting the home page. Works now.