X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox process remainds and cannot be killed by any means

Kuphostiwe

Using Windows Vista. It happens many times. It becomes impossible to open any link. Nothing happens. Then closing Firefox a process remains. Using "end process" in task manager does not kill it and there is no message. Core dump from task manager attached.

Using Windows Vista. It happens many times. It becomes impossible to open any link. Nothing happens. Then closing Firefox a process remains. Using "end process" in task manager does not kill it and there is no message. Core dump from task manager attached.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Blue Jeans Installation Plugin
  • Blue Jeans Video Plugin
  • Citrix Online App Detector Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.121.2 for Mozilla browsers
  • Microsoft Lync Web App Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Pando Web Plugin
  • RBlue Jeans Installation Plugin
  • RBlue Jeans Video Plugin
  • Shockwave Flash 26.0 r0
  • 5.1.50906.0
  • Skype for Business Web App Plug-in
  • VLC media player Web Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Zoom launcher - 3.0.1

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0

Eminye Imininingwane

Umnikazi wombuzo

(no attachment, I though I can but only images can be attached)

(no attachment, I though I can but only images can be attached)
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Please update FF to ver 54 and lets see if that helps you out. https://support.mozilla.org/en-US/kb/update-firefox-latest-version If this solves your problem please com back and let us know and mark as solved.

Please update FF to ver 54 and lets see if that helps you out. https://support.mozilla.org/en-US/kb/update-firefox-latest-version If this solves your problem please com back and let us know and mark as solved.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Be aware that it is possible it is one of your numerious plugins that is causing this issue and Ver 54 will disable some if not most of these. And you may still have to go through this process. https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes

Be aware that it is possible it is one of your numerious plugins that is causing this issue and Ver 54 will disable some if not most of these. And you may still have to go through this process. https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes

Umnikazi wombuzo

Thanks. How can I update to version 54? In the "About Firefox" window it says that my version 52.2.0 (32-bit) is the most up-to-date...

Thanks. How can I update to version 54? In the "About Firefox" window it says that my version 52.2.0 (32-bit) is the most up-to-date...
cor-el
  • Top 10 Contributor
  • Moderator
17694 izisombululo 160093 izimpendulo
Kuphostiwe

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect.

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar. *"3-bar" menu button -> Exit (Power button) *Windows: File -> Exit *Mac: Firefox -> Quit Firefox *Linux: File -> Quit ----- When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect. You can disable multi-process windows in Firefox by setting these prefs to false on the <b>about:config</b> page. *browser.tabs.remote.autostart = false *browser.tabs.remote.autostart.2 = false You can open the <b>about:config</b> page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config *http://www.ghacks.net/2016/07/22/multi-process-firefox/

Umnikazi wombuzo

Thanks cor-el. I have already tried all the above. Now I have uninstalled FF and deleted the program and data folders and reinstalled. Let's wait and see if it helps. Previous simple uninstall and reinstall did not help.

Thanks cor-el. I have already tried all the above. Now I have uninstalled FF and deleted the program and data folders and reinstalled. Let's wait and see if it helps. Previous simple uninstall and reinstall did not help.

Umnikazi wombuzo

I have uninstalled FF and deleted the program and data folders and reinstalled. It did not help. It still happens. I have a core dump, can I attach it somehow and can someone do anything with it? Looks to me this is a bug. Is there any chance of getting a fix for Vista? Is there a chance of knowing when this has began and be able to install a certain previous version that works?

I have uninstalled FF and deleted the program and data folders and reinstalled. It did not help. It still happens. I have a core dump, can I attach it somehow and can someone do anything with it? Looks to me this is a bug. Is there any chance of getting a fix for Vista? Is there a chance of knowing when this has began and be able to install a certain previous version that works?
cor-el
  • Top 10 Contributor
  • Moderator
17694 izisombululo 160093 izimpendulo
Kuphostiwe

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

What security software do you have? Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Umnikazi wombuzo

cor-el said

What security software do you have? Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

I use Avira anti-virus. It would not be really feasible to try it in safe mode, because then I will have to work in safe mode for a whole day until this happens.

''cor-el [[#answer-980341|said]]'' <blockquote> What security software do you have? Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 </blockquote> I use Avira anti-virus. It would not be really feasible to try it in safe mode, because then I will have to work in safe mode for a whole day until this happens.
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

Personally I would create a new Firefox profile, see if that runs fine, and then copy the most important data from the current profile. Refreshing Firefox is another way of doing this.

When deleting Firefox’s program and data folders (manually?) as you described, note that there is also a caching folder involved (AppData\Local), and that the best way to remove profile data is to use the Profile manager as outlined in these articles. If not (and when using only one profile), some profile data may remain and make an issue persist. Of course, if you need to keep some data such as bookmarks, passwords etc., back up your current profile folder. Refreshing Firefox will do this automatically for you.

Another thing you could do is remove your Avira product entirely and reboot the system to see if that makes any difference to the current setup.

Note that Firefox 54 is no longer supported in Windows Vista, so that explains why 52 displays as up-to-date.

If nothing helps, when did the issue start occurring, and could you trace that back to a particular Firefox version?

Personally I would [[Use the Profile Manager to create and remove Firefox profiles|create a new Firefox profile]], see if that runs fine, and then [[Recovering important data from an old profile|copy the most important data]] from the current profile. Refreshing Firefox is another way of doing this. When deleting Firefox’s program and data folders (manually?) as you described, note that there is also a caching folder involved (AppData\Local), and that the best way to remove profile data is to use the Profile manager as outlined in these articles. If not (and when using only one profile), some profile data may remain and make an issue persist. Of course, if you need to keep some data such as bookmarks, passwords etc., back up your current profile folder. Refreshing Firefox will do this automatically for you. Another thing you could do is remove your Avira product entirely and reboot the system to see if that makes any difference to the current setup. Note that Firefox 54 is [[Important - Firefox is ending support for Windows XP and Vista|no longer supported]] in Windows Vista, so that explains why 52 displays as up-to-date. If nothing helps, when did the issue start occurring, and could you trace that back to a particular Firefox version?

Umnikazi wombuzo

Found it! What the heck were they thinking when making such an option the default?! See attached.

Found it! What the heck were they thinking when making such an option the default?! See attached.
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

Thanks for feeding back. Does it also fix the issue of Firefox not responding to links? If so, could you please mark your reply as a solution?

Thanks for feeding back. Does it also fix the issue of Firefox not responding to links? If so, could you please mark your reply as a solution?

Umnikazi wombuzo

I am now thinking that in the attached snapshot "the program" is or supposed to be only the anti-virus itself. So let's see if this is indeed the problem.

I am now thinking that in the attached snapshot "the program" is or supposed to be only the anti-virus itself. So let's see if this is indeed the problem.

Umnikazi wombuzo

It was not that. Unchecking the options in Avira anti virus does not change the situation. Both the inability to end the process, and the reason to kill the process are there.

Some new idea: Maybe this has something to do with the fact that I have 2 Firefox running, each under a different Windows user? One is for work and one is for home use, and I am switching between them from time to time.

It was not that. Unchecking the options in Avira anti virus does not change the situation. Both the inability to end the process, and the reason to kill the process are there. Some new idea: Maybe this has something to do with the fact that I have 2 Firefox running, each under a different Windows user? One is for work and one is for home use, and I am switching between them from time to time.

Umnikazi wombuzo

P.S. I am working with these 2 user accounts for years. That has never been a problem. So if this for itself is a problem, it must be due to recent changes in Firefox.

P.S. I am working with these 2 user accounts for years. That has never been a problem. So if this for itself is a problem, it must be due to recent changes in Firefox.

Umnikazi wombuzo

Unfortunately, that is not it either. I tried without having Firefox running for the other user.

Unfortunately, that is not it either. I tried without having Firefox running for the other user.
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

Just some thoughts: note that if you deleted the data folders and reinstalled Firefox as a last step, multi-process will be enabled again in a new profile. Of course, make sure it is really disabled by checking about:support (Help > Troubleshooting Information) after changing the required preferences. Since several Vista users seem to have issues with multi-process (and resolved them this way), I would leave it disabled it while continuing to troubleshoot for a possible second cause of your problem.

If you can’t use Windows in its Safe Mode for a day, the alternative would be to temporarily remove Avira entirely instead. Don’t forget to reboot.

Multiple copies of Firefox for different user accounts should not be an issue at all.

Just some thoughts: note that if you deleted the data folders and reinstalled Firefox as a last step, multi-process will be enabled again in a new profile. Of course, make sure it is really disabled by checking about:support (Help > Troubleshooting Information) after changing the required preferences. Since several Vista users seem to have issues with multi-process (and resolved them this way), I would leave it disabled it while continuing to troubleshoot for a possible second cause of your problem. If you can’t use Windows in its Safe Mode for a day, the alternative would be to temporarily remove Avira entirely instead. Don’t forget to reboot. Multiple copies of Firefox for different user accounts should not be an issue at all.