Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot open Mozilla Firefox browser since a tab appears instead "https://www.malwarebytes.com/restorebrowser/index.html"

  • 3 uphendule
  • 3 zinale nkinga
  • 172 views
  • Igcine ukuphendulwa ngu Myrt

more options

For a while now I have been getting the above message when I try to open Mozilla Firefox. I have reinstalled Firefox and deleted Malwarebytes but the message persists. Below the tabs, it provides a long list of ways to "restore browser" purportedly detected during their last scan, which I have not attempted to correct. MF downloaded fine, but I cannot get to see the browser. Please provide a solution as simple as possible. This looks like malware to me.

link: https://www.malwarebytes.com/restorebrowser/index.html

Isisombululo esikhethiwe

UPDATE: The reason why I avoided following Malwarebytes suggestions was because I had scanned the latter and my direct scans revealed there was no malware, etc. After several attempts to open the Firefox browser and always receiving the above link/message, I became suspicious. I WAS WRONG! After I posted the above and having seen similar complaints elsewhere, I took another look and decided to independently follow their suggestions and it worked. Now I have a working browser for Mozilla Firefox. Too bad I had already uninstalled Malwarebytes. Since I am not an expert, I am not promoting the link and message but rather posting my experience.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (3)

more options

Isisombululo Esikhethiwe

UPDATE: The reason why I avoided following Malwarebytes suggestions was because I had scanned the latter and my direct scans revealed there was no malware, etc. After several attempts to open the Firefox browser and always receiving the above link/message, I became suspicious. I WAS WRONG! After I posted the above and having seen similar complaints elsewhere, I took another look and decided to independently follow their suggestions and it worked. Now I have a working browser for Mozilla Firefox. Too bad I had already uninstalled Malwarebytes. Since I am not an expert, I am not promoting the link and message but rather posting my experience.

more options

Hello,

You could start Firefox with a new profile to see if the issue persists.

You could also backup your bookmarks via the Library.

more options

Thanks for your quick reply. Above your suggestions, I had posted an update and how I had solved the problem. Initially, when I searched the link there were other similar inquiries and I became overly careful, thus my post here. In the end, all is well that ends well. Thanks again.