X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox is using so much ram and disk and its so slow sometimes

Kuphostiwe

Hello, from the last 2 updates firefox started to use SO MUCH ram, even if iam not doing anything, just a blank page it uses 800mb of ram! i tried safe mode and its the same and if i open more than 3 taps its start to use more than 1gb, thats so much and makes me to quit firefox but i was using it from 6 years, hope there is a fix. i formatted my laptop also, if there problem not going to be fixed iam going to use Chrome even tho iam using firefox from 5 years

firefox using 1000 mb with only 1 tab open!

Hello, from the last 2 updates firefox started to use SO MUCH ram, even if iam not doing anything, just a blank page it uses 800mb of ram! i tried safe mode and its the same and if i open more than 3 taps its start to use more than 1gb, thats so much and makes me to quit firefox but i was using it from 6 years, hope there is a fix. i formatted my laptop also, if there problem not going to be fixed iam going to use Chrome even tho iam using firefox from 5 years firefox using 1000 mb with only 1 tab open!
Ama-screenshot ananyekiwe

Okulungisiwe ngu Ragido

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 26.0 d0

Isisebenziso

  • Firefox 53.0.3
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/53.0.3/WINNT/en-US/

Izandiso

  • Adblock Plus 2.9.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • IDM Integration Module 6.28.12 (mozilla_cc3@internetdownloadmanager.com)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Stylish 2.0.7 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Download Scheduler 2.5.4 (dlScheduler@ext.net) (Akusebenzi)
  • YouTube Video and Audio Downloader 0.5.9 (feca4b87-3be4-43da-a1b1-137c24220968@jetpack) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2: NVIDIA GeForce 840M
  • adapterDeviceID: 0x0416
  • adapterDeviceID2: 0x1341
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 21091b0a
  • adapterSubsysID2: 21091b0a
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.962
  • driverDate: 3-8-2017
  • driverDate2: 5-17-2017
  • driverVersion: 20.19.15.4624
  • driverVersion2: 22.21.13.8233
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'GPU Process', u'name': u'GPU_PROCESS', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'runtime'}]}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'skia', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
bygabyga 15 izisombululo 171 izimpendulo
Kuphostiwe

Impendulo Ewusizo

As reference linux64 with a dozen tabs.

As reference [https://download.mozilla.org/?product=firefox-54.0-SSL&os=linux64&lang=en-US linux64] with a dozen tabs.

Umnikazi wombuzo

Can you explain more ? like right now iam only using 3 tabs and its using 1200 mb !

Can you explain more ? like right now iam only using 3 tabs and its using 1200 mb !
bygabyga 15 izisombululo 171 izimpendulo
Kuphostiwe

Your question is not answered. You didn't have to mark as solved.

It was for comparison for devs.

Your question is not answered. You didn't have to mark as solved. It was for comparison for devs.
Cyntil8ing 0 izisombululo 2 izimpendulo
Kuphostiwe

I'm having the same issue too. I had 4 tabs open. 1 was streaming twitch and 3 were static pages. I was using a little in excess 6GB. It doesn't happen outright though. It's like it gradually increases memory usage the longer one uses it.

I'm having the same issue too. I had 4 tabs open. 1 was streaming twitch and 3 were static pages. I was using a little in excess 6GB. It doesn't happen outright though. It's like it gradually increases memory usage the longer one uses it.

Umnikazi wombuzo

bygabyga said

Your question is not answered. You didn't have to mark as solved. It was for comparison for devs.

I didnt mark it, i dont know why that happend, any way thanks!

''bygabyga [[#answer-978601|said]]'' <blockquote> Your question is not answered. You didn't have to mark as solved. It was for comparison for devs. </blockquote> I didnt mark it, i dont know why that happend, any way thanks!
bygabyga 15 izisombululo 171 izimpendulo
Kuphostiwe

Cyntil8ing said

I'm having the same issue too. I had 4 tabs open. 1 was streaming twitch and 3 were static pages. I was using a little in excess 6GB. It doesn't happen outright though. It's like it gradually increases memory usage the longer one uses it.

Are you using windows too?

You could have a look in about:memory

To find the correct solution to your problem, we need some more non-personal information from you. Please do the following:

  1. Use ONE of these methods to open the Firefox Troubleshooting Information page:
    • Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
    • Type about:support into the Firefox address bar and press the enter key.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

''Cyntil8ing [[#answer-978604|said]]'' <blockquote> I'm having the same issue too. I had 4 tabs open. 1 was streaming twitch and 3 were static pages. I was using a little in excess 6GB. It doesn't happen outright though. It's like it gradually increases memory usage the longer one uses it. </blockquote> Are you using windows too? You could have a look in '''about:memory''' To find the correct solution to your problem, we need some more non-personal information from you. Please do the following: # Use ONE of these methods to open the Firefox Troubleshooting Information page: #* Click the menu button [[Image:New Fx Menu]], click on help [[Image:Help-29]] and select ''Troubleshooting Information''. #* Type '''about:support''' into the Firefox address bar and press the enter key. If you need further information about the Troubleshooting information page, please read the article [[Use the Troubleshooting Information page to help fix Firefox issues]].

Okulungisiwe ngu bygabyga

Cyntil8ing 0 izisombululo 2 izimpendulo
Kuphostiwe

bygabyga said

Cyntil8ing said
I'm having the same issue too. I had 4 tabs open. 1 was streaming twitch and 3 were static pages. I was using a little in excess 6GB. It doesn't happen outright though. It's like it gradually increases memory usage the longer one uses it.

Are you using windows too?

You could have a look in about:memory

To find the correct solution to your problem, we need some more non-personal information from you. Please do the following:

  1. Use ONE of these methods to open the Firefox Troubleshooting Information page:
    • Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
    • Type about:support into the Firefox address bar and press the enter key.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Sorry, I forgot to mention that. Yes. I am using windows 10 64 with up-to-date patches.

I'm at the "about:memory" and "about:support" pages. Did you want me to post something in particular or am I supposed to be looking for something in particular when it happens again?

Another bit of information that may be of use is that I fell asleep watching a stream and woke up to find that the stream was intermittent and was sluggish to respond with the memory hitting around 6GB. Prior to the patch, I did not have such issues.

I'll use FF again and see if I can recreate it. Seems like it only occurs after a few hours of usage.

''bygabyga [[#answer-978624|said]]'' <blockquote> ''Cyntil8ing [[#answer-978604|said]]'' <blockquote> I'm having the same issue too. I had 4 tabs open. 1 was streaming twitch and 3 were static pages. I was using a little in excess 6GB. It doesn't happen outright though. It's like it gradually increases memory usage the longer one uses it. </blockquote> Are you using windows too? You could have a look in '''about:memory''' To find the correct solution to your problem, we need some more non-personal information from you. Please do the following: # Use ONE of these methods to open the Firefox Troubleshooting Information page: #* Click the menu button [[Image:New Fx Menu]], click on help [[Image:Help-29]] and select ''Troubleshooting Information''. #* Type '''about:support''' into the Firefox address bar and press the enter key. If you need further information about the Troubleshooting information page, please read the article [[Use the Troubleshooting Information page to help fix Firefox issues]]. </blockquote> Sorry, I forgot to mention that. Yes. I am using windows 10 64 with up-to-date patches. I'm at the "about:memory" and "about:support" pages. Did you want me to post something in particular or am I supposed to be looking for something in particular when it happens again? Another bit of information that may be of use is that I fell asleep watching a stream and woke up to find that the stream was intermittent and was sluggish to respond with the memory hitting around 6GB. Prior to the patch, I did not have such issues. I'll use FF again and see if I can recreate it. Seems like it only occurs after a few hours of usage.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Hi   !

This could be caused by Multi-process (e10s)

If you are using e10s, you could turn it off as follows :

Type in the address bar about:config   (press Enter) (promise to be careful, if asked)

Type and search for the preferences :

browser.tabs.remote.autostart and set it's value to false   (default)

browser.tabs.remote.autostart.2 and set it's value to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

Hi &nbsp; ! This could be caused by Multi-process (e10s) If you are using e10s, you could turn it off as follows : Type in the address bar '''about:config''' &nbsp; (press Enter) (promise to be careful, if asked) Type and search for the preferences : '''browser.tabs.remote.autostart''' and set it's value to '''false''' &nbsp; (default) '''browser.tabs.remote.autostart.2''' and set it's value to ''' false''' Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

Umnikazi wombuzo

Happy112 said

Hi   ! This could be caused by Multi-process (e10s) If you are using e10s, you could turn it off as follows : Type in the address bar about:config   (press Enter) (promise to be careful, if asked) Type and search for the preferences : browser.tabs.remote.autostart and set it's value to false   (default) browser.tabs.remote.autostart.2 and set it's value to false Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

sadly that didn't help..

''Happy112 [[#answer-981164|said]]'' <blockquote> Hi &nbsp; ! This could be caused by Multi-process (e10s) If you are using e10s, you could turn it off as follows : Type in the address bar '''about:config''' &nbsp; (press Enter) (promise to be careful, if asked) Type and search for the preferences : '''browser.tabs.remote.autostart''' and set it's value to '''false''' &nbsp; (default) '''browser.tabs.remote.autostart.2''' and set it's value to ''' false''' Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart </blockquote> sadly that didn't help..
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Not sure what version of Firefox you are on but if not on version 34 please update to it https://support.mozilla.org/en-US/kb/update-firefox-latest-version Please try disabling some Extensions you are not using. Clear your cache and cookies can help Try Fat-Free Fox Extension But you should also check and follow this to make sure https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware

Not sure what version of Firefox you are on but if not on version 34 please update to it https://support.mozilla.org/en-US/kb/update-firefox-latest-version Please try disabling some Extensions you are not using. Clear your cache and cookies can help Try Fat-Free Fox Extension But you should also check and follow this to make sure https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

High RAM usage and slow performance could be caused by a corrupt session restore file that may remain unnoticed in tab behavior.

What you could do to rule this out:

  • When Firefox is open, save the current set of tabs using the Bookmark All Tabs context menu option on a tab.
  • Restart Firefox and open a new session, so avoid restoring previous tabs and windows by clicking the Restore Previous Session button when Show your home page is set in the General > Startup settings, or change the Show your windows and tabs from last time option to another one when chosen.
  • Close Firefox and make sure there is a sessionstore.js file in the associated profile folder after Firefox has completely finished unloading. (Use Help > Troubleshooting Information > Open Folder to find the profile folder.) That file should be rather small (several MBs max, I think) and a larger or even missing file when Firefox is closed may be suspicious. (You could also check this file‘s presence and size before starting the new session / as a first step, as this step will remove/overwrite it.)
  • Start Firefox, load the exact same tabs and let them actively load.

Does the problem still occur?

In case of this being the cause, the Browser Console in the Web Developer menu may also show Could not write session state file errors in the Logging tab.

High RAM usage and slow performance could be caused by a corrupt session restore file that may remain unnoticed in tab behavior. What you could do to rule this out: * When Firefox is open, save the current set of tabs using the ''Bookmark All Tabs'' context menu option on a tab. * Restart Firefox and open a new session, so avoid restoring previous tabs and windows by clicking the Restore Previous Session button when ''Show your home'' page is set in the General > Startup settings, or change the ''Show your windows and tabs from last time'' option to another one when chosen. * Close Firefox and make sure there is a ''sessionstore.js'' file in the associated profile folder after Firefox has completely finished unloading. (Use Help > Troubleshooting Information > Open Folder to find the profile folder.) That file should be rather small (several MBs max, I think) and a larger or even missing file when Firefox is closed may be suspicious. (You could also check this file‘s presence and size ''before'' starting the new session / as a first step, as this step will remove/overwrite it.) * Start Firefox, load the exact same tabs and let them actively load. Does the problem still occur? In case of this being the cause, the Browser Console in the Web Developer menu may also show ''Could not write session state file'' errors in the Logging tab.