Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox always opens my home directory structure instead of my preferred home page.

  • 4 uphendule
  • 1 inale nkinga
  • 10 views
  • Igcine ukuphendulwa ngu bygabyga

more options

Whatever I try (refresh Firefox, set home page, ...), every time I open my Firefox browser, my file directory structure is displayed instead of my preferred home page. I'm running Linux RHEL 7.3.

All Replies (4)

more options

check the Exec= line in your {/usr,~/.local}/share/applications/*-firefox-*.desktop

more options

bygabyga said

check the Exec= line in your {/usr,~/.local}/share/applications/*-firefox-*.desktop

Okay, it says:

Exec=sh -c 'firejail --noprofile --env=LD_PRELOAD="${LD_PRELOAD- }"

Any idea what to do next?

more options

riverfelix said

bygabyga said
check the Exec= line in your {/usr,~/.local}/share/applications/*-firefox-*.desktop

Okay, it says:

Exec=sh -c 'firejail --noprofile --env=LD_PRELOAD="${LD_PRELOAD- }" firefox "%u"'


Any idea what to do next?

more options

riverfelix said

Any idea what to do next?

contact redhat

untill then you could start firefox from the terminal unless there is a redhat alias for that too or just replace that Exec= with Exec=firefox %U in ~/.local/share/applications/*firefox*.desktop