Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Language add-ons no longer available in Firefox latest update 54.0

  • 4 uphendule
  • 9 zinale nkinga
  • 711 views
  • Igcine ukuphendulwa ngu AudeDL

more options

Help! All my language packages have been disabled while updating to Firefox 54.0: "Firefox was unable to find updates to your incompatible add-ons" and when I go to addons.mozilla.org, all language packages I need (including English! (GB)) show as "not available for Firefox 54.0". I'm a linguist so I really need them!! what shall I do? Do I have to go back to Firefox previous version?? Thanks for you help

Isisombululo esikhethiwe

Hi, Thank you for helping. Actually, although I got this error message right after the upgrade to Mozilla 54.0, and I didn't do anything to fix it, my language add-ons now appear again as active and I do have spell checking working ok. I don't know what happened, really!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options
more options

Isisombululo Esikhethiwe

Hi, Thank you for helping. Actually, although I got this error message right after the upgrade to Mozilla 54.0, and I didn't do anything to fix it, my language add-ons now appear again as active and I do have spell checking working ok. I don't know what happened, really!

more options

It can take some time to get all language packs compiled and be available. There are 6 platforms with about 90 locales and 90 language packs for each platform that need to be compiled and that are a lot of files. If you would update Firefox manually immediately when the new version gets released then you are more likely to get issues with updating a language pack. Dictionaries do not need to be updated apart from a possible compatibility change (max-version) when you would install a dictionary and thus there shouldn't be issues with spell checking dictionaries.

more options

Thank you Cor-el, good to know for future releases