Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Getting rid of a ghost network calendar entry among TB client's calendars

  • 2 uphendule
  • 1 inale nkinga
  • 22 views
  • Igcine ukuphendulwa ngu Cbhihe

more options

[ Context: TB 52.1.1 + Lightning on Ubuntu 14.04.5 (64bits) ]

Creating multiple calendars on TB clients, be them local of network based, is no problem.

HOWEVER: if for any reason I need to get rid of a subscribed network calendar entry, I cannot do that. The calendar file location can be a URL or a local file, e.g.: `///home/USER/.thunderbird/lng69e5t.default/calendar-data/SharedGit-cal.ics`

After unsubscribing from the network calendar its entry disappears from the TB client's list of claendars. After either host reboot or relaunch of TB on the host, the unsubscribed entries come back (unchecked). The result is that some clients have 12 unchecked entries (from previous unsubscriptions). They cannot get rid of them. (I found no reference to that issue after crawling the net for a good 20 minutes.)

How do I rid my TB clients from ghost network calendar entries after having unsubscribed the clients from those calendars ? Cheers, -ced

Okulungisiwe ngu Cbhihe

Isisombululo esikhethiwe

Bruce A. Johnson schrieb

[...] edit the prefs.js file in the Profile folder. Shutdown TB first, do not edit it while TB is running. Search for the calendar name. In my prefs.js file, I see 11 lines for each calendar. All those lines for a calendar have the same alphanumeric code. Delete them. Start Thunderbird and see if it is gone for good.

Thank you for yr answer, Bruce. In the end I reinstalled TB completely, 3 times. That was 3.5 hours of work on 3 hosts, due to the complexity of the requirements for users on each host. Importing old calendars was fine as well as everything else, but I made a mistake on one host's account (working against the clock and running tired), as I mistakenly created a network calendar instead of a local one. So I de-referenced it and was back to on the start line again, albeit only with one "ghost" calendar in that case. After some probing (translate deselect or select options unknown from me) in calendar properties, I finally hit the mark.

In trying to get rid of a ghost ("unsubscribed" but remaining ) calendar, do not forget to deselect "Switch this calendar on" in the property windows. I had never noticed this although it is very obviously located at top left of the calendar property window.

-ced

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

First, Backup the Thunderbird Profile folder so you won't lose anything if something should go wrong.

What I would suggest trying is editing the prefs.js file in the Profile folder. You have to shutdown Thunderbird first, do not edit it while Thunderbird is running.

Open prefs.js in a plain text editor. Search for the calendar name. In my prefs.js file, I see 11 lines for each calendar. All those lines for a calendar have the same alphanumeric code. Delete them.

Then start Thunderbird and see if it is gone for good.

more options

Isisombululo Esikhethiwe

Bruce A. Johnson schrieb

[...] edit the prefs.js file in the Profile folder. Shutdown TB first, do not edit it while TB is running. Search for the calendar name. In my prefs.js file, I see 11 lines for each calendar. All those lines for a calendar have the same alphanumeric code. Delete them. Start Thunderbird and see if it is gone for good.

Thank you for yr answer, Bruce. In the end I reinstalled TB completely, 3 times. That was 3.5 hours of work on 3 hosts, due to the complexity of the requirements for users on each host. Importing old calendars was fine as well as everything else, but I made a mistake on one host's account (working against the clock and running tired), as I mistakenly created a network calendar instead of a local one. So I de-referenced it and was back to on the start line again, albeit only with one "ghost" calendar in that case. After some probing (translate deselect or select options unknown from me) in calendar properties, I finally hit the mark.

In trying to get rid of a ghost ("unsubscribed" but remaining ) calendar, do not forget to deselect "Switch this calendar on" in the property windows. I had never noticed this although it is very obviously located at top left of the calendar property window.

-ced