Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

can't stay signed into my email accounts after recent update.

  • 5 uphendule
  • 1 inale nkinga
  • 20 views
  • Igcine ukuphendulwa ngu nush

more options

Why can't I stay signed into my email accounts since to most recent update?

All Replies (5)

more options

Generally speaking, Firefox keeps you signed into sites by preserving the site's cookies from visit to visit. (This assumes the site lets you stay logged in for an extended period of time by setting a persistent cookie; high security sites generally don't allow that.)

Some reasons that this might not be working:

(1) You're using a private window to visit the site (2) The site's cookies are getting cleared (3) The site's cookies have become corrupted

An update shouldn't change #1 or #2, but if you use any cookie-related add-ons, sometimes a change in Firefox will cause them to malfunction if they haven't been updating regularly themselves.


Meanwhile, these are general suggestions to try when Firefox stops working normally with a site:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

more options

One other thing: some sites may be sensitive to changes in your network settings, such as Yahoo! and sites on the AOL network. You may want to check your connection setting here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences

In the left column, click Advanced. Then on the right side, with the "Network" mini-tab active, click the "Settings" button. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

more options

I would like a simple solution to this problem - I'm not a techie. I had no problem with automatic sign in for my yahoo mail account until the last Firefox update.

more options

Hi nush, how far do you get? In other words, are you able to log into Yahoo by hand and stay logged in? The original poster had the problem that Yahoo kept kicking them back to login.

If you have a problem with either Firefox's password manager or an add-on password manager filling in your login, that's probably caused by something different. You might want to post a new question in that case:

https://support.mozilla.org/questions/new/desktop/fix-problems

Scroll down past article suggestions to continue with the form.

Please consider clicking the Share Data button to include at least a list of your extensions to show whether you have any disabled password managers.

more options

I had to log in by hand every time. However, I just solved the problem - it took a lot of digging in Mozilla Support but I found the answer. I'll explain it in case someone else has a similar problem. I clicked on the three bars on the upper left and went into Options and then Privacy and Security. Then I changed "Accept cookies from website" to Always (it was Never). That solved the problem - at least up until now. Before that I checked to see if there was a cookie for Yahoo Mail (there was). Good luck to anyone else who needs to solve this problem.