Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Website VUDU will not play my saved DVD purchases, I have to use Edge to see why?

  • 1 baphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu jscher2000

more options

I can get to the web site fine. I can log on fine. I can see all my DVD purchases. However when I attempt to watch one of my DVD's I just get VUDU's loading screen and loading last forever. I can never watch the movie. I have to switch to Microsoft's Edge to view the movies and the movies play fine. VUDU says movies should play in Firefox , but apparently they are wrong. I have the latest version of Firefox. I have : Open H264, Shockwave Flash, and Widevine add on's and set to always activate. It would appear I am missing something?

All Replies (1)

more options

I haven't used that service, but their FAQ sounds Firefox friendly.

Does your Firefox generally play all formats of HTML5 media? You can view YouTube's diagnostic page here and confirm that most of the boxes are blue (esp. H.264):

https://www.youtube.com/html5

Or if the site uses Flash, do you have any issues with Flash on Adobe's test page?

https://helpx.adobe.com/flash-player.html


If a site is generally known to work in Firefox, these are general suggestions to try when it fails to work:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)