X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox hangs on moving focus to address bar

Kuphostiwe

Firefox 53.0.3 (Windows 32-bit on 64-bit OS) hangs if I trying to move focus to address bar while any system tooltip for any element on currently opened page is shown. For example, a New Tab Page is opened. Then, I hover mouse cursor on one of a thumbnails, and a tooltip with target address appears. Then I press F6, and FF immediately stops responding and consumes about 45% of CPU so long time, that I can't wait so much (several hours), and I kill it's process. I tried to repeat it with "-safe-mode" command line option, and result is the same. The tooltip's rectangle stays on top of all windows until FF process is being killed.

Firefox 53.0.3 (Windows 32-bit on 64-bit OS) hangs if I trying to move focus to address bar while any system tooltip for any element on currently opened page is shown. For example, a New Tab Page is opened. Then, I hover mouse cursor on one of a thumbnails, and a tooltip with target address appears. Then I press F6, and FF immediately stops responding and consumes about 45% of CPU so long time, that I can't wait so much (several hours), and I kill it's process. I tried to repeat it with "-safe-mode" command line option, and result is the same. The tooltip's rectangle stays on top of all windows until FF process is being killed.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 25.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4269 izisombululo 59841 izimpendulo
Kuphostiwe

Start your Computer in safe mode. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Umnikazi wombuzo

Unfortunately, my Windows' safe mode currently doesn't work. What can I try else?

Unfortunately, my Windows' safe mode currently doesn't work. What can I try else?
FredMcD
  • Top 10 Contributor
4269 izisombululo 59841 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Windows Safe Mode does not work, or did you mean that Safe Mode didn't help? Perform a System File Check to fix corrupted system files '''Win 7, 8, 10, Vista:''' https://support.microsoft.com/en-us/kb/929833 '''Win XP:''' https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/system_file_checker.mspx?mfr=true Wiki - Windows 10 System File Check http://answers.microsoft.com/en-us/windows/wiki/windows_10-update/system-file-check-sfc-scan-and-repair-system-files/bc609315-da1f-4775-812c-695b60477a93

Umnikazi wombuzo

I mean, what I say. First case, of course!

I mean, what I say. First case, of course!
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect.

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems ---- When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect. You can disable multi-process windows in Firefox by setting these prefs to false on the <b>about:config</b> page. *browser.tabs.remote.autostart = false *browser.tabs.remote.autostart.2 = false You can open the <b>about:config</b> page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config *http://www.ghacks.net/2016/07/22/multi-process-firefox/
cor-el
  • Top 10 Contributor
  • Moderator
17571 izisombululo 158915 izimpendulo
Kuphostiwe

Sorry. I missed that you already tried Firefox Safe Mode.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:

If the Places Maintenance extension can't repair the places.sqlite database then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Sorry. I missed that you already tried Firefox Safe Mode. You can check for problems with the <b>places.sqlite</b> database (bookmarks and history) in the Firefox profile folder. *https://addons.mozilla.org/firefox/addon/places-maintenance/ See also: *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/en-US/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file If the Places Maintenance extension can't repair the places.sqlite database then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder. *keep a backup copy of places.sqlite in case a new places.sqlite database has to be created *http://kb.mozillazine.org/Unable_to_process_the_backup_file_-_Firefox You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox