Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't access my hotmail.com e-mail. SSL_ERROR_BAD_CERT_DOMAIN is what displays

  • 2 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu John99

more options

I have always been able to access my account from Mozilla, but yesterday it said error and now I cannot access it. What has happened, do I need to change my browser???? Thank you Sherry

All Replies (2)

more options

hi, unfortunately MS has misconfigured a security feature (OCSP stapling) on their servers and is sending you an expired assurance about the validity of their certificate to your firefox.

in order to resolve that, please enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.ssl.enable_ocsp_stapling. double-click it and change its value to false - this will degrade a security feature in firefox, so please revisit it in a couple of days again after microsoft has fixed their stuff and turn it back on again then...

more options

Microsoft who run hotmail have been having problems with expired security certificates on their servers.

There is a possibility that this error is generated by a fix they are trying to make. The only problem is that if it is not them making a fix but that you are looking at a none genuine site pretending to be Hotmail them you will be providing that none genuine site with your hotmail login details, which is clearly a security breach.

What happens and what error messages do you get if you try

  1. https://mail.live.com/
  2. https://157.56.198.220

If you get the error SEC_ERROR_OCSP_INVALID_SIGNING_CERT Then our current advice is

unfortunately MS has misconfigured a security feature (OCSP stapling) on their servers and is sending you an expired assurance about the validity of their certificate to your firefox.

in order to resolve that, please enter about:config into the firefox address bar (Accept any warning message you see) & search for the preference named security.ssl.enable_ocsp_stapling (type that in to the search bar). double-click it and change its value to false

- This will degrade a security feature in firefox, so please revisit it in a couple of days again after microsoft has fixed their stuff and turn it back on again then.