Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Spelling check isn't happening although I ticked it in the settings, and I have installed the dictionaries of the languages I use.

  • 6 uphendule
  • 3 zinale nkinga
  • 12966 views
  • Igcine ukuphendulwa ngu Happy112

more options

I have read all related post and tried the suggested solutions but didn't manage to solve the issue. In fact when I right-click in any text box containing more than one line, the menu doesn't even list the choice "check spelling", as explained here https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

I just installed Firefox (53.0.3) and I'm on Windows 10.

I am a linguist and I am coming back to Mozilla because, from previous experiences, it handles several languages much better than other browsers! Provided that I manage to activtae the language management option...... so thanks in advance for your help!

Isisombululo esikhethiwe

Your system details show that you have some language packs installed,   but have you considered installing a dictionary in the language(s) of your choice from here :

https://addons.mozilla.org/en-US/firefox/language-tools/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (6)

more options

Let's try this :
Type in the adress bar   about:config
(promise to be careful, if asked)
Type and look for the preference :
layout.spellcheckDefault
and you can set it's value to either :
Spell Checker Off :   0   (zero)
Check Only Multi-Line Input Boxes :   1
Check Multi and Single Line Input Boxes :   2

more options

Is the problem with one language? What about the others? What is your primary language on Firefox?

more options

Thank you for helping me.

Happy112, I did what you're suggesting already yesterday, as I read it in another question, and I set it to 2. I just checked, it's still like that.

FredMcD, none of my languages are corrected. My Firefox is displaying in English.

more options

Isisombululo Esikhethiwe

Your system details show that you have some language packs installed,   but have you considered installing a dictionary in the language(s) of your choice from here :

https://addons.mozilla.org/en-US/firefox/language-tools/

more options

That solved my problem! The missing dictionaries. I don't know why but I implied that a language package was including the dictionary...

I'm wondering why these things are not explained in the page https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker?

Anyway, thanks for your help.

more options

AudeDL said

That solved my problem! The missing dictionaries. I don't know why but I implied that a language package was including the dictionary... I'm wondering why these things are not explained in the page https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker? Anyway, thanks for your help.

You've got a point there   -   should be explained in that article. But I sure am glad that your problem is solved now   -   enjoy your
dictionaries   !

Okulungisiwe ngu Happy112