Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The firefox desktop goes to black screen, no its not my computer. it seems to be whatever website i'm on it happens. and it effects any and all tabs being used.

more options

fire fox desktop goes black. just the desktop not the task bar or taps on display, just the display. I checked my settings and scanned the fire fox program for virus found nothing. I need to shut-down and restart to get my screen back and of course anything that was being displayed is gone. It happens on any site I'm on at the time.

Isisombululo esikhethiwe

Either see if there are any updates for your graphics drivers; regardless of what you think - OR try disabling Hardware Acceleration and see if that helps.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (10)

more options

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

I doubt it's my graphic drivers since it happens within the fire fox web browser itself. It effects only the desktop or display area, the task bar is fine, sound is working, tabs still there and can be switched from one to another, just no picture. It seems to be random when it happens. Text, video or pictures doesn't matter. 5 minutes in or after a couple of hours doesn't matter.

more options

Is it happening in the Safe Mode?

more options

TyDraniu said

Is it happening in the Safe Mode?

I only used safe-mode for a short time, it was more annoying that the display area going black. It was deluged with pop-ups.

more options

Isisombululo Esikhethiwe

Either see if there are any updates for your graphics drivers; regardless of what you think - OR try disabling Hardware Acceleration and see if that helps.

more options

Have you tried to start your   computer   in Safe Mode   ?

See :   https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode

Also see :   Troubleshoot black screen problems

more options

I went to device manager and choice my graphic driver and did an update, also manually had fire-fox update itself as well after updating the driver. so far it's been 2 hours and no black display area yet.

more options

I have this exact issue as well. I have fully updated Win10 (Build 15063.483) and Updated NVidia drivers per Windows Update (369.09) for the Quadro 3000M. This issue seems to be Gtk+3 related. I'm currently running FF 52.2.1esr. This problem never occurred with Gtk+2 based 49.5esr.

more options

I have this problem too. Not very often, however. When it does happen, all tabs that were open will all be black even if they showed content moments before.

Restarting Firefox resolves it until it happens sometime in the future (usually weeks?).

Firefox 55.0.3 Windows 10 (10.0.15063) nVidia: 385.28 (current as of this writing)

Firefox is set to "use recommended settings" so hardware acceleration is probably enabled.

more options

lee_thompson said

I have this problem too. Not very often, however. When it does happen, all tabs that were open will all be black even if they showed content moments before. Restarting Firefox resolves it until it happens sometime in the future (usually weeks?). Firefox 55.0.3 Windows 10 (10.0.15063) nVidia: 385.28 (current as of this writing) Firefox is set to "use recommended settings" so hardware acceleration is probably enabled.

I have the same problem. At some point while using Firefox all tabs go blank. Only restarting Firefox helps.