Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Unable to process the backup file - recovered .json.lz4 files

  • 3 uphendule
  • 5 zinale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

I recently decided to re-install Windows 10 on my laptop. I used backup software by Western Digital called "WD SmartWare" to back up all of my files to an external drive.

After I deleted the partition and re-installed Windows 10, I discovered that the backup didn't install the AppData\Roaming folder for some reason (I've contacted them about this already) so I had no Firefox profile.

I tried a few data recovery programs and found lots of old bookmarks files with the .json.lz4 extension. Despite all of my efforts, Firefox is unable to import any of these files. I have a hard time believing they have ALL been corrupted during the deletion. Is there anything I can do to somehow fix the files or diagnose them better? I also tried restoring places.sqlite with similar problems.

All Replies (3)

more options

How old are these backup files?

If they were created by an old Firefox version then they might not be compatible with the current release.

If these are recent backups then check for issues with places.sqlite.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:

If the Places Maintenance extension can't repair the places.sqlite database then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Thanks for your suggestions. I have since been able to find a backup that worked correctly.

The files were all very recent, but the problem was that the space appeared to be re-used after they were deleted.

I used a binary editor to look at a valid bookmarks backup file and noticed it started with "mozLz40". I then started looking through my recovered files and found most of them had no resemblance to the valid file. Finally, I found one that did start with the same text and it worked correctly.

The takeaway for me from this is that just because I'm able to recover a file with the right name and size, it doesn't mean any of the content at all is correct. It seems many of the files were 100% overwritten.

I'm glad I got my bookmarks back, though.

The one other takeaway, I guess, is to double-check your backup before deleting your OS! I'm still not impressed that "WD SmartWare" doesn't include AppData\Roaming at all.

more options

If you use an undelete utility to recover deleted files then there is no guarantee that the clusters that are occupied by a recovered file haven't been reused in the meantime. This is especially the case when you recover files from weeks or months ago and there isn't much free space on the hard drive. With (large) binary files this is much harder to verify since only one corrupted cluster is enough to make the file useless.