X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Icons not displaying on Mac

Kuphostiwe

Hi there,

Certain icons are displaying as hex codes on my Mac. I've made sure that my advanced content settings allow pages to choose their own fonts. I've likewise made sure that gfx.downloadable_fonts.enabled in about:config is marked true.

I've restarted Firefox in Safe Mode and the problem persists.

I've read some information about inspecting the element, but I don't know what to look for. In opening the Web Console, I get this message in the inspector sheet: "Signal: error: {"type":"script","message":"Problem loading http://platform.twitter.com/oct.js","tagId":1491995}" tag.js:2:286 Signal: error: {"type":"wait","message":"ReferenceError: twttr is not defined","tagId":1491995} tag.js:2:286

I also see a message saying "Style sheet could not be loaded."

Any suggestions for me, team?

Thanks so much!

Hi there, Certain icons are displaying as hex codes on my Mac. I've made sure that my advanced content settings allow pages to choose their own fonts. I've likewise made sure that gfx.downloadable_fonts.enabled in about:config is marked true. I've restarted Firefox in Safe Mode and the problem persists. I've read some information about inspecting the element, but I don't know what to look for. In opening the Web Console, I get this message in the inspector sheet: "Signal: error: {"type":"script","message":"Problem loading http://platform.twitter.com/oct.js","tagId":1491995}" tag.js:2:286 Signal: error: {"type":"wait","message":"ReferenceError: twttr is not defined","tagId":1491995} tag.js:2:286 I also see a message saying "Style sheet could not be loaded." Any suggestions for me, team? Thanks so much!

Isisombululo esikhethiwe

Is it just Firefox doing it or your Mac itself?

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 25.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0

Eminye Imininingwane

Tomatoshadow2 20 izisombululo 242 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Is it just Firefox doing it or your Mac itself?

Is it just Firefox doing it or your Mac itself?

Umnikazi wombuzo

Hmm...now that I look, it FF and Chrome have the issue, but not Safari.

And it is a work machine...think it could be firewall-related?

Hmm...now that I look, it FF and Chrome have the issue, but not Safari. And it is a work machine...think it could be firewall-related?
Tomatoshadow2 20 izisombululo 242 izimpendulo
Kuphostiwe

Yeah, that could be possible, did you try to repair permissions for the Mac?

Yeah, that could be possible, did you try to repair permissions for the Mac?
Tomatoshadow2 20 izisombululo 242 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Here's a link to an apple discussion forum, with someone having a problem with MacOS Tiger. Let me know if this is a similar problem or if it's completely different. If it's different I'll do some more investigating for you.

https://discussions.apple.com/thread/394103?start=0&tstart=0

Here's a link to an apple discussion forum, with someone having a problem with MacOS Tiger. Let me know if this is a similar problem or if it's completely different. If it's different I'll do some more investigating for you. https://discussions.apple.com/thread/394103?start=0&tstart=0

Impendulo Ewusizo

OK, thanks! My machine runs Sierra, so my understanding is that it's all performed automatically.

I'll take a look at this and see what's up! Thanks for your help!

OK, thanks! My machine runs Sierra, so my understanding is that it's all performed automatically. I'll take a look at this and see what's up! Thanks for your help!

Umnikazi wombuzo

This isn't the same issue. It's not the desktop icons that aren't displaying, but browser-based icon images in FF and Chrome.

I've attached a photo, hope it helps!

This isn't the same issue. It's not the desktop icons that aren't displaying, but browser-based icon images in FF and Chrome. I've attached a photo, hope it helps!
Tomatoshadow2 20 izisombululo 242 izimpendulo
Kuphostiwe

Sorry about that, I will keep searching for you.

Sorry about that, I will keep searching for you.

Umnikazi wombuzo

Oh, please don't apologize! I'm very grateful for the assistance!

Oh, please don't apologize! I'm very grateful for the assistance!
Tomatoshadow2 20 izisombululo 242 izimpendulo
Kuphostiwe

Do you have any extensions installed?

Do you have any extensions installed?
Tomatoshadow2 20 izisombululo 242 izimpendulo
Kuphostiwe

Is this forum question related to your problem?

https://support.mozilla.org/en-US/questions/1015762

Is this forum question related to your problem? https://support.mozilla.org/en-US/questions/1015762
cor-el
  • Top 10 Contributor
  • Moderator
17473 izisombululo 157938 izimpendulo
Kuphostiwe

Special icons are usually supplied by a font that is downloaded from the server (@font-face) You may see little boxes with the hex code of the character if you do not have a font installed that covers this Unicode range.

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> Content : Fonts & Colors -> Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check gfx.downloadable_fonts.enabled on the about:config page page and make sure it is set to true (if necessary double-click the line to toggle its value to true).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Special icons are usually supplied by a font that is downloaded from the server (@font-face) You may see little boxes with the hex code of the character if you do not have a font installed that covers this Unicode range. Make sure you allow pages to choose their own fonts. *Options/Preferences -> Content : Fonts & Colors -> Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check <b>gfx.downloadable_fonts.enabled</b> on the <b>about:config</b> page page and make sure it is set to true (if necessary double-click the line to toggle its value to true). You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Umnikazi wombuzo

I've performed both of these things (allowing pages to choose own fonts; making sure gfx.downloadable_fonts.enabled is set to true), and no dice :(

I have Adblock Plus installed, Pocket, Feedly, Google Messenger,

I've performed both of these things (allowing pages to choose own fonts; making sure gfx.downloadable_fonts.enabled is set to true), and no dice :( I have Adblock Plus installed, Pocket, Feedly, Google Messenger,
cor-el
  • Top 10 Contributor
  • Moderator
17473 izisombululo 157938 izimpendulo
Kuphostiwe

Are there any font related error messages in the Web Console?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then always make sure such extensions do not block (wanted) content. There is security software that can interfere with loading content, so check that as well.

Are there any font related error messages in the Web Console? *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/Tools/Web_Console If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then always make sure such extensions do not block (wanted) content. There is security software that can interfere with loading content, so check that as well.

Umnikazi wombuzo

Aha! Now we're cooking with gas.

There are a number of font-related error messages in the Web Console.

In going into my Adblock preferences, though, I'm not sure how to make it not block wanted content. Could you provide any more detail around that?

Attached are two pictures - one showing some of the error messages I get, and one showing the Adblock preferences that I'm not sure how to manage.

Aha! Now we're cooking with gas. There are a number of font-related error messages in the Web Console. In going into my Adblock preferences, though, I'm not sure how to make it not block wanted content. Could you provide any more detail around that? Attached are two pictures - one showing some of the error messages I get, and one showing the Adblock preferences that I'm not sure how to manage.
Tomatoshadow2 20 izisombululo 242 izimpendulo
Kuphostiwe

Do you still get the error if you disable Adblock Plus?

Do you still get the error if you disable Adblock Plus?
cor-el
  • Top 10 Contributor
  • Moderator
17473 izisombululo 157938 izimpendulo
Kuphostiwe

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) where you see this happen?

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) where you see this happen?

Umnikazi wombuzo

The error still occurs when Adblock is disabled.

Here's an example of a site: http://www.sonos.com/en-us/support

The error still occurs when Adblock is disabled. Here's an example of a site: http://www.sonos.com/en-us/support
cor-el
  • Top 10 Contributor
  • Moderator
17473 izisombululo 157938 izimpendulo
Kuphostiwe

These icons are about the fontello font.

You can check the Network Monitor to see if this font is downloaded.

You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. Set devtools.fontinspector.enabled to true on the about:config page to enabled the Font tab. The icons are set via a pseudo class (:before)

These icons are about the fontello font. *http://suit.sonos.com/2.7.0/fonts/fontello/fontello.woff2 You can check the Network Monitor to see if this font is downloaded. You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. Set <b>devtools.fontinspector.enabled</b> to true on the <b>about:config</b> page to enabled the Font tab. The icons are set via a pseudo class (:before) *https://developer.mozilla.org/Tools/Page_Inspector *https://developer.mozilla.org/Tools/Network_Monitor