Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to get rid of Yahoo search engine?

  • 12 uphendule
  • 35 zinale nkinga
  • 24746 views
  • Igcine ukuphendulwa ngu GeorgeSaint

more options

I use google as startpage. I only use Google and potentially wiki as search engines, yahoo is not even to be found in the list. I have no addons or what ever that I know of that use Yahoo, neither have I installed anything that uses it.

Yet since a few days Yahoo has replaced my standard search engine (google) whenever I type in a search in the top-right textbox.

I've checked all settings and nothing has changed. Google is my standard searchengine still. In the list with search engines, there is no yahoo to be found.

So how the f... is yahoo being used as the search engine when I type something in?

It's even worse. This morning I was behind the PC and performed some google searches. I leave the PC for a few hours, come back and do a search... and suddenly Yahoo is my search engine without me having changed anything in the meantime? WTF?

What is causing it and how can I get rid of the disgusting Yahoo search that I absolutely hate?

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

In your screenshot, the "M" shield indicates the McAfee search plugin, which I guess uses Yahoo. If it keeps changing back to McAfee, you might need to disable your McAfee extension. If that doesn't restore control, please complain to McAfee!

But also, there are some reasons that your changes might not be carried over from one Firefox session to the next. This article lists a number of other potential culprits: How to fix preferences that won't save (if you don't mind some troubleshooting, you can save the Refresh for the last thing to try).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (12)

more options

Hi, open the Add-ons Manager (Ctrl+Shift+A) > Extensions/Plugins, and disable/remove anything 'Yahoo' that shouldn't be there.

You can also check your Firefox Desktop shortcut for corruption: Right click on it > Properties, and in Target, make sure there is no sign of anything other than Firefox. If there is, delete that part of it. Or if it's easier, you can just delete it and recreate a new shortcut. More: Wrong home page opens when I start Firefox - How to fix.

Another thing you can do, is to search for Yahoo in your PC's search box and look for an installation date which matches when this started.

You can also try these free programs to scan for malware, which work with your existing antivirus software:

Note that not all removal programs will detect all malware, so you may need to run several or all of them.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

After removal you may need to reset your search, which you can do by running the add-on SearchReset.


Incidentally, you have 2 versions of Shockwave Flash - which can cause problems, so the oldest should be removed from your machine -

Did this fix your problems? Please report back to us. Thank you!

Okulungisiwe ngu Scribe

more options

Isisombululo Esikhethiwe

In your screenshot, the "M" shield indicates the McAfee search plugin, which I guess uses Yahoo. If it keeps changing back to McAfee, you might need to disable your McAfee extension. If that doesn't restore control, please complain to McAfee!

But also, there are some reasons that your changes might not be carried over from one Firefox session to the next. This article lists a number of other potential culprits: How to fix preferences that won't save (if you don't mind some troubleshooting, you can save the Refresh for the last thing to try).

more options

Stop resetting my default search engine to Yahoo. I do not like Yahoo, I do not use Yahoo. I even remove it in the advance options.

HOW DO I KEEP GOOGLE AS MY INITIAL SEARCH ENGINE?

How do I keep Firefox from adding Yahoo to my list of search engines(which should only have Google.

Stop forcing me to Yahoo.

more options

Itsune9tl said

Stop resetting my default search engine to Yahoo. I do not like Yahoo, I do not use Yahoo.

Firefox is designed to allow you to permanently select a different search engine. If yours doesn't work that way, there are a few different possible explanations:

(1) {Most Common} One of your extensions changes, overrides, or causes Firefox to ignore your default search engine setting

(2) Your change is lost between Firefox sessions because something external to Firefox is removing or rolling back the settings file that stores your preference, or the file is locked so your updates aren't actually saved, or Firefox does not have the necessary privileges to the profile folder (but this would affect other settings, too)

(3) Malware has inserted code into Firefox's program folder to make changes at startup

It's best to start your investigation from #1: You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. Don't limit your careful examination of this list to extensions that refer to Yahoo or to search, although those would be red flags. All Mozilla extensions are hidden from this list; everything here is your choice and your responsibility to use/disable/remove. If you do not recall installing it, if you have any doubt about its purpose, disable it.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

How do I keep Firefox from adding Yahoo to my list of search engines(which should only have Google.

Don't worry about the box with search engine options for "one time use." The only important setting is the default search engine at the top of the page. Using Remove to completely clear the "one time" list may trigger a full reload of that area since Firefox seemingly doesn't like it to be blank. You could at least keep DuckDuckGo, for example.

more options

My default search engine is Google but "Safe browser Yahoo Search" appears each time I do a default search. How can I get rid of "Safe browser Yahoo Search" forever?

more options

Hi NeilGillespie, can you copy/paste the URL of the results page you end up on? Sometimes it has parameters that indicate the identity of the culprit.

Also:

If you start on https://www.google.com/ and do a search in the site itself, does your browser get hijacked to the other site, or does it only happen in Firefox's search bar/address bar?

Also:

Are you still running Windows XP?


Here's my suggested procedure for tracking down and cleaning up bad add-ons and other hijackers. I know it seems long, but it's really not that bad. (If you do not use Windows you can skip to #2.)

(1) Open the Windows Control Panel, Uninstall a Program. (On XP, Add/Remove Programs)

After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. (Not available in XP.) This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it.

Take out as much trash as possible here. If you're not sure, feel free to post program names or a screenshot of the list.

(2) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. All extensions are optional; the troublemaker might not be obvious from its name.

Often a link will appear above at least one disabled extension to restart Firefox to make the change effective. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

(3) You can search for remaining issues with the scanning/cleaning tools listed in the previously mentioned support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Hopefully that will flush anything on your system and in your Firefox that could be a problem.

more options

Re searching for google. (weird thing to try but...)

I'm not exactly sure what was happening, but trying to search google through the firefox browser search bar was bringing up Yahoo search, and the links for google, despite being set for for a google search. Doing the same thing on the Google site bare just brought up the link to google and a bunch of Google ads. However, the latest update seems to have fixed the problem. so it's all good. for me

Okulungisiwe ngu Itsune9tl

more options

Thanks jscher2000 and Itsune9tl. I believe the issue is fixed for now. Yes, I am still running Windows XP. I opened Firefox's Add-ons page and removed everything. Now Google opens as my default browser. Yesterday I opened a link in a trusted email. Turns out the the link was malicious and somehow installed "Safe browser Yahoo Search" even though my default search engine is Google.

more options

It's weird. It has not happened in a long time. But since a week or so it has happened twice already again. Though lucky not as bad as in the past,... for now.

This happened (I'm guessing) around the time FF changed and most addons recently became "outdated". The ONLY addon that is not outdated and thus has renewed itself (I've set all addons to auto updating) is McAfee's web advisor.

But see for yourself in the image below. "VEROUDERD" is Dutch for "outdated".

So it is almost definitely McAfee being responsible for this.

If this problem persists again, I'll probably need to repeat my chosen solution from earlier, which jscher2000 advised me in May. I had no issues anymore when I choose that solution, until thus recently.

(edited: removed typos)

Okulungisiwe ngu GeorgeSaint

more options

Oops typos above. Sorry about that. I need to go drink some coffee, I guess


P.S.

Ha darned... there is an edit button. I really need coffee I guess.

Okulungisiwe ngu GeorgeSaint

more options

Hallo   GeorgeSaint  !

Re : the legacy (verouderde - yes : 'outdated) add-ons :

The add-ons that are marked 'Verouderd' ('Legacy' in the English version of Firefox) haven't been updated by the developers and, unless they do update and migrate their add-ons to Webextensions), they won't work with Firefox 57+.

So you should try and contact the developers about this - if you want to keep using these addons with Firefox 57+.

Either that, or start a new thread and post a new question, if you like.


Re : the 'Yahoo problem' :

Would you please be so kind as to go over jscher2000's and Scribe's posts again  ? For this really sounds like you've been hijacked by search.yahoo.com

See : https://malwaretips.com/blogs/yahoo-toolbar-removal/

Okulungisiwe ngu Happy112

more options

Yes I know. I'm waiting for updates to come out. I've checked some of the developers websites already.

For now these add-ons still work though. But I'll keep an eye for replacing add-ons. Especially the YT addons would be a shame to loose as those are important for my video editing and ability to download YT videos.

But thanks for the post about it! --

And no... I dont have a Yahoo toolbar. I checked that already. It's just the McAfee addon that keeps pushing back the safesearch to a wrong setting, which by standard uses Yahoo safesearch instead Google safesearch.

It's not malware doing that. It's McAfee. Most obvious because it often happens when (I suspect) McAfee runs a background check on my system. Cant be sure as I'm not always aware McAfee is doing something and I dont always check which background program is doing anything.

Just a few days ago I also complete manually checked and cleaned Windows background processes and start-up routine. Mostly did that to speed up stuff. But there was nothing suspicious there either.

It's McAfee.

Okulungisiwe ngu GeorgeSaint