Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"Open all in tabs" behavior changed and now broken

  • 3 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu jscher2000

more options

Somewhere in recent Firefox history, yet another classic behavior was changed - probably for an inane "your own good" argument. I cannot find a way to revert it.

When I have a hierarchical bookmark set, there are groups of 10-15 links of frequently accessed sites. At the bottom of the group, is the choice to "Open All In Tabs" . . .

This *used* to load all the tabs in active pages. Now, it loads exactly one tab, and puts up empty tabs on all the other links. As I cycle through the tabs, it then goes off and loads each one.

I hate this behavior. I want the old behavior. I found a few references to about:config changes for max_concurrent_tabs (set to -1) and restore_session behavior, but nothing is working.

How do I revert this "feature" to the correct, non-new (broken) behavior?

And please start posting a list of "feature improvements" that you force on users, so we can go back and fix the things that are changed for no apparent reason and break our usage models.

All Replies (3)

more options

My Firefox 53 on Windows hasn't changed. Every tab loads (I only tried a folder containing five).

Do you use any tab-related extensions that might be overriding the traditional behavior?

more options

I am running Firefox 53.0 on Linux (Fedora 24, Cinnamon).

I am not running any extensions that alter Tab behavior.

It doesn't work, and hasn't for a couple of versions. I finally got fed up enough with the behavior to ask for how to fix it before abandoning Firefox entirely.

A lot of the changes of the past few releases are breaking major parts of the Internet, and enterprise applications like SAP. I'm about done with the arbitrary decision processes involved here.

more options

Let me recap what you're describing to see whether I understand it.

  • You have a bookmark folder with 10-15 bookmarks in it.
  • Below the 10-15 bookmarks, you click Open All in Tabs.
  • 10-15 tabs open, but only the current tab actually loads the page.
  • The others load only on demand when you view the tab.
  • This odd behavior started for you several versions ago.

I haven't heard of that. The only on-demand loading I know about is when you restore a previous session. (As your research bore out.)


Are you sure it isn't caused by one of your extensions? As a quick diagnostic, you could test in Firefox's Safe Mode. In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (do not click Refresh).

Any difference? (More info: Troubleshoot Firefox issues using Safe Mode)


If it occurs even in Safe Mode, maybe it's a previously unmentioned side effect of Multiprocess??

Multiprocess. Recent versions of Firefox are migrating more users to a "multiprocess" architecture where the user interface and the web content are in separate processes to improve stability. Could you investigate:

Are you using Multiprocess (e10s)?

Multiprocess creates a second firefox.exe or plugin-container.exe process to isolate the web content from the browser UI. You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing problems, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?