X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF Update Add-ons Automatically won't stay off, and other wackiness

Kuphostiwe

Hi, I'm running FF 50 portable and I'm having a few problems. When I uncheck update add-ons automatically through the add-ons page or in about config when I restart FF it keeps re-enabling. Also when I restart, my yahoo homepage is bringing up a version that looks like it may have been from a few hours ago because emails that I've deleted are back. I've started FF without add-ons enabled and I get all the same problems. Another thing I noticed is I'm 99% sure that I've had update add-ons automatically selected before and whenever I restarted FF I never got a pop up saying that FF was trying to update the add-ons, which I'm getting now followed by a failed pop up. I really do not want to reset FF in any way, I've spent way too long getting it to the state I like it in.

Hi, I'm running FF 50 portable and I'm having a few problems. When I uncheck update add-ons automatically through the add-ons page or in about config when I restart FF it keeps re-enabling. Also when I restart, my yahoo homepage is bringing up a version that looks like it may have been from a few hours ago because emails that I've deleted are back. I've started FF without add-ons enabled and I get all the same problems. Another thing I noticed is I'm 99% sure that I've had update add-ons automatically selected before and whenever I restarted FF I never got a pop up saying that FF was trying to update the add-ons, which I'm getting now followed by a failed pop up. I really do not want to reset FF in any way, I've spent way too long getting it to the state I like it in.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4254 izisombululo 59579 izimpendulo
Kuphostiwe

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


CT71 said

Also when I restart, my yahoo homepage is bringing up a version that looks like it may have been from a few hours ago

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

'''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. ------------------ ''CT71 [[#question-1156725|said]]'' <blockquote> Also when I restart, my yahoo homepage is bringing up a version that looks like it may have been from a few hours ago </blockquote> Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe websites. Are there any problems? Then restart.

Umnikazi wombuzo

Ok, I am now beyond confused. I cleared cookies and cache, which I had also done before and forgot to mention that. Somehow my FF updated from 50 to 51 which I absolutely have set at not to update. The problems seem to have corrected themselves, but again, I have FF to not update. ???????

Ok, I am now beyond confused. I cleared cookies and cache, which I had also done before and forgot to mention that. Somehow my FF updated from 50 to 51 which I absolutely have set at not to update. The problems seem to have corrected themselves, but again, I have FF to not update. ???????

Umnikazi wombuzo

And I just checked my update history.......it shows zero updates have been made???

And I just checked my update history.......it shows zero updates have been made???
FredMcD
  • Top 10 Contributor
4254 izisombululo 59579 izimpendulo
Kuphostiwe

It's possible that a corrupt file was removed.

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

It's possible that a corrupt file was removed. Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced,''' Select '''Update.''' Check the settings.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59579 izimpendulo
Kuphostiwe

CT71 said

And I just checked my update history.......it shows zero updates have been made???

That means a clean install was done.

''CT71 [[#answer-960299|said]]'' <blockquote> And I just checked my update history.......it shows zero updates have been made??? </blockquote> That means a clean install was done.

Umnikazi wombuzo

FredMcD said

It's possible that a corrupt file was removed. Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update. Check the settings.

Never check for updates is still checked.

''FredMcD [[#answer-960300|said]]'' <blockquote> It's possible that a corrupt file was removed. Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced,''' Select '''Update.''' Check the settings. </blockquote> Never check for updates is still checked.

Umnikazi wombuzo

Also just checked my cookies and all the cookies that I had removed are back even though I haven't been back to those sites yet. More strangeness. I don't know, I guess I'm just gonna have to thank my lucky stars and take the wait and see approach to see if everything stays Ok from here on out.

Also just checked my cookies and all the cookies that I had removed are back even though I haven't been back to those sites yet. More strangeness. I don't know, I guess I'm just gonna have to thank my lucky stars and take the wait and see approach to see if everything stays Ok from here on out.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59579 izimpendulo
Kuphostiwe

You may have a corrupt cookies.sqlite file. Delete cookies.sqlite + cookies.sqlite.old + cookies.sqlite-shm + cookies.sqlite-wal

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

You may have a corrupt '''cookies.sqlite''' file. Delete '''cookies.sqlite + cookies.sqlite.old + cookies.sqlite-shm + cookies.sqlite-wal''' Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Folder.''' To its right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the above file. Then rename or delete it. Restart Firefox.

Umnikazi wombuzo

Thanks for your help on this matter, but as of right now I'm just gonna pretend like nothing ever happened and see what becomes of everything moving forward, lol. Thanks again, and I sure hope I don't have to re-examine this thread.

Thanks for your help on this matter, but as of right now I'm just gonna pretend like nothing ever happened and see what becomes of everything moving forward, lol. Thanks again, and I sure hope I don't have to re-examine this thread.