X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My Firefox ESR 45.4 does not have a "refresh firefox" button in the "troubleshooting information" screen. How can I refresh it?

Kuphostiwe

My firefox runs extremelly slow, except when in safe mode. I tried many times disabling or even removing all add ons, and it is still the same slowness. Something more must be happening when I start in safe mode, other than just disabling add ons. I'm getting mad. Please, anyone can help me?

My firefox runs extremelly slow, except when in safe mode. I tried many times disabling or even removing all add ons, and it is still the same slowness. Something more must be happening when I start in safe mode, other than just disabling add ons. I'm getting mad. Please, anyone can help me?

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 45.4.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/45.4.0/Linux/en-US/

Izandiso

  • Firefox Hello Beta 1.1.14 (loop@mozilla.org)
  • Ant Video Downloader 2.4.7.47 (anttoolbar@ant.com) (Akusebenzi)
  • Flash Video Downloader - YouTube HD Download [4K] 15.0.6 (artur.dubovoy@gmail.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Tungsten Graphics, Inc -- Mesa DRI Intel(R) 946GZ x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Intel(R) 946GZ x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Tungsten Graphics, Inc
  • driverDate:
  • driverVersion: 2.1 Mesa 8.0.5
  • info: {u'CairoUseXRender': 1, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No;
  • webglRenderer: Tungsten Graphics, Inc -- Mesa DRI Intel(R) 946GZ x86/MMX/SSE2
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
the-edmeister
  • Top 25 Contributor
  • Moderator
5412 izisombululo 40320 izimpendulo
Kuphostiwe

The Refresh button only appears in the Default Profile. So my guess is that the Profile you are using isn't the Default Profile.

The Refresh button only appears in the Default Profile. So my guess is that the Profile you are using isn't the Default Profile.

Umnikazi wombuzo

No, I'm using the default profile.

No, I'm using the default profile.
AliceWyman
  • Moderator
240 izisombululo 2598 izimpendulo
Kuphostiwe

The "default" profile is the last profile selected in the Firefox Profile Manager. Open the Profile Manager, select the profile you wish to refresh, and then use the "Start Firefox" button so that it becomes the "default" profile. When Firefox reopens, see if the "Refresh" option appears in the Troubleshooting Information (about:support) page and in the Firefox Safe Mode window.

See Profile Manager - Create, remove, or switch Firefox profiles for details on starting and using the Profile Manager. Since you appear to be on Linux, here are the instructions from that article for Linux:

If Firefox is already included in your Linux distribution or if you have installed Firefox with the package manager of your Linux distribution:

  1. If Firefox is open, close Firefox.
  2. In Terminal run:
    firefox -P

Note: The P is capitalized. Alternatively, you can use -ProfileManager instead of -P.
The Firefox Profile Manager (Choose User Profile) window should open.

Fx31ProfileManger-Lin

FYI, You will no longer need to do this when you update Firefox ESR to the next major version, which will be version 52 ESR available for download around March 7, 2017 . Starting in Firefox 49, a "Refresh Firefox" button now appears for non-default profiles on the about:support page and in the Safe Mode window. Related bug: Bug 1265368 - Stop restricting Firefox refresh to the selected/default profile (status-firefox49: --- → fixed)

The "default" profile is the last profile selected in the Firefox Profile Manager. Open the Profile Manager, select the profile you wish to refresh, and then use the "Start Firefox" button so that it becomes the "default" profile. When Firefox reopens, see if the "Refresh" option appears in the [[Use the Troubleshooting Information page to help fix Firefox issues|Troubleshooting Information]] (about:support) page and in the [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] window. See [[Use the Profile Manager to create and remove Firefox profiles]] for details on starting and using the Profile Manager. Since you appear to be on Linux, here are the instructions from that article for Linux: If Firefox is already included in your Linux distribution or if you have installed Firefox with the package manager of your Linux distribution: # If Firefox is open, close Firefox. # In '''Terminal''' run:<br/> <code>firefox -P</code> '''Note:''' The <code>P</code> is capitalized. Alternatively, you can use <code>-ProfileManager</code> instead of <code>-P</code>.<br> The Firefox Profile Manager (Choose User Profile) window should open. ;[[Image:Fx31ProfileManger-Lin]] ----- FYI, You will no longer need to do this when you update [https://www.mozilla.org/firefox/organizations/faq/ Firefox ESR] to the next major version, which will be version 52 ESR available for download around March 7, 2017 . Starting in Firefox 49, a "Refresh Firefox" button now appears for non-default profiles on the about:support page and in the Safe Mode window. Related bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=1265368 Bug 1265368] - Stop restricting Firefox refresh to the selected/default profile (status-firefox49: --- → fixed)
AliceWyman
  • Moderator
240 izisombululo 2598 izimpendulo
Kuphostiwe

Pericles_Vicente said

My firefox runs extremelly slow, except when in safe mode. I tried many times disabling or even removing all add ons, and it is still the same slowness. Something more must be happening when I start in safe mode, other than just disabling add ons.

Firefox Safe Mode also disables hardware acceleration. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Before you do anything else, you could try turning off hardware acceleration in your Firefox preferences:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
    Fx38AdvancedPanel-General
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.
''Pericles_Vicente [[#question-1156140|said]]'' <blockquote> My firefox runs extremelly slow, except when in safe mode. I tried many times disabling or even removing all add ons, and it is still the same slowness. Something more must be happening when I start in safe mode, other than just disabling add ons. </blockquote> Firefox Safe Mode also disables hardware acceleration. See [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] Before you do anything else, you could try turning off hardware acceleration in your Firefox preferences: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #;[[Image:Fx38AdvancedPanel-General|width=500]] #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist.
cor-el
  • Top 10 Contributor
  • Moderator
17591 izisombululo 159130 izimpendulo
Kuphostiwe

You can also check the profiles.ini file that is one level lower that the profile folder with the random name.

You should find the profiles.ini file in this hidden location:

  • Linux: *~/.mozilla/firefox/
  • Mac: *~/Library/Application Support/Firefox/
  • Windows: %AppData%\Mozilla\Firefox\
    *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Note that you are behind on updates. So please install or update to the current 45.7.0 esr version.

You can also check the profiles.ini file that is one level lower that the profile folder with the random name. *http://kb.mozillazine.org/profiles.ini_file You should find the profiles.ini file in this hidden location: *Linux: *~/.mozilla/firefox/ *Mac: *~/Library/Application Support/Firefox/ *Windows: %AppData%\Mozilla\Firefox\<br>*C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\ ---- Note that you are behind on updates. So please install or update to the current 45.7.0 esr version. *https://www.mozilla.org/en-US/firefox/organizations/all/ *https://www.mozilla.org/en-US/firefox/organizations/notes/ *https://www.mozilla.org/en-US/firefox/organizations/system-requirements/

Umnikazi wombuzo

AliceWyman said

The "default" profile is the last profile selected in the Firefox Profile Manager. Open the Profile Manager, select the profile you wish to refresh, and then use the "Start Firefox" button so that it becomes the "default" profile. When Firefox reopens, see if the "Refresh" option appears in the Troubleshooting Information (about:support) page and in the Firefox Safe Mode window. See Profile Manager - Create, remove, or switch Firefox profiles for details on starting and using the Profile Manager. Since you appear to be on Linux, here are the instructions from that article for Linux: If Firefox is already included in your Linux distribution or if you have installed Firefox with the package manager of your Linux distribution:
  1. If Firefox is open, close Firefox.
  2. In Terminal run:
    firefox -P
Note: The P is capitalized. Alternatively, you can use -ProfileManager instead of -P.
The Firefox Profile Manager (Choose User Profile) window should open.
Fx31ProfileManger-Lin

FYI, You will no longer need to do this when you update Firefox ESR to the next major version, which will be version 52 ESR available for download around March 7, 2017 . Starting in Firefox 49, a "Refresh Firefox" button now appears for non-default profiles on the about:support page and in the Safe Mode window. Related bug: Bug 1265368 - Stop restricting Firefox refresh to the selected/default profile (status-firefox49: --- → fixed)

''AliceWyman [[#answer-958797|said]]'' <blockquote> The "default" profile is the last profile selected in the Firefox Profile Manager. Open the Profile Manager, select the profile you wish to refresh, and then use the "Start Firefox" button so that it becomes the "default" profile. When Firefox reopens, see if the "Refresh" option appears in the [[Use the Troubleshooting Information page to help fix Firefox issues|Troubleshooting Information]] (about:support) page and in the [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] window. See [[Use the Profile Manager to create and remove Firefox profiles]] for details on starting and using the Profile Manager. Since you appear to be on Linux, here are the instructions from that article for Linux: If Firefox is already included in your Linux distribution or if you have installed Firefox with the package manager of your Linux distribution: # If Firefox is open, close Firefox. # In '''Terminal''' run:<br/> <code>firefox -P</code> '''Note:''' The <code>P</code> is capitalized. Alternatively, you can use <code>-ProfileManager</code> instead of <code>-P</code>.<br> The Firefox Profile Manager (Choose User Profile) window should open. ;[[Image:Fx31ProfileManger-Lin]] ----- FYI, You will no longer need to do this when you update [https://www.mozilla.org/firefox/organizations/faq/ Firefox ESR] to the next major version, which will be version 52 ESR available for download around March 7, 2017 . Starting in Firefox 49, a "Refresh Firefox" button now appears for non-default profiles on the about:support page and in the Safe Mode window. Related bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=1265368 Bug 1265368] - Stop restricting Firefox refresh to the selected/default profile (status-firefox49: --- → fixed) </blockquote>

Umnikazi wombuzo

Thanks, Alice and cor-el, but I've already tried this. Same problem remains. It's time for me to update my kernel (Wheezy, unable to go beyond firefox 45.4), but it won't be Debian Jessie, I'm going to Ubuntu Studio 16 as I work with audio production.

Thanks, Alice and cor-el, but I've already tried this. Same problem remains. It's time for me to update my kernel (Wheezy, unable to go beyond firefox 45.4), but it won't be Debian Jessie, I'm going to Ubuntu Studio 16 as I work with audio production.

Okulungisiwe ngu Pericles_Vicente

AliceWyman
  • Moderator
240 izisombululo 2598 izimpendulo
Kuphostiwe

In case it helps, you could try creating a new profile and then copy your important data to the new profile a little at a time - see Recovering important data from an old profile for details.

Another option would be to rename the ~/.mozilla/firefox/ folder that contains the profiles.ini file, to firefoxOLD (for backup purposes) which will create a new default profile as per http://kb.mozillazine.org/Creating_a_new_default_profile

In case it helps, you could try creating a new profile and then copy your important data to the new profile a little at a time - see [[Recovering important data from an old profile]] for details. Another option would be to rename the ~/.mozilla/'''firefox'''/ folder that contains the profiles.ini file, to '''firefoxOLD''' (for backup purposes) which will create a new default profile as per http://kb.mozillazine.org/Creating_a_new_default_profile