X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Autocomplete bar has just become thoroughly intrusive

Kuphostiwe

I just updated to ff 51.0.1. My autocomplete dropdown list of suggested sites that comes up when I start to enter an address in the bar is now HUGE, with stars, little site icons and lord knows what else. I HATE it. How do I get it back to the neat and tidy one I used to have - no stars, no nothing (it IS set not to show bookmarks already.) I just want the address of the few sites that would fit up there, with just WORDS ! In a smallish font, not about 28 as it seems to be now. I don't want to have to add in stylish or anything.... Is this the allegedly AWESOME bar ? Awesome it isn't.

I just updated to ff 51.0.1. My autocomplete dropdown list of suggested sites that comes up when I start to enter an address in the bar is now HUGE, with stars, little site icons and lord knows what else. I HATE it. How do I get it back to the neat and tidy one I used to have - no stars, no nothing (it IS set not to show bookmarks already.) I just want the address of the few sites that would fit up there, with just WORDS ! In a smallish font, not about 28 as it seems to be now. I don't want to have to add in stylish or anything.... Is this the allegedly AWESOME bar ? Awesome it isn't.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • GEPlugin
  • Google Update
  • Google Updater pluginhttp://pack.google.com/
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Picasa plugin
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 21.0 r0
  • VLC media player Web Plugin
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:51.0) Gecko/20100101 Firefox/51.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17538 izisombululo 158577 izimpendulo
Kuphostiwe

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* URLBAR autocomplete - drop down list */
#PopupAutoCompleteRichResult{
 width: 1000px !important;
 max-width: 1000px !important;
 margin-left: 0 !important;
/* margin-left: -20px !important; */
}

/* URLBAR autocomplete - border */
.autocomplete-richlistitem {padding-top:2px!important; padding-bottom:2px!important}
.autocomplete-richlistitem:not(:first-child) {border-top:1px solid #ddd!important}
.autocomplete-richlistitem[selected="true"] {border-top-color:transparent!important}

/* URLBAR font-size - drop down list */
.ac-title-text{font-size: 14px!important}
.ac-url-text  {font-size: 14px!important}
*|span.ac-emphasize-text {}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userChrome.css file in the editor window
  • make sure that the userChrome.css file starts with the default @namespace line
  • make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

You can use this button to go to the current Firefox profile folder:

Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* URLBAR autocomplete - drop down list */ #PopupAutoCompleteRichResult{ width: 1000px !important; max-width: 1000px !important; margin-left: 0 !important; /* margin-left: -20px !important; */ } /* URLBAR autocomplete - border */ .autocomplete-richlistitem {padding-top:2px!important; padding-bottom:2px!important} .autocomplete-richlistitem:not(:first-child) {border-top:1px solid #ddd!important} .autocomplete-richlistitem[selected="true"] {border-top-color:transparent!important} /* URLBAR font-size - drop down list */ .ac-title-text{font-size: 14px!important} .ac-url-text {font-size: 14px!important} *|span.ac-emphasize-text {} </nowiki></pre> ---- The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration *create the <b>chrome</b> folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *use a plain text editor like Notepad to create a (new) <b>userChrome.css</b> file in the chrome folder (file name is case sensitive) *paste the code in the userChrome.css file in the editor window *make sure that the userChrome.css file starts with the default <u>@namespace line</u> *make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.<br>otherwise Windows may add a hidden <i>.txt</i> file extension and you end up with a not working <i>userChrome.css.txt</i> file You can use this button to go to the current Firefox profile folder: *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Okulungisiwe ngu cor-el

Umnikazi wombuzo

Sadly I THINK I did all that right - I certainly always have hidden files showing anyway, and it DOES show up in the newly created chrome folder (which wasn't there before so surely I should be able to go back to how it was somehow ?) as a .css file, complete with little cog icon ! but it hasn't changed the HUGE bar I'm getting. (I HAVE managed to get rid of the bookmarks showing at least - I had unchecked them, but I guess that needed a browser restart.

MASSIVE font, clear across the width of the browser.... It used to be small, and only whatever width was needed for the longest suggested url... (It's the size of the font I REALLY hate...) My MAX size in options is 14; this is well over that.

Sadly I THINK I did all that right - I certainly always have hidden files showing anyway, and it DOES show up in the newly created chrome folder (which wasn't there before so surely I should be able to go back to how it was somehow ?) as a .css file, complete with little cog icon ! but it hasn't changed the HUGE bar I'm getting. (I HAVE managed to get rid of the bookmarks showing at least - I had unchecked them, but I guess that needed a browser restart. MASSIVE font, clear across the width of the browser.... It used to be small, and only whatever width was needed for the longest suggested url... (It's the size of the font I REALLY hate...) My MAX size in options is 14; this is well over that.