X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox won't open outlook when I click on an email link on a webpage though IE11 will even though Firefox is default browser

Kuphostiwe

I use windows 7 and for some reason Firefox 50.1.0 has stopped giving me the facility to click on a contact e-mail link in any web page so that microsoft outlook will open and allow me to use the e-mail link. IE11 has no issues with this but I'd rather use firefox which I have as default. Why will firefox no longer open outlook when I click on a link in a web page?

I use windows 7 and for some reason Firefox 50.1.0 has stopped giving me the facility to click on a contact e-mail link in any web page so that microsoft outlook will open and allow me to use the e-mail link. IE11 has no issues with this but I'd rather use firefox which I have as default. Why will firefox no longer open outlook when I click on a link in a web page?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 24.0 r0
  • 5.1.50901.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4254 izisombululo 59584 izimpendulo
Kuphostiwe

Type about:preferences#applications<enter> in the address bar. Look for mailto and press the button to its right.

Type '''about:preferences#applications'''<enter> in the address bar. Look for '''mailto''' and press the button to its right.

Umnikazi wombuzo

Outlook is selected in the mailto line but it still doesn't work and open outlook when an e-mail link is selected -unlike IE11which works perfectly for some reason

Outlook is selected in the mailto line but it still doesn't work and open outlook when an e-mail link is selected -unlike IE11which works perfectly for some reason

Okulungisiwe ngu neilcaine

FredMcD
  • Top 10 Contributor
4254 izisombululo 59584 izimpendulo
Kuphostiwe

Very odd.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Very odd. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Umnikazi wombuzo

Yes the problem is still there starting in safe mode, looks like I'll just have to copy the links, then open outlook and paste into the address bar! I just think it's strange that IE11 doesn't have this issue, does firefox have some kind of compatibility issue with outlook 2010?

Yes the problem is still there starting in safe mode, looks like I'll just have to copy the links, then open outlook and paste into the address bar! I just think it's strange that IE11 doesn't have this issue, does firefox have some kind of compatibility issue with outlook 2010?
FredMcD
  • Top 10 Contributor
4254 izisombululo 59584 izimpendulo
Kuphostiwe
Ask you question here also; https://support.microsoft.com http://answers.microsoft.com/en-US/windows/forum/windows_10
dmcentee 1 izisombululo 16 izimpendulo
Kuphostiwe

I have this problem too.

On my Windows 7 machine, where Windows Live Mail is my default mail program, Firefox 53.0 does open Live Mail correctly

On my Windows 10 machine, where MS Outlook 2016 is my default mail client Firefox does not open the email program. Yes, I checked in my options and Outlook is the default application for mailto

Very vexing.

Does anyone have a solution??

I have this problem too. On my Windows 7 machine, where Windows Live Mail is my default mail program, Firefox 53.0 does open Live Mail correctly On my Windows 10 machine, where MS Outlook 2016 is my default mail client Firefox does not open the email program. Yes, I checked in my options and Outlook is the default application for mailto Very vexing. Does anyone have a solution??
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

dmcentee said

On my Windows 10 machine, where MS Outlook 2016 is my default mail client Firefox does not open the email program. Yes, I checked in my options and Outlook is the default application for mailto

I have to start by saying that Windows 10 has some odd behaviors when it comes to default applications, and Firefox can't always work around them.

If you paste the following into the Windows search box or the Windows Run dialog and press Enter to submit it, does it launch a new message in Outlook?

mailto:someone@example.com?subject=Hello

Could you change your mailto setting on the Options page, Applications panel, to "Always Ask" and see whether Firefox displays a dialog with mail client choices when you click a link or when you paste the above into the address bar and press Enter to load it?

''dmcentee [[#answer-966682|said]]'' <blockquote> On my Windows 10 machine, where MS Outlook 2016 is my default mail client Firefox does not open the email program. Yes, I checked in my options and Outlook is the default application for mailto </blockquote> I have to start by saying that Windows 10 has some odd behaviors when it comes to default applications, and Firefox can't always work around them. If you paste the following into the Windows search box or the Windows Run dialog and press Enter to submit it, does it launch a new message in Outlook? mailto:someone@example''.''com?subject=Hello Could you change your mailto setting on the Options page, Applications panel, to "Always Ask" and see whether Firefox displays a dialog with mail client choices when you click a link or when you paste the above into the address bar and press Enter to load it?

Okulungisiwe ngu jscher2000

dmcentee 1 izisombululo 16 izimpendulo
Kuphostiwe

Thank you for your reply.

I changed mailto to 'always ask' --- and Firefox did as it was supposed to.

I changed mailto back to Outlook 2016 --- and presto, it works now.

I don't get it, but it appears to be fixed.

Thanks again.

p.s. I really, really dislike Windows 10. It seems like its raison d'être seems to be to force people to the 'store'. As far as I can see, it has not other value

Thank you for your reply. I changed mailto to 'always ask' --- and Firefox did as it was supposed to. I changed mailto back to Outlook 2016 --- and presto, it works now. I don't get it, but it appears to be fixed. Thanks again. p.s. I really, really dislike Windows 10. It seems like its raison d'être seems to be to force people to the 'store'. As far as I can see, it has not other value
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

dmcentee said

I don't get it, but it appears to be fixed.

The file that stores preferences set on the Options page, Applications panel sometimes becomes corrupted, and that probably straightened it out.

''dmcentee [[#answer-966698|said]]'' <blockquote> I don't get it, but it appears to be fixed. </blockquote> The file that stores preferences set on the Options page, Applications panel sometimes becomes corrupted, and that probably straightened it out.