Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How fix Google signin showing when Firefox starts instead of homepage

  • 11 uphendule
  • 3 zinale nkinga
  • 371 views
  • Igcine ukuphendulwa ngu FredMcD

more options

When I start Firefox I am frequently, not always, shown a Google sign in page instead of my homepage. I can't figure out how this is happening. I have searched the web for a solution, but have not hit on the right search argument to get any results. I would like to understand why this is happening and stop it. TIA for any help.

Isisombululo esikhethiwe

marcus.lycus said

https://accounts.google.com/ServiceLogin?passive=1209600&continue=https://accounts.google.com/o/oauth2/auth?access_type%3Doffline%26scope%3Dhttps://www.googleapis.com/auth/calendar%2Bhttps://www.googleapis.com/auth/tasks%2Bhttps://www.google.com/m8/feeds/%26response_type%3Dcode%26redirect_uri%3Dhttp://localhost:1064/authorize/%26client_id%3D70142480915.apps.googleusercontent.com%26from_login%3D1%26as%3D-2eb9ccb9017c57e6<mpl=embedded&oauth=1&sarp=1&scc=1#identifier

Apparently there is an application on your computer that interacts with your Google account (mail, calendar, tasks). If you try the address http://localhost:1064/ does it present any user interface identifying what that program is?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (11)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Google Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

more options

Thanks for the suggestion, Fred. I removed a Google Maps extension and a Google Earth plug in and restarted but still got the Google sign in the first time I opened Firefox. Didn't consider Google extensions/plug ins because they have been installed for quite some time and the start page issue is recent. Attached a screenshot of remaining extensions and plug ins. Based on the direction you pointed me to, I am going to try disabling the extensions one at a time and see if that yields results.

more options

Google Maps and Google Earth are safe so you can restore them.


Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display? Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want to be displayed?

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any webpage or about: page you want.

more options

What is your home page?

Firefox can be set to start up with multiple home pages, each in a separate tab. If you need to remove an unwanted home page, or to change your home page, check out this article: How to set the home page.

more options

Again, thanks for the suggestions. I don't think the home page settings are the problem. After some testing I realized that the Google sign in page is only displayed immediately after a boot. And Firefox is opened automatically, like it is part of Startup. After that first time, Firefox reverts to normal behavior and opens the designated home page. Until the next time Windows is started.

Here is what I have tried since last posting:

Disabled all Firefox extensions and plugins, one at a time, and rebooted after each. No change.

Checked startups using msconfig. Nothing unusual or unexpected.

Browsed Services. Disabled two Google Update services. No change.

Searched registry for "google". Found what appeared to be residue from applications used in the past: Picasa, Google Maps and Earth, etc.

Searched Firefox about:config for "google" and found entries for google safe browsing - a feature I discovered has been baked into Firefox for years. Don't know how to even test if it might be the culprit.

more options

Okay. This is what is happening. Somewhere in your system bootup, Google.com has been placed. Check these out;

Windows Start > All Programs > StartUp

Windows Task Scheduler.

more options

Hi marcus.lycus, what is the rest of the address? Usually a redirect URL is indicated as part of the signing page address, or the back button my have some history. That other URL may be the original request you need to track down and remove rather than the sign-in page itself.

more options

Fred - only startup I found was for my Windows Home Server. Task Scheduler never occurred to me. Found couple entries for Google Update. Disabled but had no effect on problem.

jscher - attached is URL for Google signin but don't understand what it is doing (back button greyed out):

https://accounts.google.com/ServiceLogin?passive=1209600&continue=https://accounts.google.com/o/oauth2/auth?access_type%3Doffline%26scope%3Dhttps://www.googleapis.com/auth/calendar%2Bhttps://www.googleapis.com/auth/tasks%2Bhttps://www.google.com/m8/feeds/%26response_type%3Dcode%26redirect_uri%3Dhttp://localhost:1064/authorize/%26client_id%3D70142480915.apps.googleusercontent.com%26from_login%3D1%26as%3D-2eb9ccb9017c57e6<mpl=embedded&oauth=1&sarp=1&scc=1#identifier

more options

Isisombululo Esikhethiwe

marcus.lycus said

https://accounts.google.com/ServiceLogin?passive=1209600&continue=https://accounts.google.com/o/oauth2/auth?access_type%3Doffline%26scope%3Dhttps://www.googleapis.com/auth/calendar%2Bhttps://www.googleapis.com/auth/tasks%2Bhttps://www.google.com/m8/feeds/%26response_type%3Dcode%26redirect_uri%3Dhttp://localhost:1064/authorize/%26client_id%3D70142480915.apps.googleusercontent.com%26from_login%3D1%26as%3D-2eb9ccb9017c57e6<mpl=embedded&oauth=1&sarp=1&scc=1#identifier

Apparently there is an application on your computer that interacts with your Google account (mail, calendar, tasks). If you try the address http://localhost:1064/ does it present any user interface identifying what that program is?

more options

The mystery is solved. The source of the problem is a calendar program that for some reason is set to sync with Google!? Suspect the program has become corrupted as it has been erratic since the last update. But Firefox and Google have nothing to do with the problem.

Anyhow, thanks FredMcD and jscher2000 for the repeated help which nudged me in the right direction.

more options

That was very good work. Well done.