Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox is not saving updated passwords

  • 17 uphendule
  • 4 zinale nkinga
  • 52 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Several months ago, Firefox stopped saving updated passwords. For instance, I have changed my Amazon password. Every time I go to Amazon it displays my old password (I can tell by the length), and after I manually enter the new password it asks if I want to update the saved password. I click yes but each time I go back it is still the same old password that is stored. This happens on many sites, not just Amazon.

All Replies (17)

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Thanks Fred. I checked for Advanced SystemCare and I don't have that and I don't remember installing any new protection/blocking/firewall type software since I initially set up my computer.

more options

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Then follow the directions.


Profile data can be removed or not recorded several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings; (Type about:preferences#privacy<enter> in the address bar.)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.

Are you using any password add-ons or programs?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Thanks again for the suggestions.

I ran the Add-on you suggested and it seemed to think everything was OK.

Not in Private Mode although "Use Tracking Protection in Private Windows" is checked. (I assume it always has been as I don't think I changed this setting)

Not using any addons at all.

Tried safe mode and the problem is still there.

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia


Use these links to create a new profile. Use this new profile as is. Is the problem still there?

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible


Type about:profiles<enter> in the address bar.

more options

Tried safe mode and creating a new profile and the issue is still exactly as before.

more options

I called for more help

more options

Did you install any extensions in the new profile or restored files from a previously used profile folder?

more options

No. Just created the new profile, left it as is and tried it immediately.

more options

This has been happening since the last update plus 2 I think. Checked all the things to check, read all the articles and questions, but god forbid the Sumo's accept that it's an error on Firefox's part and not the users. It IS actually saving the updated password, just not attaching it to any login, so it's worthless. To work around it until they finally experience it themselves and start to fix it, follow the instructions for Viewing Logins and Passwords (Options, Security, Saved Logins), select (by clicking) the line with the Login you want the correct password for, right click and select Edit Password and type in your new correct password.

more options

There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) you can find several add-ons that can override this, and give you better control of your password information. You can also try a Form Filling add-on.

more options

FredMcD said

There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) you can find several add-ons that can override this, and give you better control of your password information. You can also try a Form Filling add-on.

This is so tiresome.

It is NOT UPDATING ALREADY Saved Passwords. It is "saving" the new password, but since it is not attaching it to the appropriate login info, every time you go to the site, it has it as the old password, and you of course get their error. Kindly re-read the last sentence of the first paragraph of my above post.

I wrote that I had read all the articles, etc. This is NOT a particular website's issue, as it has occurred with too many to be so. It is in fact, a problem, that as stated, started occurring within the last couple of updates. I also know it is not a computer or OS problem as it has occurred on 2 totally different computers/systems for me (a desktop with Win XP and a laptop with 10), plus add in at least the original poster's system info.

more options

Hi kerryok5, could you try direct editing to see whether Firefox saves the change in that case? This would be on the Options/Preferences page:

Windows: "3-bar" menu button (or Tools menu) > Options Mac: "3-bar" menu button (or Firefox menu) > Preferences

In the left column, click Security. Then on the right side, find the "Saved Logins" button.

After opening that dialog, click the Show Passwords button. If you have set a Master Password (recommended!), enter your Master Password to display the Password column in the dialog.

To change a password, double-click it to make it editable, then type in the new value and tab out or click away from that box. Firefox should save the change immediately.

Does that work?

If that isn't saved either, I wonder whether there might be a problem with the file that stores saved logins (logins.json), but I'm reluctant to suggest manual tinkering because you might have to start from scratch with your bookmarks passwords.

Edit: whoops.

Okulungisiwe ngu jscher2000

more options

Hi jscher2000 I'm having the exact same problem. I tried to change the passwords manually, as per your instructions, and Firefox still isn't saving them. The new password shows up correctly under Saved Passwords, but when I try to login, it's still using the old password. I don't know what else to do.

more options

UPDATE - I went back to Saved Passwords and completely removed the old password updates, leaving only the newly changed password and it now works! Thank you and I hope this helps someone else.

more options

You can look at this extension to edit/correct entries in the Password Manager to see if they are saved this way. Note that you cam also double-click a name and password field in the Password Manager to edit this item (also via the right-click context menu accessible).

If that still doesn't work then check the logins.json file in a text editor to see if it contains empty lines or stray commas or lines that look corrupted if you compare them with others.

more options

SilverTrove That was very good work. Well done. Please flag your last post as Solved Problem so others will know.