Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox will not run

  • 12 uphendule
  • 4 zinale nkinga
  • Igcine ukuphendulwa ngu FredMcD

more options

I removed some adware-trojan with Windows Defender and Comodo firewall that had geekbuddy a program that malewarebytes found 254 adware entries from. So deleted the things and then could no longer connect to the internet. After fidling around and think the old xp winsock fix internet started working again. With explorer i can get online in 2 seconds.

Ones i try to start firefox then it wont run. I see it lower in the taskmanager between the processes firefox32bit, but it wont start to be on the top of task manager. 15-30 minutes after clicking open out of the blue it pops up if i'm lucky. And ones it started and i click open on my desktop icon then it immediately opens a new window with fox running fine.

Working on Win10 16 gb ram 8064p, so not an ancient slow computer fox ran like a ferarri before the trouble.

Taken actions: I uninstalled firefox, tried the reset and even tried to rename my profile to old 2. I also see a load of files in my firefox main folder. Tried to run Firefox portable but that wont run eighter. Yet that folder does not have all these api files in the main folder.

These are some of them, there are 40 of these api dll's in my folder api-ms-win-core-console-l1-1-0 api-ms-win-core-interlocked-l1-1-0 api-ms-win-core-processenvironment-l1-1-0

Install log shows win 8 while i am on win 10

Mozilla Firefox Installation Started: 2016-11-30 18:26:18

Installation Details

 Install Dir: C:\Program Files (x86)\Mozilla Firefox
 Locale     : nl
 App Version: 50.0.1
 GRE Version: 50.0.1
 OS Name    : Windows 8.1 (I have Win 10 Pro 64bit) = Firefox Setup Stub 50.0.1 (2)
 Target CPU : x86

Maybe this helps to locate the problem; Some Dutch info in there, am Dutch

  1. LOCALIZATION NOTE (CrashID): The %s is replaced with the Crash ID from the server, which is a string like abc12345-6789-0abc-def1-23456abcdef1

CrashID=Crash-ID: %s

  1. LOCALIZATION NOTE (CrashDetailsURL): The %s is replaced with a URL that the user can visit to view the crash details.

CrashDetailsURL=U kunt details over deze crash bekijken op %s ErrorBadArguments=De toepassing gaf een ongeldig argument mee. ErrorExtraFileExists=De toepassing heeft geen toepassingsgegevensbestand aangemaakt. ErrorExtraFileRead=Kan toepassingsgegevensbestand niet lezen. ErrorExtraFileMove=Kan toepassingsgegevensbestand niet verplaatsen. ErrorDumpFileExists=De toepassing heeft geen crashdumpbestand aangemaakt. ErrorDumpFileMove=Kan crashdump niet verplaatsen. ErrorNoProductName=De toepassing heeft zich niet geïdentificeerd. ErrorNoServerURL=De toepassing heeft geen crashrapportageserver gespecificeerd. ErrorNoSettingsPath=Kan instellingen van de crashreporter niet vinden. ErrorCreateDumpDir=Kan geen map voor dumps in wachtrij maken.

  1. LOCALIZATION NOTE (ErrorEndOfLife): The %s is replaced with the product name.

ErrorEndOfLife=De versie van %s die u gebruikt, wordt niet meer ondersteund. Crashrapporten voor deze versie worden niet meer geaccepteerd. Overweeg bij te werken naar een ondersteunde versie.

Before i reinstalled firefox i updated it, did not work, uninstalled Java then installed jre-8u111-windows-x64 Don't see Java between plugins or extentions eighter after reinstall.

I copied my Morzilla folder that is inside roaming about a month ago when all worked fine. So as last try i can remove firefox again, go into roaming folder and delete the Morzilla folder in there and replace it with the one i backed up 1 month ago. That is what i always do if i get a new computer. This computer has been working fine incl firefox for over a year. And as i explained IExplorer still works fine. So i fear that the trojan messed up firefox. Or the trojan makes firefox think that i am on Win 8 instead of win 10 and that is why i have this trouble. Right click on my computer still shows that i work on Win 10 Pro 64 bit. So if i try to download firefox then it should recognise my used version since i can not chose which version to download Firefox Setup Stub 50.0.1 is what i get, and again FirefoxPortableLegacy36 also will not start. So in some way firefox seems to be blocked.

But figure that wont change anything cos if that would work then firefox portable should be able to run as well since that is 2 or more years old not including recent extentions or plugins. So i wont do that for now, hope someone here knows a solution. And yep i did close the non starting firefox32bit in my taskmanager before trying to run the portable version

Before i reinstalled firefox i saw a warning that there was a pref.js file in firefox that was not made by firefox. Guess that was because then i did not have java installed and that pref file had a java icon so bet it belonged to java. After re install of fox and java i don't see that in the error text file

Hope this is enough info to get it fixed

Isisombululo esikhethiwe

Asking a new question about voice chat would be best.

Go to your response, and click the link to its right.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (12)

more options

First, let's make sure your system is clean.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link} Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory.

Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done.

If there is a problem, start your Computer in safe mode and try again.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

THANKS, for giving it a try to help me FredMcD Will give the links a read and try. Microsoft Safety Scanner running a full scan atm. Will get back ones i read and tested the links you offered. See we can't edit or reply, so outcome in next reply ;) Will wait till Microsoft Safty Scanner completes so i can add the thing it found. 1 3th now 250 000 files still only the 1 found thing.

Extra: I tried to install AVGfree cos i no longer trust Windows defender. But it would not install, guess because it detected defender, that came with the pc ones i bought it. Think 2 antivir on 1 pc wont work that is also why i fear the linked tools will not work but will try. Those tools are oem so i can not reinstall them after uninstalling them. Otherwise i would have uninstalled defender when i bought it as i always used AVG

I already used these: iExplore = to kill running processes. Malewarebytes = maleware removal i run that ones a week at least = up to date Windows Defender anti virus that found the trojan = up to date Windows_Doctor_2.9.0.0, Windows_Repair_Pro, WinUtilities_Professional_Edition_13.0.

And i have Advanced Systemcare 10 installed and driverbooster. Driverbooster also has an internet fix tool, but that hung when i tried that. Think winsock fix [reset] made internet work again for IE. Advanced systemcare also has an adblocker and maleware tool. All give a clean bill now, but will give the other tools a try as well as long as i don't need to install them. As then the tools might conflict with the tools that i have installed. So hope they are portable tools.

Cause: I bought a second hand hard disk 125 gb for 5 euro, from a dump store. Was full with porn so deleted all then did format. Should have done format without deleting the files first, lesson learned curiosity killed yet another mad cat haha Cheap ok, but caused me a lot of time grrr Because i think this was the cause, i have no had a virus on my computer in 8 or so years.

The problem started when audio chat stopped working on Facebook. Then i started to scan and found the bad guys. For downloads i need to turn off my addblockers else i can not download the needed tools. Been experimenting with VM Ware Player and Virtualbox running Mac OS on them on pc, successfully. I don't download that much on a regular bases but this month downed 250GB. So does not amaze me this happened grr. Learned a lot about running Mac on my PC, but did not expect this extra update lesson of Trojan removal haha. Uninstalled both virtualizers to be sure they did not cause it. As Virtualbox is by Oracle the same company that creates Java. So feared they had a conflict but uninstalling them didn't change a thing.

I tried Commodo firewall to try a new wall. And that had geekbuddy with it that malewarebytes saw as maleware. So uninstalled that after deleting the maleware. These were the cleaned badguys by the way, Trojan:w32/Suweezy and Mintluks.A Detected

Last ran scan; Microsoft Safety Scanner Time it took: 1;19 Amount scanned: 850 000 Found: 1 = BrowserModifier:Win32/Soctuseer, removed

Looking at your links first before closing my browser as i fear it will not start then. And i can now get and read your links on firefox. But this last missed thing is browser related looking at the name. So this might already have fixed it. Will report on that after doing you tests ;)

Just ran a last check with Microsoft Safety Scanner, that was advised by Windows to get Mintluks.A a deep check, Since you said try if there is nothing bad left, ran a complete scan and indeed found 1 already after scanning 500 files. Hope it wont close firefox as i am afraid i can't open it again. But got to fix this else i need to format and find a new win10 iso as my win7 got updated and i ended with win10, had it marked as don't install but win10 forced itself in while i updated. Now i have a legal Win bought with laptop. So hate to have to use an illegal windows again now that i finally got a legal version that i can keep up to date.

Non of the tools could fix the internet, so i went into settings and unmarked comodo firewall in the internet settings. Commodo is uninstalled but i still find it in settings and also deleted it from win start links 3 times already. After unselecting commodo in internet adapter settings the line and wifi were still not working. Then i turned think it is blue tooth off on the button on top of my laptop next to sound off. Then turned it on again and firefox opened out of the blue and my line and wifi were connected. No the buton was not off it was on i just turned it off then on again to see if it would reset that way. Just before it i used the winsock fix tool for xp. Normally xp soft wont run on win 10 but of that worked on the push of the button. So i figure winsock reset was the fix. Then you know the whole story, sorry for the lots of words but i figure every detail might give you a clue so give all details ;) And i bet you a laugh as indeed dumb mistake for a musician that has been working on computers since atari 1040 haha

Both problem files were located in non system files, the trojans came from OSX to USB and another mac hack tool. So am not that worried about that really. Figure this last one i found comes from the new hard drive that i got and it is an old one hench it was not found. So i fugure the trouble is because of comoda geekbuddy. That gave me 254 addware entries on malewarebytes, so fear that must be it since it left left ovvers in my internet settings. Perhaps comodo is still linked to fox and it can not find comodo so does not start before it searched my whole pc ? But the fan does not go on, so don't think it is searching, fan goes on at every other search or scan. So can be various things thats why i have a hard time with this one. Certainly because it only affects firefox. Pc starts fine works fine and net too ones i use IE ? So weird.

Reply back after reading your links

Indeed social2Search i removed as well took malewarebytes 3 scans to get rid of it, yet still a piece left

BrowserModifier:Win32/Soctuseer is a type of potentially unwanted program that may install other threats when run into the computer. This is a name given by Microsoft Security Software to identify computer threat that is linked to Social2Search adware or PUP. Unwanted programs are software that intends to implicate changes on the computer or browser without asking for user's approval. In this case, BrowserModifier:Win32/Soctuseer may install other adware, toolbars, browser redirect, and hijack the home page of affected browser. Threat behavior Installation

BrowserModifier:Win32/Soctuseer files and codes can be acquired by user from ranges of sources. Malicious links, spam email messages, or Peer-to-peer connection can lead to the infection. It may also be dropped onto your PC by threats like Trojans, viruses, or malware. Payload

When BrowserModifier:Win32/Soctuseer is present on the computer, it will make various changes. In particular, potentially unwanted programs are targeting Internet browsers like Internet Explorer, Google Chrome, and Mozilla Firefox. Changes will be carried out by BrowserModifier:Win32/Soctuseer by adding add-on, extension, or plug-in. This may result to the integration of toolbar or unknown search engine. Symptoms

Aside from mentioned changes on the PC, BrowserModifier:Win32/Soctuseer also installs files and folders. It can also make registry changes to load itself during Windows start-up.

This adware will display excessive advertisements from Social2Search

more options

Has your problem been fixed yet?

Remember that there are anti-virus scanners (which are most of the programs you were using), and there are malware scanners (and root scanners as well). These probe deeper into the computer then anti- virus scanners do.

more options

Kasterski TDSSKiller [Portable] Nothing found = 20 sec scan

Microsoft Safety Scanner [Install] Found 1 see above 1 hour 20 min scan

Malewarebytes [Install] found 1 PUP in java for Win10.exe, luckily i did not try to install that feld dodgy Jre was installed so let malewarebytes delete this one

SUPERAntiSpyware Portable Scanner [Mine installed paid = portable i guess] 6min 50sec

registry; 64 000 no error Memory; 827 no error Filescan; 203 Adware; 202 Cookies, half of them are in microsoft cookies rest in firefox cookies, cleaned all 1 PUP.Patcher/Variant.Process-1 = in Keygen [false pos probably, but got another free version so delete it]

adwcleaner_6.030 malewarebytes [portable] 1 minute scan

15 reg entries from firefox found firefox\naweri-cofise firefox\Profiles\my pro.default\extentions\ END folder, HKLM, HKU, HKCU

Ok after cleaning i downloaded the English version of firefox with explorer, not tried to start fox. Firefox Setup 50.0.2

Uninstall firefox Now i need to uninstall firefox, normally i'd use io uninstaller. but ok manual way C:\Program Files (x86)\Mozilla Firefox\uninstall\helper, click it to uninstall

i now run io uninstaller to check if there are left overs and it needs a deep scan Now morzilla found nor any left overs

Backup old profile firefox Now i need to rename my passwords, favorite folders .old At win 10 that is here C:\Users\Your account name\AppData\Roaming\Mozilla I already do this regularly, right click on morzilla and rar it, not delete after rar Then put todays date after the name firefox, that is how you can make backups. After you install a new firefox, rar the morzilla folder, name original. Unrar your backup take date from name so it only says morzilla and it will work with favs and passwords Now as the tutor says .old

Mozilla\Extentions.old Mozilla\Firefox\Crash Reports.old = folder Mozilla\Firefox\Profiles.old = file Mozilla\Firefox\Profiles.old = folder = can't rename is linked to something, so i go inside folder

Mozilla\Firefox\Profiles\number.default.old [my favs and passwords= account 160 mb] Mozilla\Firefox\Profiles\number.default=old 1 [was already there= 18 mb]

Registry Cleaning Rebooting the computer and then i run Advanced Systemcare over it to scan the registry As extra i run WinUtilities Professional Edition 13.0 to clean the rest of the cookies and trash Restart again and then i install Firefox Setup 50.0.2

Then i will check if the fox starts, if so i can remove the .old files

Result: Nope still wont start, see Firefox in background processes without 32bit this time. 1e is after install it supossed to start, 2nd i double clicked on desktop shortcut. 2.22 double clicked to open it, 2;27 i pressed on my bluetooth on off button on my laptop. And i see firefox moving away from background and on the bottom of the taskbar i see firefox

Import options, don't see firefox import, so import nothing It starts but it does not have my passwords and favorites And if i close it and try to start it again, guess what,, in the background again. Testing if the button was coincidence or a wake up firefox haha hahaha this is unreal, firefox opens up again after on off

I checked the net Elitebook 8460p to see what that button is for ;)

(4) Wireless light White: An integrated wireless device, such as a wireless local area network (WLAN) device and/or a Bluetooth® device, is on. Amber: All wireless devices are off.

So i can take firefox away from the background by turning wifi off then on again. Then firefox will start, no worries about my passwords and favorites. I can replace the whole morzilla folder inside roaming from 4 days ago or 1 month ago and still got the .old So guess fixing that we best leave till the end, or not ?

more options

I Think that i have fixed it, will test tomorrow if voice chat works again as well. If so then i will make a last reply to say it is fixed ;)

'What did i do ?', for those who may encounter the same thing

Bring back passwords and favorites I went into the roaming folder and copied all that was in my .old profile. Went into the new profile and did paste, replacing the folders with same names

The fix: I also had-have foxyproxy as addon, So completely disabled foxyproxy. Now i can click Firefox and it immediately starts up.

Will test tomorrow just found it, 8 in the morning, so first some sleep. Will confirm tomorrow if everything is fix now or not ;)

more options

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backups of files / folders that you choose.

OPIE {web link} Import/Export extension preferences

Firefox Environment Backup Extension Home Page {web link}

more options

No it did not work have the same problem again today. I see firefox growing in background, so i see it using more memory around 170 mb after waiting 10 min or so then i can turn wifi off and on then 2-5 minutes after fox starts.

Yesterday i looked how fox made connection to the net. about:preferences#advanced Tools\Options\Advanced\Network\Connection\Configure how Firefox connects to the Internet

Settings was "Use system proxy settings" Changed to Auto-detect proxysettings for this network.

I remember changing that when i could not get on the net, so changed it back. Then i thought it was proxy related so turned foxyproxy to enable all. And yesterday i could close firefox click it and it opened again. Today no go, so still not fixed sadly.

I clicked your profile backup tools right click open in next tab. Thought that didn't work cos nothing happened a minute after 4 tabs opened. So fox clearly still has a starting problem :(

My extentions.old is empty and my new extentions folder as well btw. So all my saved favorites and addblock stated working when i replaced the new profile with the old profile. I will have a look at one of those tools but most times when i need to work with a backup then firefox no longer works cos that win has crashed. So then i can't use these tools since they are part of firefox. That is why i use the replace profile way. That has been working for me for years ones i needed to help others to resurrect fox or when my sys crashed.

Installed FEBE ,so have to restart firefox grrr Hope i'll be able to start it again haha i no longer trust my beloved firefox to do it's job well, but will have to so logging out for now. brb i hope lol, if it takes long i'll restart to see if that helps.

PS i will set firefox to No Proxy this time to see if that helps starting it up :) No change so set it back to auto detect proxy settings. Will now enable foxyproxy to see if that has any influence since turning it off helped yesterday.

Refresh Firefox: Help\Troubleshooting Information Did a refresh firefox again, but then fox stops. I still see 1 fox running in the backround on task manager. 3,3 mb not growing in size. So i click my desktop shortcut to try to start it again. 5 min after nothing happened yet both only 3.3 mb. So off and on wireless conection, And indeed starts fresh. I need to turn on menubar and bookmarks toolbar and i see my own links. Addblock, foxyproxy are gone, so addond deactivated. Now trying restarting it again without the addons

FEBE gone as well that is what i meant when saying those tools are useless ;) But i might be able to reinstall febe and then browse to the backup that i saved. But links are in it so no need to do that now ;) Will restart to see if taking the addons away helped ;) brb

Result: Now fox still does not open have to do the wifi off on thing various times before firefox opens and it opens on a white page, then win10 apps pop up. I don't use apps don't know how to since i also don't have internet on my phone, so i never use apps. But when i try to conect to the internet youtube it takes 3 minutes to open youtube or any other website. Used proxy off, auto proxy, proxy on in fox settings to try to get it conected and after a while 3-5 min i see youtube or this page loading. So now it is even worse and will again copy my old profile info to the new profile. So my addons are back and i fix that conecting thing again because before i did not have to wait for 3-5 min to load a page ones fox was open. Thus reset only makes the problem worse.

Adding febe again so need to close firefox again. Then i will try to load the backed up file to see if Febe is of any use to me. If that wont bring back my addons then i do replace folders again from my .old profile. Results on edit ones i'm back on ;)

No that febe thing is hell to me. Now it asks me to create a new profile to put my backup on that new profile. In the past i tried such things and overwrote my excisting profile and lost all i had. So that i will never do again. Thus i will copy my .old profile files again and copy-paste it in my active profile doing replace on the folders and hope conecting ones fox runs will go fast again as it should with freaking 16 gb ram installed. That is why i spend so much extra on the ram as poor person that was a big investment, so i need to make that investment functional else it was in vain.

I did the reset because firefox is extremely slow atm and on the bottom of the page fox said do reset then it will be fast again. But that made it even slower. Before fox opened in 3 sec my whole computer starts up in 19 to 47 sec. Now pages load up as if i'm on a call in modem instead of Cable.

Back on the old profile, febe disabled and foxyproxy allow all adblock active again as well. Now it loads on startpage and if i open a new tab webpages start quickly again.

But still not fixed as starting fox needs the turn of and on of wifi and i repeated that 10+ times to get fox started. had 12 firefox running in background before it started. So not fixed yet by any means. Hope a new idea pops up as atm i also know nothing to try. So i will do hours of scanning again in the mean while. Will do all the aware and virus scans again to see if it finds new stuff. Untill i see a new reply with things i can test ;(

Okulungisiwe ngu Passie

more options

From the start again to 2nd check if i missed anything,

Turned on my 3 tb external drive as well this time

1 iExplore, Checking for processes to terminate: No issues found End running processes that might stop you from running scans-uninstalling bad programs, so first this one Rkill log can be found on the desktop

2 Kasperski TDSSKiller = nothing found 617 checked now instead of 614 but [this scan only scans WINDOWS and program files] If found logs are here: C:\TDSSKiller.

3 Adwcleaner_6.030 = No clue what to do to fix it so will try some new settings Tools\Options\Proxy selected, since i think this has to do with proxies eventhough foxyproxy is on allow all Tools\Options\Winsock was already selected, but did not do reset last time, now will After that i run the scan = nothing found If found logs are here: C:\AdwCleaner

4 SUPERAntiSpyware Scanner First it scans program files and program harddisk then it scans extra disks files, with option to scan inside zip as well. Be carefull with this as it does give false positives, thus will destroy keygens of programs as it sees them as trojan or PUP. So carefull with what you delete in this scan ! This program always finds stuff, so bet some finds are non sense. Found 8 Adware Tracking Cookies: At the end of the scan you can select and search per found item. But it ends me on google search without the filename so can't copy paste what has been found, dumb of the tool ! Tool can be found here but has no logs, C:\Program Files\SUPERAntiSpyware

Found and deleted:

At start i could not update the definitions as it said only paid members. But after the scan finished i did get the option to update definitions, so did and scanned again. Nothing detected this time

5 Malwarebytes Anti-Malware Updating database and then scan Nothing found

6 Your installed AntiVirus, Windows Defender in my case. Update definitions and scan, all scans before took 1-6 min this will take 3 hours next too Back after doing these scans on my C disk and external 3 tb disk Done the full scan only found 2 more keygens of old saved programs. And 1 keydump thing inside an old XP Client edition iso. Removed all but these were all on the external disk and not installed. Only do this so it wont bite me in the back ones fixed haha

7 Microsoft Safety Scanner Scanned 2.6 mil files took 4,30 hours = Nothing found

Tomorrow i will try to install Win 10 on portable virtualbox And then i'll try the 50.2 firefox on that as 2nd test ;) Let's see if the same happens on a fresh virtual win 10 while i wait for extra help.

Thanks for calling in some extra help, will edit ones the last scan finished :)

Okulungisiwe ngu Passie

more options

I called for more help

more options

Firefox starts again after 5 seconds, still slower then before and voice chat still did not work when i tried it. But after i tried Skype and after changing some settings Skype did work. So i will test it for some days and see if voice chat starts working again. Cleaned my pc after doing the fix and hope voice chat will work again as well. Will report later on that.

How did i finally get fox to run again ?

IE worked fine but fox would not connect unless i turned wireless off then fox plopped up and i could turn wireless on again and work on fox. Only voice chat did not work.

So it had to be proxy or how it conected related. First thought it was because of maleware social2search. But after cleaning everything i started to think it was program related. COMODO firewall came with geekbuddy that gave malewarebytes 254 maleware warnings. So i deleted it right after installing. Yet it did not completey get uninstalled.

I had to remove Comodo up to 3 times from my start\programs. Properties on my Wifi-line both showed comodo firewall driver in it.

So i started to search for a removal tool for Comodo firewall. Ran it went to my internet settings and deleted the optional function to mark comodo in my settings and restarted. Then firefox loaded again.

So NEVER EVER instal COMODO products that is an Evil company that should be brought to court ! The fix does not even come from that company but from users because that company only knows how to give users trouble but fixing their bad they leave to others. So worst company EVER ! IMHO COMODO as company should be seen as a Virus !

Please leave the topic, while i try to fix voice chat on facebook again as well, because that still does not function as it did before. I will go on trying to fix that, ant help is welcome with that. Voice chat does work with Skype so there must still be a blocked setting within firefox that blocks it. If i find the cause myself then i will post it to help readers who might encounter the same problem obviously.

Before all this i could use voice chat on fb without needing to install anything. So will first try to get it running without install. if no go after some time then i will install , FacebookVideoCallSetup_v1-2-205-0 Didn't yet as i fear that tool is ad,male,spyware as i can not find this download on the facebook page it self. And as said before this install was not needed eighter. So leaving that as last resourt.

On to clean cookies in the hope that will eradicate any traces left by that damn comodo trash tool.

This is the cleanup tool to remove that Comodo trash: Note: This tool is NOT provided by Comodo Group. Comodo Group holds no responsibility for the potential damage caused by using this tool. link text

So first they mess up our computers and then let one of their moderaters scare you by offering a fix that can damage your system even more ! I was desperate so after lots of hesitation used the fix and it seems to have partly fixed my problem. But imo what Comodo does is illegal and if i were rich then i would bring them to court to at least get compensation for all the hours of scanning and lost lifetime.

So yep sorry i am a bit angry. Thought my trouble was caused by a cild that makes trojans to tease people. But all seems to be caused by a real company that dares to think they are the best security company. Yeah that way i can provide security too, if you cause the danger the cause is known and fix easy. grrr

You know how to cause this problem firefox tech people. Install comodo firewall it comes with geekbuddy, that will pop up and force itself on you to offer help eventhough you don't ask for help. That keeps happening so you get irritated and scan your pc with malewarebytes and find 254 entries by geekbuddy. You let malewarebytes remove the trash, then it restarts , then you uninstall comodo they ask why, i replied cos of geekbuddy poping up.

Then you run malewarebytes again and it will find if i recall well 4 bad, remove it restart scan again finds 1 remove restart scan and clean. Then use the scans from fox support helper and you will find a browsermodifer.trojan as read above. Then first you can't get on the net at all so need to reset winsock i even reset the connection after modemname [2] was connected device, but fox will no longer run then.

Run the moderator his tool to uninstall leftovers select geekbudy then 2nd scan firewall cleanup, then 3th run to see if non was left and fox will conect again and internet no longer is on [2] but you run on your normal connection again. So if your curious and want to recreate the error in a virtual win as example for testing purposes, that is how you mess it up.

I uninstalled comodo with iobit uninstaller because that does a deep scan after uninstall t make sure everything is gone. So i also keep that in account. Could be that only the uninstaller by comodo can do a tidy uninstall and iobit uninstaller is partly to blame. But still uninstallers should all work the same way all use windows functions only have different look gui ;) And if a program just gave you 254 adware trash then to me it is not wise to touch even the uninstall part of such a program. As ones i find trash that comes from a program then to me that whole program becomes a Virus. So then i will use an tool from a save company not from the infection giving company.

Okulungisiwe ngu Passie

more options

Voicechat on facebook is still not working. But Firefox starts, so figure it will be best to make a new question for that problem. Firefox will not run and voicechat will not work are 2 different questions. The cause of the problem is probably linked to this problem.

But i figure i wont get an answer to it on this question as now the help question changed to a different question. So will probably be better to look at this problem as fixed and i add a new question to ask help with voice chat. Don't know how firefox deals with this on the forum. Do i need to edit my first reply and add [Solved] ? Or do i only have to click solved above edit reply ?

Okulungisiwe ngu Passie

more options

Isisombululo Esikhethiwe

Asking a new question about voice chat would be best.

Go to your response, and click the link to its right.