On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 50.0 + Mac + United States-International PC keyboard layout

  • Akukho zimpendulo
  • 1 inale nkinga
  • 11 views
more options

I noticed a bug with apostrophes on my OS X El Capitan. When I try to type a word like "don't" Firefox shows "don'" and ignores the press of the T key.

Worth to mention I use the "United States-International PC" keyboard layout because I use Latin characters like áàéíóú in my language.

It means that when I need to type a word like "café" I have to type c-a-f-'-e and the OS will automatically knows I want to type "é".

In any other browser or app, when I write "don't" it knows I'm typing an apostrophe and when I type "café" it knows I'm typing an acute accent. But not in Firefox.

If I use the keyboard layout "United States" (not international), the apostrophe works normally.

I tried removing language packs, dictionaries and disabling spelling and nothing worked. I ran Firefox in safe mode (add-ons disabled) and the problem still happens. Looks like it's an incompatibility between Firefox 50 and United States-International PC keyboard layout. I don' know if it happens in Windows or Linux.

I noticed a bug with apostrophes on my OS X El Capitan. When I try to type a word like "don't" Firefox shows "don'" and ignores the press of the T key. Worth to mention I use the "United States-International PC" keyboard layout because I use Latin characters like áàéíóú in my language. It means that when I need to type a word like "café" I have to type c-a-f-'-e and the OS will automatically knows I want to type "é". In any other browser or app, when I write "don't" it knows I'm typing an apostrophe and when I type "café" it knows I'm typing an acute accent. But not in Firefox. If I use the keyboard layout "United States" (not international), the apostrophe works normally. I tried removing language packs, dictionaries and disabling spelling and nothing worked. I ran Firefox in safe mode (add-ons disabled) and the problem still happens. Looks like it's an incompatibility between Firefox 50 and United States-International PC keyboard layout. I don' know if it happens in Windows or Linux.