Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FoxNews requires JavaScript to play videos, Firefox 50 may have turned off Java Quick Starter and can't play videos

  • 15 uphendule
  • 5 zinale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu MozillaQ

more options

Extensions info says can't verify certificate so disabled. I'm running Windows XP SP3 on Lenovo IBM T60.

All Replies (15)

more options
more options

Didn't know the distinctions in programs of similar name, that's helpful but wondering how to solve the problem of Firefox 50 allowing JavaScript to function so videos play as they did before I updated Firefox several days ago. Also, the ads prior to the videos play but the following video has a curved arrow that continues to rotate in a small circle ie never finishes loading/ playing.

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.


As a test, disable your flash and ad blockers.

more options

Didn't understand Hot Key line, did get to Add-ons Manager and Plug Ins. Shock Wave and Adobe Acrobat were able to be updated successfully earlier yesterday/ today so they read Always Activate, Quicktime 7.7.6.0 and Silverlight 5.1.30514.0 read Ask to Activate because they're older but all that's available for XP. The location of JavaScript is in Extensions and still is disabled by Firefox. Can I enable, get a Cert acceptable to Firefox, download a certified JavaScript etc? Did the left click on address symbol, clicked Permissions button and found all listed items checked Default, JavaScript not included because its not a plug-in but appears in Firefox Extensions, not shown in left click list.

Okulungisiwe ngu MozillaQ

more options

JavaScript is built into Firefox. The JavaScript you see in the Add-ons Manager is from Adobe and is disabled because of security concerns.


A Hot Key is a combination of keys that you can press to do something or go somewhere without having to go thru any menus.

In the above instruction; <Control>(Mac=<Command>) <Shift> A)

Hold down the <Control> key. Or if you're on a Mac, the <Command> key. Then press the A. This opens the Add-ons Manager.


Forgot to add; In the above you must also hold down the <Shift> key to open the Main manager window. Without opens the manager in a sidebar.

Okulungisiwe ngu FredMcD

more options

Thanks for deciphering the Hot Key commands, I've never owned/ operated a Mac and didn't realize that that was what was being referred to. Main Q: if JavaScript is built into FireFox and FoxNews is it always on? need to be turned on? etc

more options

Hi   !
Would you do this please:
Type in the address bar:   about:config (promise to be careful) Type   javascript and look for   javascript.enabled make sure it's value is set to   true

Also take a look at:
https://helpx.adobe.com/x-productkb/multi/enable-javascript.html

more options

Can you give a link to a specific page where you get an error message about JavaScript and indicate where it appears, for example, large banner across the top, popup message, in a placeholder where you expect the video to appear, etc.

As a Windows XP user, you probably know that with more and more sites going to an HTML5 media player and some no longer offering an alternate Flash version, the number of sites on which you can watch video in Firefox is shrinking. (Because Firefox's HTML5 video player needs the Microsoft Media Foundation to decode MP4 video and Microsoft only released it for Vista and newer.) If this is the problem on Fox News, they may be losing another viewer... but you also could check out this workaround (I haven't tried it myself): http://www.msfn.org/board/topic/175591-enable-mp4-h264-aac-html5-video-in-firefox-on-windows-xp-without-flash/

Or it could be something else completely.

more options

I don't know if this relates to the problem with FOX News videos that you are having, but see my answer here - https://support.mozilla.org/en-US/questions/1147860#answer-938308

There's something wrong with the FOX News website videos, and it seems to be a lot worse in Firefox 50 than in the older versions that also tested there this morning.

more options
more options

Thanks for all the suggestions, I just got home and tried the "about: config" where I found "javascript.enabled= true" and "Help>about Firefox (XP)" as "50.0 up to date". Also just tried youtube where I played music and a Trey Gowdy Benghazi hearing perfectly. p.s. Almost forgot to say there was never a banner/ message saying JavaScript wasn't working properly, I got that info from FoxNews "Contact Us> videos not playing" where it said problems are usually due to software and browser issues, and that I should ensure that JavaScript was enabled, clear cache and cookies, then reboot if nothing else works. Not sure about clearing cookies and cache in Firefox , knew how to do that in Explorer. My Norton 360 and IBM ThinkVantage clear a lot when I use ThinkVantage to "Clean my hard drive".

Okulungisiwe ngu MozillaQ

more options

Cache & Cookies:

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

more options

Thanks for the multiple ways of removing cookies, fun to try. However, nothing better regarding main issue of playing Fox News videos.

more options

Did you already test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart. (Flash isn't disabled in Safe Mode.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Hadn't tried that technique before, but did just now with no change in results. I've emailed Fox News support the 3rd time, they say they're working on my problem. I told them until they fix issue, I've started going to youtube and playing Fox News videos there so I can keep up somewhat with the news, though its not the same or as up to date.