X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"Firefox is installing components needed to play audio or video..."

Kuphostiwe

I have a clean basic install of Windows 7 64 bit Pro. It is completely up to date. New install of Firefox 49.

When going to Netflix I get the message

"Firefox is installing components needed to play audio or video..."

but never completes. If I try to run a netflix video my pc crashes, won't reboot until I do a power off.

The desired videos play on Netflix in IE fine.

I have NO antivirus running, FF is set to auto update.

Any ideas ?

I have a clean basic install of Windows 7 64 bit Pro. It is completely up to date. New install of Firefox 49. When going to Netflix I get the message "Firefox is installing components needed to play audio or video..." but never completes. If I try to run a netflix video my pc crashes, won't reboot until I do a power off. The desired videos play on Netflix in IE fine. I have NO antivirus running, FF is set to auto update. Any ideas ?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 23.0 r0
  • 5.1.50901.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4246 izisombululo 59405 izimpendulo
Kuphostiwe

Are you using any player programs like VLC, Real Player . . . . . . .  ??

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link} Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder.
https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory.

Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done.


If there is a problem, start your Computer in safe mode and try again.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Are you using any player programs like VLC, Real Player . . . . . . . ?? Let’s do a full clean re-install; '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link} Save the file. Then '''Close Firefox.''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows:''' C:\Program Files C:\Program Files (x86) '''Mac:''' Open the "Applications" folder.<br>https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux:''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install [https://support.mozilla.org/en-US/kb/install-firefox-linux Firefox on Linux]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page,] simply remove the folder Firefox in your home directory. '''Do Not''' remove the profiles folder. Look for, and rename any '''Mozilla''' or '''Firefox''' program folders by adding '''.old''' to them. Do not rename the '''Mozilla Thunderbird''' folder if there is one. After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. --------- If there is a problem, start your '''Computer''' in safe mode and try again. '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Umnikazi wombuzo

To put in perspective, I am a computer engineer doing technical work for 30 years.

All the basic steps I have already taken.

I have a clean install of Win 7 on a new unit that I just assembled. ASUS mobo, Skylake 6700K cpu, Samsung SSD, all top quality parts.

I have no funky software such as anti virus or additional firewall that might interfere with downloads.

I down loaded the full off line package for Firefox and did the install. I created a new default user account. This is a process I have done at work , literally thousands of times over the years since what I do is set up new work stations for my large organization.

Up until now this process has always worked.

I use ghost imaging software, so when I ran into the problem , I just rolled back my image to just before I did the FF install and tried again, same result.

My guess is either something has changed in FF or something has changed at NetFlix regarding DRM utilizing the new CDM mechanism. Honestly I believe it is a bug, since I have followed the same steps thousands of time prior over the years.

I have no problems with FF on any other site , such as You tube and the Netflix works fine with IE, so the problem is specifically the FF / Netflix interaction and trying to get whatever components are needed for that particular site.

If you have any other ideas I welcome them. All input is appreciated.

To put in perspective, I am a computer engineer doing technical work for 30 years. All the basic steps I have already taken. I have a clean install of Win 7 on a new unit that I just assembled. ASUS mobo, Skylake 6700K cpu, Samsung SSD, all top quality parts. I have no funky software such as anti virus or additional firewall that might interfere with downloads. I down loaded the full off line package for Firefox and did the install. I created a new default user account. This is a process I have done at work , literally thousands of times over the years since what I do is set up new work stations for my large organization. Up until now this process has always worked. I use ghost imaging software, so when I ran into the problem , I just rolled back my image to just before I did the FF install and tried again, same result. My guess is either something has changed in FF or something has changed at NetFlix regarding DRM utilizing the new CDM mechanism. Honestly I believe it is a bug, since I have followed the same steps thousands of time prior over the years. I have no problems with FF on any other site , such as You tube and the Netflix works fine with IE, so the problem is specifically the FF / Netflix interaction and trying to get whatever components are needed for that particular site. If you have any other ideas I welcome them. All input is appreciated.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59405 izimpendulo
Kuphostiwe

I called for more help.

I called for more help.

Umnikazi wombuzo

Thanks , any support is appreciated.

This morning the problem has changed slightly in that the message of downloading components is no longer appearing when I log in to Netflix.

So I tried a video, and my system hard crashed again and kept cycling unto I did a power down.

So I am moving towards a video driver issue. Perhaps when the vids are running on IE they might be using a different mechanism, such as silverlight, which invokes the driver in a different mode.

The details - no graphics card, just using the CPU embedded graphics,

Skylake 6700k - not overclocked, running Intel HD 530 graphics.

Driver is from Intel -date 2016.10.07 version 21.20.16.4534 On panel - ASUS PB277Q 27" 1ms (GTG) TN Panel Widescreen LCD/LED Monitor with a HDMI cable

Resolution set to 2560 x 1440 @75 hz

I've tried a few different resolutions but no change, crashes every time.

=========================

On a related note, I tried to find my own question by looking for it on the search box with a few key words, but it doesn't show up, so I am wondering how you even found it.

=========================

Thanks

Thanks , any support is appreciated. This morning the problem has changed slightly in that the message of downloading components is no longer appearing when I log in to Netflix. So I tried a video, and my system hard crashed again and kept cycling unto I did a power down. So I am moving towards a video driver issue. Perhaps when the vids are running on IE they might be using a different mechanism, such as silverlight, which invokes the driver in a different mode. The details - no graphics card, just using the CPU embedded graphics, Skylake 6700k - not overclocked, running Intel HD 530 graphics. Driver is from Intel -date 2016.10.07 version 21.20.16.4534 On panel - ASUS PB277Q 27" 1ms (GTG) TN Panel Widescreen LCD/LED Monitor with a HDMI cable Resolution set to 2560 x 1440 @75 hz I've tried a few different resolutions but no change, crashes every time. ===================================== On a related note, I tried to find my own question by looking for it on the search box with a few key words, but it doesn't show up, so I am wondering how you even found it. ===================================== Thanks
FredMcD
  • Top 10 Contributor
4246 izisombululo 59405 izimpendulo
Kuphostiwe

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


sparky772 said

I tried to find my own question by looking for it on the search box

What search box were you using?

'''Note: Windows users''' should download the '''active_x''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the '''plugin only.''' Not the '''active_x.''' ------------- See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---------------------- ''sparky772 [[#answer-937524|said]]'' <blockquote> I tried to find my own question by looking for it on the search box </blockquote> What search box were you using?

Umnikazi wombuzo

  1. 1 - I checked with Intel and I have the latest video driver.
  2. 2 - I have the current FLASH player.
  3. 3 - Per the article cited above, I turned off WebGL and Hardware acceleration.

I am still getting the crash.

The most common cause in my experience for a unit crashing this way and then cycling on reboot is that the vid card is trying to enter some mode that it can't support hence the repeated cycling. I'm convinced that some how , FF when trying to play these Netflix vids is trying to enter some unsupported mode.

But the players are Netflix, Intel vid driver , FF, flash player. Somewhere in the process one of the players is requesting my video take some action that is problematic.

But I am at a loss as to what that can be, or what I can turn off .

=============================

The search box I was referring to is the one that appears at the top of the mozilla support page. Upper right, corner , box rouned ends, with the words SEARCH MOZILLA SUPPORT and a magnifer icon.

I just thought it odd that I can't find my own question.

#1 - I checked with Intel and I have the latest video driver. #2 - I have the current FLASH player. #3 - Per the article cited above, I turned off WebGL and Hardware acceleration. I am still getting the crash. The most common cause in my experience for a unit crashing this way and then cycling on reboot is that the vid card is trying to enter some mode that it can't support hence the repeated cycling. I'm convinced that some how , FF when trying to play these Netflix vids is trying to enter some unsupported mode. But the players are Netflix, Intel vid driver , FF, flash player. Somewhere in the process one of the players is requesting my video take some action that is problematic. But I am at a loss as to what that can be, or what I can turn off . ========================================= The search box I was referring to is the one that appears at the top of the mozilla support page. Upper right, corner , box rouned ends, with the words SEARCH MOZILLA SUPPORT and a magnifer icon. I just thought it odd that I can't find my own question.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59405 izimpendulo
Kuphostiwe

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx29
In the address bar, type '''about:crashes'''<enter>.''' Note:''' If any reports do not have '''BP''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data.''' '''We need the report numbers to see the whole report.''' Using your mouse, '''mark''' the most '''resent 7 - 10''' crash reports, and '''copy''' them. Now go to the reply box below and '''paste''' them in. (Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.) ;[[Image:aboutcrashesFx29|width=500]]