X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox stops responding and just keeps buffering. I have to close it down and reopen it to use it again. FF48 OK but not FF49 or FF50.

Kuphostiwe

FF48 was working well. I updated to FF49 and experienced the first episodes of FF not responding. Didn't change anything but just rolled back to FF48. All was fine again. When FF50 released, I updated and experienced the same thing -- FF not responding. Again, did not change a thing but rolled it back to FF48 and all is fine again.

FF49 and FF50 go into this unresponsive mode after I either view a flash program or view something on YOUTUBE. Again -- this does not happen in FF48.

This "not responding" registers as an application hang in the windows system -- event id 1002. It does not show up as a crash and does not generate a crash report.

I am running in Windows 10 64bit.

FF48 was working well. I updated to FF49 and experienced the first episodes of FF not responding. Didn't change anything but just rolled back to FF48. All was fine again. When FF50 released, I updated and experienced the same thing -- FF not responding. Again, did not change a thing but rolled it back to FF48 and all is fine again. FF49 and FF50 go into this unresponsive mode after I either view a flash program or view something on YOUTUBE. Again -- this does not happen in FF48. This "not responding" registers as an application hang in the windows system -- event id 1002. It does not show up as a crash and does not generate a crash report. I am running in Windows 10 64bit.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • Citrix Online App Detector Plugin
  • Shockwave Flash 23.0 r0
  • 5.1.50901.0
  • WildTangent Games App V2 Presence Detector
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hi supportneeded,

I understand that Firefox has been downgraded due to a start up hang. I am happy to help.

Please respond with the results of the following troubleshooting steps: Firefox hangs or is not responding - How to fix I would pay particular attention to the section about the antivirus software and the Firefox Refresh instructions.

Hi supportneeded, I understand that Firefox has been downgraded due to a start up hang. I am happy to help. Please respond with the results of the following troubleshooting steps: [[Firefox hangs or is not responding - How to fix]] I would pay particular attention to the section about the antivirus software and the Firefox Refresh instructions.

Umnikazi wombuzo

FF49 and FF50 do not hang on start up. They hang after I access a program that requires flash or when I view something on YOUTUBE.

I am up to date on my flash and all other plugins.

Again -- I do not change A THING -- NOTHING -- no refresh -- NOTHING when I roll back to FF48 and everything works fine.

When I am rolled back to FF48 I can view flash programs and YOUTUBE without incident.

If I update to FF49 or FF50 -- Firefox hangs with the message that Firefox is not responding and I have to close it.

So -- something is different between the FF48 version and the more recent versions -- FF49 and FF50.

Why else would it work fine in FF48 and not in FF49 or FF50.

FF49 and FF50 do not hang on start up. They hang after I access a program that requires flash or when I view something on YOUTUBE. I am up to date on my flash and all other plugins. Again -- I do not change A THING -- NOTHING -- no refresh -- NOTHING when I roll back to FF48 and everything works fine. When I am rolled back to FF48 I can view flash programs and YOUTUBE without incident. If I update to FF49 or FF50 -- Firefox hangs with the message that Firefox is not responding and I have to close it. So -- something is different between the FF48 version and the more recent versions -- FF49 and FF50. Why else would it work fine in FF48 and not in FF49 or FF50.
Wesley Branton
  • Top 10 Contributor
582 izisombululo 4952 izimpendulo
Kuphostiwe

Firefox has slowly been rolling out a new feature called e10s, in order to increase performance and security. It is only enabled on systems that reach certain criteria and may still have some bugs in it.

Although it will improve over time, perhaps this feature is causing your performance issues?

You can see if this feature is enabled by navigating to about:support in your Firefox address bar. This will open your browser's troubleshooting details. The Multiprocess Windows field will tell you if e10s is enabled on your system.

A value of 1/1 means that it is enabled, while a value of 0/1 means that it is disabled. Please let us know what value your troubleshooting information displays.

Thanks.

Firefox has slowly been rolling out a new feature called '''e10s''', in order to increase performance and security. It is only enabled on systems that reach certain criteria and may still have some bugs in it. Although it will improve over time, perhaps this feature is causing your performance issues? You can see if this feature is enabled by navigating to <code>about:support</code> in your Firefox address bar. This will open your browser's troubleshooting details. The ''Multiprocess Windows'' field will tell you if e10s is enabled on your system. A value of <code>1/1</code> means that it is enabled, while a value of <code>0/1</code> means that it is disabled. Please let us know what value your troubleshooting information displays. Thanks.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

If it is on, and the Flash plugin is on and up to date, it is possible to disable e10s until Napi plugins are not longer supported in two more releases.

Or I can recommend trying the beta version of Firefox or Firefox Developer Mode in the meantime.

In order to change your Firefox Configuration please do the following:

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config "This might void your warranty!" warning page may appear.
    Click I accept the risk! to continue to the about:config page.
  3. Search for e10s and set extensions.e10sBlocksenabling to false.
  4. Restart Firefox.
If it is on, and the Flash plugin is on and up to date, it is possible to disable e10s until Napi plugins are not longer supported in two more releases. Or I can recommend trying the beta version of Firefox or Firefox Developer Mode in the meantime. In order to change your Firefox Configuration please do the following: # In the [[Awesome Bar - Search your Firefox bookmarks, history and tabs from the address bar|address bar]], type '''about:config''' and press the '''Enter''' key. # The about:config "''This might void your warranty!''" warning page may appear.<br> Click '''I accept the risk!''' to continue to the about:config page. #Search for e10s and set extensions.e10sBlocksenabling to false. #Restart Firefox.

Umnikazi wombuzo

On the trouble shooting page, my multi-process Windows field: 0/2 Disabled.

On the trouble shooting page, my multi-process Windows field: 0/2 Disabled.

Umnikazi wombuzo

Not sure if it is relevant, but on the trouble shooting page when I am in FF50 my multi-process I see -- Windows field: 0/1 (Disabled by add-ons)

Obviously slightly different than the one I listed in my last reply which was taken when I was in FF48: 0/2 Disabled.

Again -- not sure if the difference is relevant.

Not sure if it is relevant, but on the trouble shooting page when I am in FF50 my multi-process I see -- Windows field: 0/1 (Disabled by add-ons) Obviously slightly different than the one I listed in my last reply which was taken when I was in FF48: 0/2 Disabled. Again -- not sure if the difference is relevant.

Umnikazi wombuzo

I just went into about:config and set extensions.e10sBlocksenabling to false.

It was set to true.

I just went into about:config and set extensions.e10sBlocksenabling to false. It was set to true.

Umnikazi wombuzo

OK -- looks like doing the about:config change for the extensions.e10sBlocksenabling to false WORKED.

I'm in FF50 -- watched a flash program and watched a YOUTUBE and everything is working fine.

In my Troubleshooting windows the value for the multi-process windows is now 1/1 (Enabled by default).

Fingers crossed that it is now all OK.

OK -- looks like doing the about:config change for the extensions.e10sBlocksenabling to false WORKED. I'm in FF50 -- watched a flash program and watched a YOUTUBE and everything is working fine. In my Troubleshooting windows the value for the multi-process windows is now 1/1 (Enabled by default). Fingers crossed that it is now all OK.
Wesley Branton
  • Top 10 Contributor
582 izisombululo 4952 izimpendulo
Kuphostiwe

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

Umnikazi wombuzo

I waited to respond on purpose. I wanted to give a few days to make sure all worked well. I applied the about:config fix to another computer as well. Both are responding beautifully!!! FF is now a pleasure to use -- fast, responsive and solid. Our household is thrilled...

I waited to respond on purpose. I wanted to give a few days to make sure all worked well. I applied the about:config fix to another computer as well. Both are responding beautifully!!! FF is now a pleasure to use -- fast, responsive and solid. Our household is thrilled...

Umnikazi wombuzo

Thought things were great and I am now experiencing complete FF freezes. The only was I can close FF is to end task in task manager and then open FF again and then I can use it again.

All freezes show up as application errors -- 1002 and 1000.

1002 is FF50 stopped responding.

1000 is faulting module mozglue.dll

First freeze I was in my comcast email account.

After that I was typing a response to you.

Drag

Thought things were great and I am now experiencing complete FF freezes. The only was I can close FF is to end task in task manager and then open FF again and then I can use it again. All freezes show up as application errors -- 1002 and 1000. 1002 is FF50 stopped responding. 1000 is faulting module mozglue.dll First freeze I was in my comcast email account. After that I was typing a response to you. Drag

Umnikazi wombuzo

Had to roll back to FF48 -- FF became unusable... kept freezing. So strange -- it was fabulous for days in FF50 with the about:config fix. I wonder what happened.

Had to roll back to FF48 -- FF became unusable... kept freezing. So strange -- it was fabulous for days in FF50 with the about:config fix. I wonder what happened.

Umnikazi wombuzo

If it helps -- when I was in FF50 ... it looked like one tab at a time was crashing. I had two listings for FF in the task manager. One was in the Apps section and the other one was in background processes. At first I was ending the one in Apps and it would shut FF down completely.

I then tried ending the FF task that showed up in the background process and that would show that one of the opened tabs had crashed but left the rest of the tabs open and I could continue on FF.

Then it kept happening -- FF would freeze, I would end the background process in task manager and another tab was shown to have crashed.

I have no idea if FF would have kept crashing until all but one tab was left open -- that was when I bailed and rolled back to FF48.

If it helps -- when I was in FF50 ... it looked like one tab at a time was crashing. I had two listings for FF in the task manager. One was in the Apps section and the other one was in background processes. At first I was ending the one in Apps and it would shut FF down completely. I then tried ending the FF task that showed up in the background process and that would show that one of the opened tabs had crashed but left the rest of the tabs open and I could continue on FF. Then it kept happening -- FF would freeze, I would end the background process in task manager and another tab was shown to have crashed. I have no idea if FF would have kept crashing until all but one tab was left open -- that was when I bailed and rolled back to FF48.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

So this is what I believe to be happening. You are correct to highlight that there were two processes before the about:config entry was changed in Firefox 50. What this did was turn off e10s multiprocessing entirely, however it also reverted to some of the issues that motivated the multi process feature to begin with: the freezing plugins causing the who browser to freeze up instead of just tabs and then also plugin processes independent....

Anyway let's keep that config to true for now since it will be default soon enough.

Second what this also says is that we may need some alternatives to watch Youtube. ^This I may ask for some help from Wesley as well :-)

An add on is blocking e10s from turning on for your particular profile, that is why in 50 on the about support page it gives that reason for it being disabled for the profile.

Two ideas: please change your plugins for watching youtube to "always ask" if you decide to try 50 again. If it freezes while the plugin is disabled, then we know it might not be the Adobe Flash Player. (First make sure it is up to date) However if the opposite is true and you need flash player to watch youtube (which really you do not), try to disable the hardware acceleration to disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem?

Last tid-bit and sorry for so many steps, does safe mode (this disables addons) have no more freezing as well? Troubleshoot Firefox issues using Safe Mode

So this is what I believe to be happening. You are correct to highlight that there were two processes before the about:config entry was changed in Firefox 50. What this did was turn off e10s multiprocessing entirely, however it also reverted to some of the issues that motivated the multi process feature to begin with: the freezing plugins causing the who browser to freeze up instead of just tabs and then also plugin processes independent.... Anyway let's keep that config to true for now since it will be default soon enough. Second what this also says is that we may need some alternatives to watch Youtube. ^This I may ask for some help from Wesley as well :-) An add on is blocking e10s from turning on for your particular profile, that is why in 50 on the about support page it gives that reason for it being disabled for the profile. Two ideas: please change your plugins for watching youtube to "always ask" if you decide to try 50 again. If it freezes while the plugin is disabled, then we know it might not be the Adobe Flash Player. (First make sure it is up to date) However if the opposite is true and you need flash player to watch youtube (which really you do not), try to disable the hardware acceleration to disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.adobe.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Last tid-bit and sorry for so many steps, does safe mode (this disables addons) have no more freezing as well? [[Troubleshoot Firefox issues using Safe Mode]]

Umnikazi wombuzo

I do have "always ask" for the flash player.

It is up to date.

I do not have a check mark on hardware acceleration. I changed that a long time ago.

I can still roll back to FF48 and everything works well again.

In FF48 multi-process windows are once again 0/2 disabled and the extensionsblockenabling is still false (from the change I made a few days ago).

What is so weird is that FF50 was FABULOUS for a couple of days. I was able to watch flash programs and YOUTUBE -- no issues. Then today -- it was like someone threw a switch and it started freezing. I was in email at the time -- I don't remember even using flash player for anything. Def did not go to YOUTUBE.

This new behavior is the entire FF freezing -- not a "buffering not responding message" -- it is a total freeze. I can't even shut it down by clicking on the X in the corner. The only way to close it is in the task manager.

I do have "always ask" for the flash player. It is up to date. I do not have a check mark on hardware acceleration. I changed that a long time ago. I can still roll back to FF48 and everything works well again. In FF48 multi-process windows are once again 0/2 disabled and the extensionsblockenabling is still false (from the change I made a few days ago). What is so weird is that FF50 was FABULOUS for a couple of days. I was able to watch flash programs and YOUTUBE -- no issues. Then today -- it was like someone threw a switch and it started freezing. I was in email at the time -- I don't remember even using flash player for anything. Def did not go to YOUTUBE. This new behavior is the entire FF freezing -- not a "buffering not responding message" -- it is a total freeze. I can't even shut it down by clicking on the X in the corner. The only way to close it is in the task manager.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

I am really sorry that I gave the wrong information before. Turning off e10s is not a great long term or short term help.

However I learned from the community that there is an addon compatibility addon you can try to see if it is one of the addons that might be installed. If you turn one on or off one at a time we can report the one that might be causing issues. https://addons.mozilla.org/firefox/ad.../add-on-compatibility-reporter/

I am really sorry that I gave the wrong information before. Turning off e10s is not a great long term or short term help. However I learned from the community that there is an addon compatibility addon you can try to see if it is one of the addons that might be installed. If you turn one on or off one at a time we can report the one that might be causing issues. [https://addons.mozilla.org/firefox/addon/add-on-compatibility-reporter/]

Umnikazi wombuzo

I will try the add on compatibility reporter and see what happens.

I will try the add on compatibility reporter and see what happens.

Okulungisiwe ngu supportneeded

Umnikazi wombuzo

FF50 went into not responding again after I watched a video. I have the add on compatibility reporter installed. Nothing showed up on it after I re-opened FF.

Now what?

I bet if I roll back to FF48 all will be well again.

I installed Chrome and so far it is trouble free.

What's up Firefox????

FF50 went into not responding again after I watched a video. I have the add on compatibility reporter installed. Nothing showed up on it after I re-opened FF. Now what? I bet if I roll back to FF48 all will be well again. I installed Chrome and so far it is trouble free. What's up Firefox????

Umnikazi wombuzo

Oh -- no crash report for this. It was an application hang recorded in the event viewer as an event 1002 just like before.

Oh -- no crash report for this. It was an application hang recorded in the event viewer as an event 1002 just like before.

Umnikazi wombuzo

Upgraded again to FF50 and things behaving for now. Since I didn't do a thing to any of my settings, I can only guess that you guys are tweaking things behind the scenes and whatever you did solved my issues. For now.

Upgraded again to FF50 and things behaving for now. Since I didn't do a thing to any of my settings, I can only guess that you guys are tweaking things behind the scenes and whatever you did solved my issues. For now.