Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 50 on Win10 now refuses to open local files

  • 10 uphendule
  • 11 zinale nkinga
  • 9246 views
  • Igcine ukuphendulwa ngu MisterNeutron

more options

FF50 on Win10 won't open local files, like file:///C:/Users/MN/Documents/something/index.html. It claims the file is inaccessible. No problem on macOS 10.12.1. This is VERY new behavior - I've never had this problem before. I run an application that produces web pages, and I need to preview them before uploading, so this is a MAJOR impediment. Chrome and Edge have no difficulty with this.

I believe this is being done for security reasons, but I need to be able to override it. I'll take the risk.

Isisombululo esikhethiwe

If you start from

file:///C:/

can you navigate your way to that folder? How far can you get?

For the sake of science, could you test a few other methods of opening index.html in Firefox to see whether any of them work:

  • double-click the file in Windows Explorer (if Firefox is your default browser)
  • in Windows Explorer, right-click the file > Open With (if shown)
  • drag-and-drop the file from Windows Explorer to a Firefox tab
  • in Firefox: File menu > Open File (or Ctrl+O)

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process (content processes move into plugin-container.exe). When you first install Firefox (or flush your profile), Firefox assesses whether your system is compatible with e10s and sets a flag to enable it in your next session. That could explain how the second run was different from the first, so let's check on that.

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (10)

more options

A new symptom to report. I did a clean reinstall of Firefox - even deleted the existing profiles. No import of data from any other browser. No extensions. No sync with Firefox on my macOS laptop (this is a Win10 desktop machine). Hey presto, local files could be opened once again!

Close Firefox, launch it again, and the problem is back: "Access to the file was denied / The file at /C:/Users/JT/Documents/Site/index.html is not readable. / It may have been removed, moved, or file permissions may be preventing access."

more options

Isisombululo Esikhethiwe

If you start from

file:///C:/

can you navigate your way to that folder? How far can you get?

For the sake of science, could you test a few other methods of opening index.html in Firefox to see whether any of them work:

  • double-click the file in Windows Explorer (if Firefox is your default browser)
  • in Windows Explorer, right-click the file > Open With (if shown)
  • drag-and-drop the file from Windows Explorer to a Firefox tab
  • in Firefox: File menu > Open File (or Ctrl+O)

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process (content processes move into plugin-container.exe). When you first install Firefox (or flush your profile), Firefox assesses whether your system is compatible with e10s and sets a flag to enable it in your next session. That could explain how the second run was different from the first, so let's check on that.

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

more options

Oh, you win the InterWebs for the day!!

No difference in the 4 ways of launching the page, though the drag-in, while producing the same error message, also showed an endless progress spinner in the tab.

"Multiprocess Windows" was 1/1, so "yes" to e10s.

Setting autostart2 to false appears to be the charm.

Thank you, thank you!

more options

Hmm, hopefully that is a known bug on its way to getting fixed.

I created a test profile to see whether I could navigate to a file on disk with e10s running and it worked, so there might be something a bit unusual about your Windows permissions on that folder/file that will be important to solving this issue. ??

more options

Oh, this was happening with files all over the C: drive, so it didn't seem like a permission issue (and no other browser complained about any of them). But let me do some experimenting - if I stumble onto anything interesting, I'll post back.

more options

Now this is interesting... With e10s enabled again, the failure occurs when opening any file in the Documents or Pictures library. No problem from Music, Videos, Downloads, Desktop, the root of C:, or my second internal drive, E:.

more options

I don't know why Documents or Pictures would be specially protected while the others aren't. It's purely local, not on OneDrive?

I tested on Windows 7, so I probably need to get on a Windows 10 system and try it there.

more options

Hmmm... My reply seems to have vanished.

In short, I went in and explicitly gave the Owner of Documents and Pictures all file permissions, which, strangely, were not there. Now there are no more failures opening local files, even with e10s enabled. Go figure.

more options

On Windows 7 I don't have OWNER permissions on those folders, but my login is a member of the Administrators group, so I have permission indirectly that way. I'll have to look at Windows 10 at some point to see how it's different.

more options

My login is, likewise, an Administrator account, so you would think.... but apparently not!

I sometimes wonder if anyone actually uses Windows in a multi-user environment. I certainly don't know anyone who does. All those layers of complexity may not be serving much purpose.